aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-17 01:29:09 +0800
committeraz <az@FreeBSD.org>2013-09-17 01:29:09 +0800
commite5596801d431ca5d9459342e7ff647dfc6f364ef (patch)
tree4c742a14f77ec0e3cede6ed430252f490585d7a3
parentb2f16c80b142aee00e8ed2dc542941a099d6fecc (diff)
downloadfreebsd-ports-gnome-e5596801d431ca5d9459342e7ff647dfc6f364ef.tar.gz
freebsd-ports-gnome-e5596801d431ca5d9459342e7ff647dfc6f364ef.tar.zst
freebsd-ports-gnome-e5596801d431ca5d9459342e7ff647dfc6f364ef.zip
- convert to the new perl5 framework
- remove redundant perl usage, since we use it already in global context Approved by: portmgr (bapt@, blanket)
-rw-r--r--mail/dspam-devel/Makefile3
-rw-r--r--mail/dspam/Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index cf781d2803e4..b3854ddf962d 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -87,7 +87,7 @@ WEBUI_DESC= Install WebUI, pulls in Apache or see below
OPTIONS_DEFAULT= SYSLOG DEBUG DAEMON CLAMAV CLAMAV_LOCAL MYSQL55 \
PGSQL SQLITE3 HASH
-USE_PERL5= yes
+USES= perl5
USE_AUTOTOOLS= libtool
.ifdef(SNAP_DATE)
USE_AUTOTOOLS+= autoconf:env automake
@@ -402,7 +402,6 @@ RUN_DEPENDS+= p5-GD-Graph3d>=0:${PORTSDIR}/graphics/p5-GD-Graph3d
RUN_DEPENDS+= p5-GD-TextUtil>=0:${PORTSDIR}/graphics/p5-GD-TextUtil
CONFIGURE_ARGS+=--enable-logging
CONFIGURE_ARGS+=--enable-user-logging
-USE_PERL5= yes
PLIST_SUB+= WebUI=""
_SED_SCRIPT+= -e 's/%%WebUI%%//g'
_SED_SCRIPT+= -e 's,%%WWWDIR%%,${WWWDIR},g'
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 467a9f55af3e..337d593a6344 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -73,7 +73,7 @@ OPTIONS_DEFAULT= SYSLOG DEBUG DAEMON CLAMAV CLAMAV_LOCAL \
PGSQL SQLITE3 HASH
MAKE_JOBS_UNSAFE= yes
-USE_PERL5= yes
+USES= perl5
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -381,7 +381,6 @@ RUN_DEPENDS+= p5-GD-Graph3d>=0:${PORTSDIR}/graphics/p5-GD-Graph3d
RUN_DEPENDS+= p5-GD-TextUtil>=0:${PORTSDIR}/graphics/p5-GD-TextUtil
CONFIGURE_ARGS+=--enable-logging
CONFIGURE_ARGS+=--enable-user-logging
-USE_PERL5= yes
PLIST_SUB+= WebUI=""
_SED_SCRIPT+= -e 's/%%WebUI%%//g'
_SED_SCRIPT+= -e 's,%%WWWDIR%%,${WWWDIR},g'