aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2018-01-26 03:19:57 +0800
committermadpilot <madpilot@FreeBSD.org>2018-01-26 03:19:57 +0800
commite5f1f9a5acd631938d3211aa7f64a515c47b9f26 (patch)
tree4c57cba678898cfdd56694cb47a83f7d8001841c
parent294274acc4fee3228f6123f9bd8ea341a0174e8f (diff)
downloadfreebsd-ports-gnome-e5f1f9a5acd631938d3211aa7f64a515c47b9f26.tar.gz
freebsd-ports-gnome-e5f1f9a5acd631938d3211aa7f64a515c47b9f26.tar.zst
freebsd-ports-gnome-e5f1f9a5acd631938d3211aa7f64a515c47b9f26.zip
- Update xfce4-timer-plugin to 1.7.0
- Adjust dependencies, plugin migrated to gtk3 - Strip binaries - Silence portlint warning about variables ordering
-rw-r--r--x11-clocks/xfce4-timer-plugin/Makefile8
-rw-r--r--x11-clocks/xfce4-timer-plugin/distinfo5
-rw-r--r--x11-clocks/xfce4-timer-plugin/pkg-plist12
3 files changed, 16 insertions, 9 deletions
diff --git a/x11-clocks/xfce4-timer-plugin/Makefile b/x11-clocks/xfce4-timer-plugin/Makefile
index 99d91cf2acae..5e428df7b8c5 100644
--- a/x11-clocks/xfce4-timer-plugin/Makefile
+++ b/x11-clocks/xfce4-timer-plugin/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-timer-plugin
-PORTVERSION= 1.6.0
-PORTREVISION= 1
+PORTVERSION= 1.7.0
CATEGORIES= x11-clocks xfce
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@@ -13,10 +12,11 @@ COMMENT= Timer plugin for Xfce
LICENSE= GPLv2
+USES= libtool pkgconfig gettext gmake xfce tar:bzip2
INSTALLS_ICONS= yes
+INSTALL_TARGET= install-strip
GNU_CONFIGURE= yes
-USE_GNOME= glib20 gtk20 intltool intlhack
+USE_GNOME= cairo gtk30 intltool
USE_XFCE= panel
-USES= pkgconfig gettext gmake xfce tar:bzip2
.include <bsd.port.mk>
diff --git a/x11-clocks/xfce4-timer-plugin/distinfo b/x11-clocks/xfce4-timer-plugin/distinfo
index ff7b6d63bad2..76d0171551d8 100644
--- a/x11-clocks/xfce4-timer-plugin/distinfo
+++ b/x11-clocks/xfce4-timer-plugin/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xfce4/xfce4-timer-plugin-1.6.0.tar.bz2) = 39d7d21f099bc4219f6a6156142f0bbb8374986ee1970a9c0c8dc138b87f867c
-SIZE (xfce4/xfce4-timer-plugin-1.6.0.tar.bz2) = 325662
+TIMESTAMP = 1516869040
+SHA256 (xfce4/xfce4-timer-plugin-1.7.0.tar.bz2) = 2e4e5343e39926230cc981d5fe56cd58a2f3817d2e9b6089b5673a2e39bf7e9b
+SIZE (xfce4/xfce4-timer-plugin-1.7.0.tar.bz2) = 381222
diff --git a/x11-clocks/xfce4-timer-plugin/pkg-plist b/x11-clocks/xfce4-timer-plugin/pkg-plist
index bce922607320..af47988ebda5 100644
--- a/x11-clocks/xfce4-timer-plugin/pkg-plist
+++ b/x11-clocks/xfce4-timer-plugin/pkg-plist
@@ -1,5 +1,7 @@
-libexec/xfce4/panel-plugins/xfce4-timer
-share/icons/hicolor/48x48/apps/xfce4-timer.png
+lib/xfce4/panel/plugins/libxfcetimer.so
+share/icons/hicolor/32x32/apps/xfce4-timer-plugin.png
+share/icons/hicolor/48x48/apps/xfce4-timer-plugin.png
+share/icons/hicolor/scalable/apps/xfce4-timer-plugin.svg
share/locale/ar/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/ast/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/bg/LC_MESSAGES/xfce4-timer-plugin.mo
@@ -12,14 +14,18 @@ share/locale/en_AU/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/en_GB/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/es/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/eu/LC_MESSAGES/xfce4-timer-plugin.mo
+share/locale/fi/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/fr/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/gl/LC_MESSAGES/xfce4-timer-plugin.mo
+share/locale/he/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/hr/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/hu/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/id/LC_MESSAGES/xfce4-timer-plugin.mo
+share/locale/is/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/it/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/ja/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/ko/LC_MESSAGES/xfce4-timer-plugin.mo
+share/locale/lt/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/lv/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/ms/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/nb/LC_MESSAGES/xfce4-timer-plugin.mo
@@ -41,4 +47,4 @@ share/locale/ur/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/ur_PK/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/zh_CN/LC_MESSAGES/xfce4-timer-plugin.mo
share/locale/zh_TW/LC_MESSAGES/xfce4-timer-plugin.mo
-share/xfce4/panel-plugins/xfce4-timer.desktop
+share/xfce4/panel/plugins/xfce4-timer-plugin.desktop