aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-10-24 16:29:00 +0800
committeredwin <edwin@FreeBSD.org>2007-10-24 16:29:00 +0800
commite63af8428d97af225e0ba4bf163cadfb3c912f33 (patch)
treedd84d81d1a51228ab540db5a042903874be2b902
parentee72d846d549fcaf5c3fab95a2afca4115478992 (diff)
downloadfreebsd-ports-gnome-e63af8428d97af225e0ba4bf163cadfb3c912f33.tar.gz
freebsd-ports-gnome-e63af8428d97af225e0ba4bf163cadfb3c912f33.tar.zst
freebsd-ports-gnome-e63af8428d97af225e0ba4bf163cadfb3c912f33.zip
fix index, fix check-for-distfiles-target
-rw-r--r--devel/aunit/Makefile25
-rw-r--r--devel/florist-gpl/Makefile25
2 files changed, 26 insertions, 24 deletions
diff --git a/devel/aunit/Makefile b/devel/aunit/Makefile
index da7b1536a5a2..87f655cad64c 100644
--- a/devel/aunit/Makefile
+++ b/devel/aunit/Makefile
@@ -9,7 +9,7 @@ PORTNAME= aunit
PORTVERSION= 1.05
CATEGORIES= devel
MASTER_SITES= http://libre.adacore.com/
-EXTRACT_SUFX= -src.tgz
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tgz
MAINTAINER= john_m_cooper@yahoo.com
COMMENT= AUnit is an adaption of the Java JUnit unit test framework
@@ -18,23 +18,24 @@ BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat
RUN_DEPENDS= gnatgcc:${PORTSDIR}/lang/gnat
USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
.include <bsd.port.pre.mk>
# Check for GNAT sources.
-.if !exists(${DISTDIR}/${DISTFILE}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG= ${PRINTF}
-IGNORE=Because of licensing and registration restrictions, you must fetch\n \
- the source distribution manually. Please access\n \
- http://libre.adacore.com/\ with a web browser, register\n \
- (It's free!) and log in. Download the source files:\n\n \
- \t${DISTFILE}\n\n \
- and place them in ${DISTDIR}\n
- ${ECHO_MSG} ${IGNORE}
+.if !exists(${DISTDIR}/${DISTFILES}) && !defined(PACKAGE_BUILDING)
+pre-everything::
+ @echo "Because of licensing and registration restrictions, you must"
+ @echo "fetch the source distribution manually. Please access"
+ @echo "http://libre.adacore.com/ with a web browser, register"
+ @echo "(It's free!) and log in. Download the source files:"
+ @echo
+ @echo " ${DISTFILES}"
+ @echo
+ @echo "and place them in ${DISTDIR}"
+ @exit 1
.endif
-WRKSRC= ${WRKDIR}/aunit-${PORTVERSION}-src
-
pre-build:
@${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
diff --git a/devel/florist-gpl/Makefile b/devel/florist-gpl/Makefile
index 78feb2f3a521..439d781dfeff 100644
--- a/devel/florist-gpl/Makefile
+++ b/devel/florist-gpl/Makefile
@@ -9,7 +9,7 @@ PORTNAME= florist-gpl
PORTVERSION= 2006
CATEGORIES= devel
MASTER_SITES= http://libre.adacore.com/
-EXTRACT_SUFX= -src.tgz
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tgz
MAINTAINER= john_m_cooper@yahoo.com
COMMENT= The POSIX Ada Binding
@@ -20,21 +20,22 @@ GNU_CONFIGURE= yes
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
LIBS="${PTHREAD_LIBS}"
+WRKSRC= ${WRKDIR}/florist-${PORTVERSION}-src
.include <bsd.port.pre.mk>
# Check for GNAT sources.
-.if !exists(${DISTDIR}/${DISTFILE}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG= ${PRINTF}
-IGNORE=Because of licensing and registration restrictions, you must fetch\n \
- the source distribution manually. Please access\n \
- http://libre.adacore.com/\ with a web browser, register\n \
- (It's free!) and log in. Download the source files:\n\n \
- \t${DISTFILE}\n\n \
- and place them in ${DISTDIR}\n
- ${ECHO_MSG} ${IGNORE}
+.if !exists(${DISTDIR}/${DISTFILES}) && !defined(PACKAGE_BUILDING)
+pre-everything::
+ @echo "Because of licensing and registration restrictions, you must"
+ @echo "fetch the source distribution manually. Please access"
+ @echo "http://libre.adacore.com/ with a web browser, register"
+ @echo "(It's free!) and log in. Download the source files:"
+ @echo
+ @echo " ${DISTFILES}
+ @echo
+ @echo "and place them in ${DISTDIR}"
+ @exit 1
.endif
-WRKSRC= ${WRKDIR}/florist-${PORTVERSION}-src
-
.include <bsd.port.post.mk>