aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-22 04:08:33 +0800
committerpav <pav@FreeBSD.org>2006-06-22 04:08:33 +0800
commite65cbb3f3571170499ea4e0a14da3a3f7ab60327 (patch)
treee95216693f221e9b5002ef939d56b4fc743596c0
parentde14fb1eebf51542cb172612e9bc6201b58c6105 (diff)
downloadfreebsd-ports-gnome-e65cbb3f3571170499ea4e0a14da3a3f7ab60327.tar.gz
freebsd-ports-gnome-e65cbb3f3571170499ea4e0a14da3a3f7ab60327.tar.zst
freebsd-ports-gnome-e65cbb3f3571170499ea4e0a14da3a3f7ab60327.zip
gphotofs is a FUSE filesystem module to mount your camera as a filesystem.
This allow using your camera with any tool able to read from a mounted filesystem. WWW: http://gphoto.sourceforge.net/proj/gphotofs/
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/fusefs-gphotofs/Makefile35
-rw-r--r--graphics/fusefs-gphotofs/distinfo3
-rw-r--r--graphics/fusefs-gphotofs/pkg-descr5
-rw-r--r--graphics/fusefs-gphotofs/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d19e6cb3123a..c268bd2741f0 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -140,6 +140,7 @@
SUBDIR += frontline
SUBDIR += ftgl
SUBDIR += fujiplay
+ SUBDIR += fusefs-gphotofs
SUBDIR += fv
SUBDIR += fyre
SUBDIR += g2
diff --git a/graphics/fusefs-gphotofs/Makefile b/graphics/fusefs-gphotofs/Makefile
new file mode 100644
index 000000000000..da86e59e0bf4
--- /dev/null
+++ b/graphics/fusefs-gphotofs/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gphotofs
+# Date created: 21 June 2006
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gphotofs
+PORTVERSION= 0.2
+CATEGORIES= graphics sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gphoto
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Mount PTP camera as a file system
+
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs \
+ gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+USE_BZIP2= yes
+USE_GNOME= glib20
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= depends on kernel module that requires FreeBSD 6 or later
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|USE_VERSION=22|USE_VERSION=25|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/graphics/fusefs-gphotofs/distinfo b/graphics/fusefs-gphotofs/distinfo
new file mode 100644
index 000000000000..ffc7d33aef9b
--- /dev/null
+++ b/graphics/fusefs-gphotofs/distinfo
@@ -0,0 +1,3 @@
+MD5 (gphotofs-0.2.tar.bz2) = 76940cc0bed043b90080a3f004b2dc6e
+SHA256 (gphotofs-0.2.tar.bz2) = 664f1265dcaa2d24d17052219e7883881df505edee9dde45144432f630480ca4
+SIZE (gphotofs-0.2.tar.bz2) = 72137
diff --git a/graphics/fusefs-gphotofs/pkg-descr b/graphics/fusefs-gphotofs/pkg-descr
new file mode 100644
index 000000000000..d6fbc2e36231
--- /dev/null
+++ b/graphics/fusefs-gphotofs/pkg-descr
@@ -0,0 +1,5 @@
+gphotofs is a FUSE filesystem module to mount your camera as a filesystem.
+This allow using your camera with any tool able to read from a mounted
+filesystem.
+
+WWW: http://gphoto.sourceforge.net/proj/gphotofs/
diff --git a/graphics/fusefs-gphotofs/pkg-plist b/graphics/fusefs-gphotofs/pkg-plist
new file mode 100644
index 000000000000..da1006e7ed5c
--- /dev/null
+++ b/graphics/fusefs-gphotofs/pkg-plist
@@ -0,0 +1 @@
+bin/gphotofs