aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-03-23 04:37:29 +0800
committerpav <pav@FreeBSD.org>2008-03-23 04:37:29 +0800
commite6cd31656054aee4eb9ecf3e186a1efa6b62ddee (patch)
treec253b9da3253235d2cf972ab87710b01feb46754
parent005a3ff067723ab1fb43b30b17a679c92ea48f6e (diff)
downloadfreebsd-ports-gnome-e6cd31656054aee4eb9ecf3e186a1efa6b62ddee.tar.gz
freebsd-ports-gnome-e6cd31656054aee4eb9ecf3e186a1efa6b62ddee.tar.zst
freebsd-ports-gnome-e6cd31656054aee4eb9ecf3e186a1efa6b62ddee.zip
Pocket Sphinx is a frontend to the sphinxbase large-vocabulary,
speaker-independent, continuous speech recognition engine. This is an early release of a research system. The APIs and function names are likely to change, and several tools still need to be made available to make this all complete. Once the system is built, try running the Perl script sphinx2-demo. The pocketsphinx-test script should run pocketsphinx-batch over an example utterance of "go forward ten meters." WWW: http://www.speech.cs.cmu.edu/sphinx/ PR: ports/121610 Submitted by: Richard Neese <r.neese@gmail.com>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/pocketsphinx/Makefile33
-rw-r--r--audio/pocketsphinx/distinfo3
-rw-r--r--audio/pocketsphinx/pkg-descr12
-rw-r--r--audio/pocketsphinx/pkg-plist95
5 files changed, 144 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 2abc64e1f2dc..d6f82f39b596 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -497,6 +497,7 @@
SUBDIR += play
SUBDIR += playgsf
SUBDIR += playmidi
+ SUBDIR += pocketsphinx
SUBDIR += portaudio
SUBDIR += portaudio2
SUBDIR += praat
diff --git a/audio/pocketsphinx/Makefile b/audio/pocketsphinx/Makefile
new file mode 100644
index 000000000000..635dd8446632
--- /dev/null
+++ b/audio/pocketsphinx/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: pocketsphinx
+# Date created: 3 Jan 2008
+# Whom: Richard Neese
+#
+# $FreeBSD$
+#
+
+PORTNAME= pocketsphinx
+PORTVERSION= 0.4.1
+CATEGORIES= audio accessibility
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cmusphinx
+
+MAINTAINER= r.neese@gmail.com
+COMMENT= Speech recognition system
+
+LIB_DEPENDS= sphinxfe.0:${PORTSDIR}/audio/sphinxbase
+
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/sphinxbase" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAKE_ENV= MKDIR="${MKDIR}" \
+ OSVERSION=${OSVERSION} \
+ CXX="${CXX}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/pocketsphinx/distinfo b/audio/pocketsphinx/distinfo
new file mode 100644
index 000000000000..e06883dd9f5d
--- /dev/null
+++ b/audio/pocketsphinx/distinfo
@@ -0,0 +1,3 @@
+MD5 (pocketsphinx-0.4.1.tar.gz) = 1ac25a77c82c4b33cad3ca698357ad43
+SHA256 (pocketsphinx-0.4.1.tar.gz) = 4906abc5f1eaadb036d43de692d495387791fee72b63276f0bbca02d7ef1d0cb
+SIZE (pocketsphinx-0.4.1.tar.gz) = 8931969
diff --git a/audio/pocketsphinx/pkg-descr b/audio/pocketsphinx/pkg-descr
new file mode 100644
index 000000000000..ae4c6c531ab2
--- /dev/null
+++ b/audio/pocketsphinx/pkg-descr
@@ -0,0 +1,12 @@
+Pocket Sphinx is a frontend to the sphinxbase large-vocabulary,
+speaker-independent, continuous speech recognition engine.
+
+This is an early release of a research system. The APIs and function
+names are likely to change, and several tools still need to be made
+available to make this all complete.
+
+Once the system is built, try running the Perl script sphinx2-demo.
+The pocketsphinx-test script should run pocketsphinx-batch over an example
+utterance of "go forward ten meters."
+
+WWW: http://www.speech.cs.cmu.edu/sphinx/
diff --git a/audio/pocketsphinx/pkg-plist b/audio/pocketsphinx/pkg-plist
new file mode 100644
index 000000000000..463751ddce7d
--- /dev/null
+++ b/audio/pocketsphinx/pkg-plist
@@ -0,0 +1,95 @@
+bin/pocketsphinx_batch
+bin/pocketsphinx_continuous
+bin/pocketsphinx_mdef_convert
+bin/pocketsphinx_ptt
+bin/pocketsphinx_swb
+bin/pocketsphinx_test
+bin/pocketsphinx_tidigits
+include/pocketsphinx/basic_types.h
+include/pocketsphinx/bin_mdef.h
+include/pocketsphinx/blkarray_list.h
+include/pocketsphinx/cache_lm.h
+include/pocketsphinx/cmdln_macro.h
+include/pocketsphinx/dict.h
+include/pocketsphinx/fbs.h
+include/pocketsphinx/fsg_history.h
+include/pocketsphinx/fsg_lextree.h
+include/pocketsphinx/fsg_psubtree.h
+include/pocketsphinx/fsg_search.h
+include/pocketsphinx/hmm.h
+include/pocketsphinx/kb.h
+include/pocketsphinx/kdtree.h
+include/pocketsphinx/lm.h
+include/pocketsphinx/lm_3g.h
+include/pocketsphinx/lmclass.h
+include/pocketsphinx/log.h
+include/pocketsphinx/magic.h
+include/pocketsphinx/mdef.h
+include/pocketsphinx/phone.h
+include/pocketsphinx/posixwin32.h
+include/pocketsphinx/s2_semi_mgau.h
+include/pocketsphinx/s2io.h
+include/pocketsphinx/s2params.h
+include/pocketsphinx/s2types.h
+include/pocketsphinx/search.h
+include/pocketsphinx/search_const.h
+include/pocketsphinx/senscr.h
+include/pocketsphinx/subvq_mgau.h
+include/pocketsphinx/tmat.h
+include/pocketsphinx/vector.h
+include/pocketsphinx/word_fsg.h
+lib/libpocketsphinx.a
+lib/libpocketsphinx.la
+lib/libpocketsphinx.so
+lib/libpocketsphinx.so.0
+libdata/pkgconfig/pocketsphinx.pc
+%%DATADIR%%/model/hmm/an4/mdef
+%%DATADIR%%/model/hmm/an4/mixture_weights
+%%DATADIR%%/model/hmm/an4/subvq
+%%DATADIR%%/model/hmm/an4/transition_matrices
+%%DATADIR%%/model/hmm/tidigits/feat.params
+%%DATADIR%%/model/hmm/tidigits/mdef
+%%DATADIR%%/model/hmm/tidigits/means
+%%DATADIR%%/model/hmm/tidigits/sendump
+%%DATADIR%%/model/hmm/tidigits/transition_matrices
+%%DATADIR%%/model/hmm/tidigits/variances
+%%DATADIR%%/model/hmm/wsj1/feat.params
+%%DATADIR%%/model/hmm/wsj1/kdtrees
+%%DATADIR%%/model/hmm/wsj1/mdef
+%%DATADIR%%/model/hmm/wsj1/means
+%%DATADIR%%/model/hmm/wsj1/noisedict
+%%DATADIR%%/model/hmm/wsj1/sendump
+%%DATADIR%%/model/hmm/wsj1/transition_matrices
+%%DATADIR%%/model/hmm/wsj1/variances
+%%DATADIR%%/model/lm/swb/swb.dic
+%%DATADIR%%/model/lm/swb/swb.lm.DMP
+%%DATADIR%%/model/lm/tidigits/an4.dic
+%%DATADIR%%/model/lm/tidigits/an4.ug.lm
+%%DATADIR%%/model/lm/tidigits/an4.ug.lm.DMP
+%%DATADIR%%/model/lm/tidigits/test.digits.fsg
+%%DATADIR%%/model/lm/tidigits/tidigits.dic
+%%DATADIR%%/model/lm/tidigits/tidigits.lm
+%%DATADIR%%/model/lm/tidigits/tidigits.lm.DMP
+%%DATADIR%%/model/lm/turtle/README
+%%DATADIR%%/model/lm/turtle/goforward.16k
+%%DATADIR%%/model/lm/turtle/turtle.cor
+%%DATADIR%%/model/lm/turtle/turtle.corpus
+%%DATADIR%%/model/lm/turtle/turtle.ctl
+%%DATADIR%%/model/lm/turtle/turtle.dic
+%%DATADIR%%/model/lm/turtle/turtle.handdict
+%%DATADIR%%/model/lm/turtle/turtle.lm
+%%DATADIR%%/model/lm/turtle/turtle.lm.DMP
+%%DATADIR%%/model/lm/turtle/turtle.sent
+%%DATADIR%%/model/lm/turtle/turtle.token
+%%DATADIR%%/model/lm/turtle/turtle.vocab
+@dirrm %%DATADIR%%/model/lm/turtle
+@dirrm %%DATADIR%%/model/lm/tidigits
+@dirrm %%DATADIR%%/model/lm/swb
+@dirrm %%DATADIR%%/model/lm
+@dirrm %%DATADIR%%/model/hmm/wsj1
+@dirrm %%DATADIR%%/model/hmm/tidigits
+@dirrm %%DATADIR%%/model/hmm/an4
+@dirrm %%DATADIR%%/model/hmm
+@dirrm %%DATADIR%%/model
+@dirrm %%DATADIR%%
+@dirrm include/pocketsphinx