aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-31 06:58:38 +0800
committeradamw <adamw@FreeBSD.org>2014-08-31 06:58:38 +0800
commite77db74b0c2c3e11029af0e37781e153b19c3008 (patch)
treee4924070bb21f93cc53ff7b2cd5a98c3e935cce7
parent16f72a066f58a0f92b198094819baf557f5809b1 (diff)
downloadfreebsd-ports-gnome-e77db74b0c2c3e11029af0e37781e153b19c3008.tar.gz
freebsd-ports-gnome-e77db74b0c2c3e11029af0e37781e153b19c3008.tar.zst
freebsd-ports-gnome-e77db74b0c2c3e11029af0e37781e153b19c3008.zip
Fix build on -current.
This is an ugly fix, and makes some assumptions, but necessary as Uses/readline.mk doesn't export which path it's using, it just modifies *FLAGS directly.
-rw-r--r--devel/libepp-nicbr/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/libepp-nicbr/Makefile b/devel/libepp-nicbr/Makefile
index 8037c826babb..6c7786170770 100644
--- a/devel/libepp-nicbr/Makefile
+++ b/devel/libepp-nicbr/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= libxerces-c.so:${PORTSDIR}/textproc/xerces-c3
OPTIONS_DEFINE= READLINE
OPTIONS_DEFAULT=READLINE
+OPTIONS_SUB= yes
READLINE_DESC= Enable readline support
USE_OPENSSL= yes
@@ -34,10 +35,11 @@ USES= gmake
.if ${PORT_OPTIONS:MREADLINE}
USES+= readline
-PLIST_SUB+= READLINE=""
+. if !exists(/usr/lib/libreadline.so)
+CONFIGURE_ARGS+=--with-readline-includes=${LOCALBASE}/include
+. endif
.else
CONFIGURE_ENV+= ac_cv_lib_readline_readline=no
-PLIST_SUB+= READLINE="@comment "
.endif
post-patch: