aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2002-02-22 22:20:19 +0800
committercy <cy@FreeBSD.org>2002-02-22 22:20:19 +0800
commite8e55c995a35520f88376934856a8c6e9eb56875 (patch)
treebeddef7f9f0f2537e12a8411e7e280e729d900ce
parent37577c358fcd405f0bcbb3b4f4755bb4175f54f6 (diff)
downloadfreebsd-ports-gnome-e8e55c995a35520f88376934856a8c6e9eb56875.tar.gz
freebsd-ports-gnome-e8e55c995a35520f88376934856a8c6e9eb56875.tar.zst
freebsd-ports-gnome-e8e55c995a35520f88376934856a8c6e9eb56875.zip
Add configuration options to Tripwire 1.3.1 install:
- Add the TWCONFIG variable to install a user defined tw.config instead of the one supplied with the port. - Add the NO_DB_BUILD variable to skip the database build during install for users upgrading or reinstalling the port who wish to use an existing or previously installed Tripwire database. PR: ports/35127 Submitted by: cjc Approved by: jgreco@ns.sol.net
-rw-r--r--security/tripwire/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/tripwire/Makefile b/security/tripwire/Makefile
index a54f61ea8e41..da6b7a126b8c 100644
--- a/security/tripwire/Makefile
+++ b/security/tripwire/Makefile
@@ -19,6 +19,8 @@ NO_CDROM= "cannot be redistributed for more than the cost of duplication"
NO_PACKAGE= "requires local database to be built"
RESTRICTED= "contains crypto class algorithms"
+TWCONFIG?= ${FILESDIR}/tw.conf.freebsd2
+
post-extract:
@ (cd ${WRKDIR}; tar xpf T1.2.tar)
@@ -29,13 +31,14 @@ post-patch:
pre-configure:
@ ${CP} ${FILESDIR}/conf-freebsd2.h ${WRKSRC}/configs
@ ${SED} s%/kernel%`sysctl -bn kern.bootfile`% \
- < ${FILESDIR}/tw.conf.freebsd2 \
+ < ${TWCONFIG} \
> ${WRKSRC}/configs/tw.conf.freebsd2
post-install:
@ ${MKDIR} /var/adm/tcheck
- @ ${CP} ${FILESDIR}/tw.conf.freebsd2 /var/adm/tcheck/tw.config
+ @ ${CP} ${TWCONFIG} /var/adm/tcheck/tw.config
# Creating tripwire database
+.ifndef NO_DB_BUILD
@ (cd /var/adm/tcheck; tripwire -initialize)
.if defined(TRIPWIRE_FLOPPY) && ${TRIPWIRE_FLOPPY} == YES
# preparing the floppy
@@ -53,5 +56,6 @@ post-install:
@ umount /mnt
# Do not forget to remove and write-protect the floppy.
.endif
+.endif
.include <bsd.port.mk>