aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2019-08-12 09:33:35 +0800
committerkoobs <koobs@FreeBSD.org>2019-08-12 09:33:35 +0800
commite99d97f74e166fad6ef8c7a953896da68194fac4 (patch)
tree532efb766773394db2bf1bd70b69039cb2933639
parent2c5a0b9d39f8a6b59bb4d24e0f674feb7ce9ce5e (diff)
downloadfreebsd-ports-gnome-e99d97f74e166fad6ef8c7a953896da68194fac4.tar.gz
freebsd-ports-gnome-e99d97f74e166fad6ef8c7a953896da68194fac4.tar.zst
freebsd-ports-gnome-e99d97f74e166fad6ef8c7a953896da68194fac4.zip
devel/py-virtualenvwrapper: Allow Python 3 builds
virtualenvwrapper supports Python 3, remove unnecessary limitation on 2.7 accordingly. A dependency (sphinxcontrib-bitbucket) Python 3 build/run error was fixed in ports r508699, which is required by virtualenvwrapper for its DOCS option/build. While I'm here: - Level up ports compliance (NO_ARCH, USES/USE order) - Remove unecessary DOCS_VARS DOCSDIR override (concurrent does this) - Patch virtualenvwrapper command invocations (virtualenv, virtualenv-clone) to use Python version-specific filenames Approved by: portmgr (blanket(s): ports compliance, python compliance) MFH: 2019Q3
-rw-r--r--devel/py-virtualenvwrapper/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/devel/py-virtualenvwrapper/Makefile b/devel/py-virtualenvwrapper/Makefile
index c4b8cc30a9c4..6a403bdaf8d5 100644
--- a/devel/py-virtualenvwrapper/Makefile
+++ b/devel/py-virtualenvwrapper/Makefile
@@ -3,7 +3,7 @@
PORTNAME= virtualenvwrapper
PORTVERSION= 4.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,20 +19,24 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stevedore>0:devel/py-stevedore@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}virtualenv>0:devel/py-virtualenv@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}virtualenv-clone>0:devel/py-virtualenv-clone@${PY_FLAVOR}
+# Actually 2.6-2.7,3.3-3.6
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinxcontrib-bitbucket>=1.0:textproc/py-sphinxcontrib-bitbucket@${PY_FLAVOR}
+DOCS_VARS= PYDISTUTILS_BUILD_TARGET+=build_sphinx \
+ PYDISTUTILS_BUILDARGS="-a -E"
-USES= python:2.7
-USE_PYTHON= autoplist concurrent distutils
-
-DOCS_VARS= DOCSDIR=${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME} \
- PYDISTUTILS_BUILD_TARGET+=build_sphinx \
- PYDISTUTILS_BUILDARGS="-a -E"
+NO_ARCH= yes
post-patch:
- @${REINPLACE_CMD} -e 's|$$(command \\which python)|${PYTHON_CMD}|1' \
+ @${REINPLACE_CMD} \
+ -e 's|$$(command \\which python)|${PYTHON_CMD}|1' \
+ -e 's|="virtualenv"|="virtualenv${UNIQUE_SUFFIX}"|1' \
+ -e 's|="virtualenv-clone"|="virtualenv-clone${UNIQUE_SUFFIX}"|1' \
${WRKSRC}/${PORTNAME}.sh
post-patch-DOCS-on: