aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-08-29 06:33:45 +0800
committerpav <pav@FreeBSD.org>2006-08-29 06:33:45 +0800
commite9d1dd4d96f19b6257e14c1b4b26d75d01807971 (patch)
treef8547729cf076f471ade07b1890bb401bf324702
parentd1cb1ca6833738891984dcbfa78f514046abc435 (diff)
downloadfreebsd-ports-gnome-e9d1dd4d96f19b6257e14c1b4b26d75d01807971.tar.gz
freebsd-ports-gnome-e9d1dd4d96f19b6257e14c1b4b26d75d01807971.tar.zst
freebsd-ports-gnome-e9d1dd4d96f19b6257e14c1b4b26d75d01807971.zip
Folding@Home is a distributed computing project -- people from through out the
world download and run software to band together to make one of the largest supercomputers in the world. Every computer makes the project closer to our goals. Folding@Home uses novel computational methods coupled to distributed computing, to simulate problems thousands to millions of times more challenging than previously achieved. WWW: http://folding.standford.edu PR: ports/101235 Submitted by: Yonatan <onatan@gmail.com>
-rw-r--r--biology/Makefile1
-rw-r--r--biology/linux-foldingathome/Makefile43
-rw-r--r--biology/linux-foldingathome/distinfo3
-rw-r--r--biology/linux-foldingathome/pkg-descr9
-rw-r--r--biology/linux-foldingathome/scripts/FoldingAtHome5
5 files changed, 61 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 9dfadc1fbf3d..69f946bebccb 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -38,6 +38,7 @@
SUBDIR += lagan
SUBDIR += lamarc
SUBDIR += libgenome
+ SUBDIR += linux-foldingathome
SUBDIR += lsysexp
SUBDIR += mafft
SUBDIR += migrate
diff --git a/biology/linux-foldingathome/Makefile b/biology/linux-foldingathome/Makefile
new file mode 100644
index 000000000000..ed8878efba18
--- /dev/null
+++ b/biology/linux-foldingathome/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: foldingathome
+# Date created: 2/8/2006
+# Whom: Yonatan <onatan@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= foldingathome
+PORTVERSION= 5.02
+CATEGORIES= biology
+MASTER_SITES= http://www.stanford.edu/group/pandegroup/release/
+PKGNAMEPREFIX= linux-
+DISTNAME= FAH${PORTVERSION:S/.//}-Linux
+EXTRACT_SUFX= .exe
+
+MAINTAINER= onatan@gmail.com
+COMMENT= Distributed client for Protein Folding
+
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386 amd64
+REINPLACE_ARGS=
+PLIST_FILES= share/${PORTNAME}/${DISTNAME}${EXTRACT_SUFX} \
+ bin/FoldingAtHome
+PLIST_DIRS= share/${PORTNAME}
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${WRKSRC}
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX}
+ ${CHMOD} 755 ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX}
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${REINPLACE_CMD} -e "s|DATADIR|${DATADIR}|" ${SCRIPTDIR}/FoldingAtHome \
+ | ${REINPLACE_CMD} -e "s|BINNAME|${DISTNAME}${EXTRACT_SUFX}|" \
+ > ${PREFIX}/bin/FoldingAtHome
+ ${CHMOD} 755 ${PREFIX}/bin/FoldingAtHome
+ ${MKDIR} ${DATADIR}
+ ${CP} ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX} ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/biology/linux-foldingathome/distinfo b/biology/linux-foldingathome/distinfo
new file mode 100644
index 000000000000..2cfac333d0ef
--- /dev/null
+++ b/biology/linux-foldingathome/distinfo
@@ -0,0 +1,3 @@
+MD5 (FAH502-Linux.exe) = 4855e808fb94e6d2c5fde345aea0cdc3
+SHA256 (FAH502-Linux.exe) = 02e2d3665a6e8f8fc89c7751b8faadff6885d34860643bdd4107d92825754d33
+SIZE (FAH502-Linux.exe) = 249236
diff --git a/biology/linux-foldingathome/pkg-descr b/biology/linux-foldingathome/pkg-descr
new file mode 100644
index 000000000000..b9b85bf68f8c
--- /dev/null
+++ b/biology/linux-foldingathome/pkg-descr
@@ -0,0 +1,9 @@
+Folding@Home is a distributed computing project -- people from through out the
+world download and run software to band together to make one of the largest
+supercomputers in the world. Every computer makes the project closer to our
+goals.
+Folding@Home uses novel computational methods coupled to distributed computing,
+to simulate problems thousands to millions of times more challenging than
+previously achieved.
+
+WWW: http://folding.standford.edu
diff --git a/biology/linux-foldingathome/scripts/FoldingAtHome b/biology/linux-foldingathome/scripts/FoldingAtHome
new file mode 100644
index 000000000000..3bd56fcb9f39
--- /dev/null
+++ b/biology/linux-foldingathome/scripts/FoldingAtHome
@@ -0,0 +1,5 @@
+#!/bin/sh
+CURDIR=`pwd`
+cd DATADIR
+nice -n 20 ./BINNAME -freeBSD
+cd $CURDIR