aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-07-03 14:41:13 +0800
committerthierry <thierry@FreeBSD.org>2004-07-03 14:41:13 +0800
commite9ed1d286436bc8a5ff74db1b3d34c50c1484d25 (patch)
tree6d0ebd24a226925517d8bbccef5020f5af7de2a3
parent08ce9b7a344e0b19b6910a91b5658a93da1fbbc3 (diff)
downloadfreebsd-ports-gnome-e9ed1d286436bc8a5ff74db1b3d34c50c1484d25.tar.gz
freebsd-ports-gnome-e9ed1d286436bc8a5ff74db1b3d34c50c1484d25.tar.zst
freebsd-ports-gnome-e9ed1d286436bc8a5ff74db1b3d34c50c1484d25.zip
Adding www/preferential & www/preferential-firefox, GUI interface to
view and edit all Mozilla / Firefox prefs. PR: ports/63237
-rw-r--r--www/Makefile2
-rw-r--r--www/preferential-firefox/Makefile18
-rw-r--r--www/preferential/Makefile26
-rw-r--r--www/preferential/distinfo2
-rw-r--r--www/preferential/pkg-descr5
-rw-r--r--www/preferential/pkg-plist2
-rw-r--r--www/xpi-preferential/Makefile18
7 files changed, 73 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d005d89a66ac..29bcf0aedb8a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -531,6 +531,8 @@
SUBDIR += pnews
SUBDIR += postnuke
SUBDIR += pound
+ SUBDIR += preferential
+ SUBDIR += preferential-firefox
SUBDIR += privoxy
SUBDIR += privoxy+ipv6
SUBDIR += pserv
diff --git a/www/preferential-firefox/Makefile b/www/preferential-firefox/Makefile
new file mode 100644
index 000000000000..7bf8caeb66ec
--- /dev/null
+++ b/www/preferential-firefox/Makefile
@@ -0,0 +1,18 @@
+# Ports collection makefile for: preferential-firefox
+# Date created: Tue Oct 28, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= preferential
+#PKGNAMESUFFIX set to -firefox in ../mozex/Makefile.xpi
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GUI interface to view & edit all Firefox prefs
+
+MASTERDIR= ${.CURDIR}/../preferential
+
+WITH_FIREFOX= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/preferential/Makefile b/www/preferential/Makefile
new file mode 100644
index 000000000000..86778d03b99d
--- /dev/null
+++ b/www/preferential/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: preferential
+# Date created: Tue Oct 28, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME?= preferential
+PORTVERSION= 0.6.1a
+CATEGORIES= www
+MASTER_SITES= http://downloads.mozdev.org/preferential/versions/ \
+ http://mozdev.mirrors.nyphp.org/preferential/versions/
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER?= ports@FreeBSD.org
+COMMENT?= GUI interface to view & edit all Mozilla prefs
+
+USE_X_PREFIX= yes # Cannot be included after <bsd.port.pre.mk>.
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozex/Makefile.xpi"
+
+do-install:
+ @${INSTALL_DATA} ${WRKDIR}/preferential.jar ${MOZDIR}/chrome
+
+.include <bsd.port.post.mk>
diff --git a/www/preferential/distinfo b/www/preferential/distinfo
new file mode 100644
index 000000000000..00b858320f34
--- /dev/null
+++ b/www/preferential/distinfo
@@ -0,0 +1,2 @@
+MD5 (preferential-0.6.1a/preferential-0.6.1a.xpi) = 0630fa253f4b328f890251fab1e8c55a
+SIZE (preferential-0.6.1a/preferential-0.6.1a.xpi) = 76432
diff --git a/www/preferential/pkg-descr b/www/preferential/pkg-descr
new file mode 100644
index 000000000000..f413839b2503
--- /dev/null
+++ b/www/preferential/pkg-descr
@@ -0,0 +1,5 @@
+The Preferential project aims to provide all users of Gecko browsers
+(eg. Mozilla, Firefox) with a simple, accessible GUI that allows the
+modification of any preference set within that browser environment.
+
+WWW: http://preferential.mozdev.org/
diff --git a/www/preferential/pkg-plist b/www/preferential/pkg-plist
new file mode 100644
index 000000000000..c7f67cfb7203
--- /dev/null
+++ b/www/preferential/pkg-plist
@@ -0,0 +1,2 @@
+%%MOZDIR%%/chrome/preferential.jar
+%%MOZDIR%%/chrome/overlayinfo/browser/content/overlays.rdf
diff --git a/www/xpi-preferential/Makefile b/www/xpi-preferential/Makefile
new file mode 100644
index 000000000000..7bf8caeb66ec
--- /dev/null
+++ b/www/xpi-preferential/Makefile
@@ -0,0 +1,18 @@
+# Ports collection makefile for: preferential-firefox
+# Date created: Tue Oct 28, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= preferential
+#PKGNAMESUFFIX set to -firefox in ../mozex/Makefile.xpi
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GUI interface to view & edit all Firefox prefs
+
+MASTERDIR= ${.CURDIR}/../preferential
+
+WITH_FIREFOX= yes
+
+.include "${MASTERDIR}/Makefile"