aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-01-25 04:47:17 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-01-25 04:47:17 +0800
commitea472083955b652ac7497b932bc64d4d2cfd5833 (patch)
tree3a345995732ab7b7647d3726676aa5bb951da9f5
parent19025e32286a7c8b40c3fc68dcd99ea29de67d7d (diff)
downloadfreebsd-ports-gnome-ea472083955b652ac7497b932bc64d4d2cfd5833.tar.gz
freebsd-ports-gnome-ea472083955b652ac7497b932bc64d4d2cfd5833.tar.zst
freebsd-ports-gnome-ea472083955b652ac7497b932bc64d4d2cfd5833.zip
- Remove optional dependency on databases/ruby-bdb1 as there
is really no compelling reason to keep it. It just adds confusion. Portupgrade should gracefully handle rebuilding the pkgdb now if the bdb backend changes because of this. If not just force rebuild: pkgdb -uf - Make databases/ruby-bdb the unconditional db backend
-rw-r--r--ports-mgmt/portupgrade/Makefile21
1 files changed, 1 insertions, 20 deletions
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index f061fa2218f0..65f48babb772 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -3,6 +3,7 @@
PORTNAME= portupgrade
PORTVERSION= 2.4.10.4
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= ports-mgmt
MASTER_SITES= SF/portupgrade/pkgtools/dist/ \
@@ -14,13 +15,7 @@ COMMENT= FreeBSD ports/packages administration and management tool suite
LICENSE= BSD
-NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= DOCS
-OPTIONS_RADIO= DB_OVERRIDE
-OPTIONS_RADIO_DB_OVERRIDE= BDB4 BDB1
-OPTIONS_DEFAULT= BDB4 DOCS
-BDB1_DESC= Use Berkeley DB 1
-BDB4_DESC= Use Berkeley DB >=2
CONFLICTS_INSTALL= portupgrade-devel-*
@@ -59,13 +54,8 @@ INSTALL_TARGET= install
INSTALL_TARGET+= install-doc
.endif
-.if ${PORT_OPTIONS:MBDB4}
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb
-.elif ${PORT_OPTIONS:MBDB1}
-# For PKG_DBDRIVER={bdb1_btree,bdb1_hash}
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb1.so:${PORTSDIR}/databases/ruby-bdb1
-.endif
# parsedate is needed for date globbing
.if ${RUBY_VER} == 1.9
@@ -80,15 +70,6 @@ MAKE_ENV+= NEED_COMPAT_SCRIPT=yes
PLIST_SUB+= SCRIPT="@comment "
.endif
-pre-extract:
-.if exists(${RUBY_SITEARCHLIBDIR}/bdb.so) && ${PORT_OPTIONS:MBDB1}
- @${ECHO_MSG} "================================================================="
- @${ECHO_MSG} "BDB1 is defined but databases/ruby-bdb port installed."
- @${ECHO_MSG} "Remove ruby-bdb or redefine options."
- @${ECHO_MSG} "================================================================="
- @exit 1
-.endif
-
post-install:
if [ ! -f ${PREFIX}/etc/pkgtools.conf ]; then \
${CP} -p ${PREFIX}/etc/pkgtools.conf.sample ${PREFIX}/etc/pkgtools.conf; \