aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2017-01-03 04:17:23 +0800
committercs <cs@FreeBSD.org>2017-01-03 04:17:23 +0800
commiteb0b9e29bc919740aaebe40e83893832c37ddb41 (patch)
treed2d37e32a5c21b07222b6f516e2b830d04afec0f
parente5879f5b0a131e96886edc565e736882bf32d150 (diff)
downloadfreebsd-ports-gnome-eb0b9e29bc919740aaebe40e83893832c37ddb41.tar.gz
freebsd-ports-gnome-eb0b9e29bc919740aaebe40e83893832c37ddb41.tar.zst
freebsd-ports-gnome-eb0b9e29bc919740aaebe40e83893832c37ddb41.zip
Bapu allows you to manage your Gandi virtual machines.
WWW: https://bitbucket.org/carlostrub/bapu
-rw-r--r--net/Makefile1
-rw-r--r--net/go-bapu/Makefile23
-rw-r--r--net/go-bapu/distinfo3
-rw-r--r--net/go-bapu/pkg-descr3
-rw-r--r--net/go-bapu/pkg-plist2
5 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aed777322e12..e8dbfd492b3f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -173,6 +173,7 @@
SUBDIR += gnu-dico
SUBDIR += gnu-radius
SUBDIR += go-amqp
+ SUBDIR += go-bapu
SUBDIR += go-cs
SUBDIR += go-geoip
SUBDIR += go-httppath
diff --git a/net/go-bapu/Makefile b/net/go-bapu/Makefile
new file mode 100644
index 000000000000..cdfa4b112c91
--- /dev/null
+++ b/net/go-bapu/Makefile
@@ -0,0 +1,23 @@
+# Created by: Carlo Strub <cs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bapu
+PORTVERSION= 0.1.0
+CATEGORIES= net
+MASTER_SITES= https://bitbucket.org/carlostrub/bapu/get/
+PKGNAMEPREFIX= go-
+DISTNAME= v${PORTVERSION}
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Virtual Machine Controller for Gandi.net
+
+LICENSE= BSD3CLAUSE
+
+USES= go tar:bzip2
+GO_PKGNAME= bitbucket.org/carlostrub/bapu
+WRKSRC= ${WRKDIR}/carlostrub-bapu-4258e51442b6
+
+post-install:
+ ${CP} -R ${WRKSRC}/bapu.toml.sample ${STAGEDIR}${PREFIX}/etc/
+
+.include <bsd.port.mk>
diff --git a/net/go-bapu/distinfo b/net/go-bapu/distinfo
new file mode 100644
index 000000000000..4f2de6e0b902
--- /dev/null
+++ b/net/go-bapu/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483386197
+SHA256 (v0.1.0.tar.bz2) = 6e0ab806a2ee8a0e8bcec62eddafb111e2489a7dd74ecff342574ad6f60f0d65
+SIZE (v0.1.0.tar.bz2) = 6191339
diff --git a/net/go-bapu/pkg-descr b/net/go-bapu/pkg-descr
new file mode 100644
index 000000000000..e62e87269c5d
--- /dev/null
+++ b/net/go-bapu/pkg-descr
@@ -0,0 +1,3 @@
+Bapu allows you to manage your Gandi virtual machines.
+
+WWW: https://bitbucket.org/carlostrub/bapu
diff --git a/net/go-bapu/pkg-plist b/net/go-bapu/pkg-plist
new file mode 100644
index 000000000000..35c7bad3fd3a
--- /dev/null
+++ b/net/go-bapu/pkg-plist
@@ -0,0 +1,2 @@
+bin/bapu
+@sample etc/bapu.toml.sample