aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2015-08-23 18:37:22 +0800
committerkuriyama <kuriyama@FreeBSD.org>2015-08-23 18:37:22 +0800
commiteb0d46a11c2add618cf469d14a0e7cbb087fd54b (patch)
tree9c26c8a0920af4dd8739026a1c491a97cf07b19e
parentbc14f65e68fcc0dcebf0944923ccda679126c0e1 (diff)
downloadfreebsd-ports-gnome-eb0d46a11c2add618cf469d14a0e7cbb087fd54b.tar.gz
freebsd-ports-gnome-eb0d46a11c2add618cf469d14a0e7cbb087fd54b.tar.zst
freebsd-ports-gnome-eb0d46a11c2add618cf469d14a0e7cbb087fd54b.zip
Strip unwanted HTML tags and attributes.
WWW: http://search.cpan.org/dist/HTML-Restrict/
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Restrict/Makefile29
-rw-r--r--www/p5-HTML-Restrict/distinfo2
-rw-r--r--www/p5-HTML-Restrict/pkg-descr3
-rw-r--r--www/p5-HTML-Restrict/pkg-plist2
5 files changed, 37 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0f354194d9ef..46c03fef76ea 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -926,6 +926,7 @@
SUBDIR += p5-HTML-QuickCheck
SUBDIR += p5-HTML-RSSAutodiscovery
SUBDIR += p5-HTML-ResolveLink
+ SUBDIR += p5-HTML-Restrict
SUBDIR += p5-HTML-RobotsMETA
SUBDIR += p5-HTML-Scrubber
SUBDIR += p5-HTML-Seamstress
diff --git a/www/p5-HTML-Restrict/Makefile b/www/p5-HTML-Restrict/Makefile
new file mode 100644
index 000000000000..d91baa840fba
--- /dev/null
+++ b/www/p5-HTML-Restrict/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= HTML-Restrict
+PORTVERSION= 2.2.2
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to strip unwanted HTML tags and attributes
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= \
+ p5-Data-Dump>0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-List-MoreUtils>0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Moo>=1.002000:${PORTSDIR}/devel/p5-Moo \
+ p5-Type-Tiny>=1.000001:${PORTSDIR}/devel/p5-Type-Tiny \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-namespace-clean>0:${PORTSDIR}/devel/p5-namespace-clean
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH= YES
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Restrict/distinfo b/www/p5-HTML-Restrict/distinfo
new file mode 100644
index 000000000000..372a08f6eb21
--- /dev/null
+++ b/www/p5-HTML-Restrict/distinfo
@@ -0,0 +1,2 @@
+SHA256 (HTML-Restrict-2.2.2.tar.gz) = 90dbd6448999c74563451ad0284e4f1ce4cff7edfad7c3f9c761fcbd487bbfe0
+SIZE (HTML-Restrict-2.2.2.tar.gz) = 26190
diff --git a/www/p5-HTML-Restrict/pkg-descr b/www/p5-HTML-Restrict/pkg-descr
new file mode 100644
index 000000000000..37694e50e88e
--- /dev/null
+++ b/www/p5-HTML-Restrict/pkg-descr
@@ -0,0 +1,3 @@
+Strip unwanted HTML tags and attributes.
+
+WWW: http://search.cpan.org/dist/HTML-Restrict/
diff --git a/www/p5-HTML-Restrict/pkg-plist b/www/p5-HTML-Restrict/pkg-plist
new file mode 100644
index 000000000000..57e359e82f8b
--- /dev/null
+++ b/www/p5-HTML-Restrict/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/HTML::Restrict.3.gz
+%%SITE_PERL%%/HTML/Restrict.pm