aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-07-19 18:19:26 +0800
committerdanfe <danfe@FreeBSD.org>2013-07-19 18:19:26 +0800
commiteb1c7479145f0a8c1711abb105a5fc268ac68622 (patch)
treeb0dceec88b9fa1698f1ec148f88e35edc1b5dd94
parent121d7356af1a8c09c4880e193a4e96a14cdd9b46 (diff)
downloadfreebsd-ports-gnome-eb1c7479145f0a8c1711abb105a5fc268ac68622.tar.gz
freebsd-ports-gnome-eb1c7479145f0a8c1711abb105a5fc268ac68622.tar.zst
freebsd-ports-gnome-eb1c7479145f0a8c1711abb105a5fc268ac68622.zip
- Fix the installation error
- Sanitize OPTIONS and make them actually work - Trim Makefile header while here - Reformat port description text and remove old-school attribution Reported by: pointyhat-west
-rw-r--r--net/nakenchat/Makefile53
-rw-r--r--net/nakenchat/files/patch-Makefile10
-rw-r--r--net/nakenchat/pkg-descr14
3 files changed, 27 insertions, 50 deletions
diff --git a/net/nakenchat/Makefile b/net/nakenchat/Makefile
index 7c22da4394c0..158697e580bf 100644
--- a/net/nakenchat/Makefile
+++ b/net/nakenchat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nakenchat
-# Date created: 01 July 2003
-# Whom: Michael Kohn (mike@mikekohn.net)
-#
+# Created by: Michael Kohn <mike@mikekohn.net>
# $FreeBSD$
-#
PORTNAME= nakenchat
PORTVERSION= 2.12
@@ -16,45 +12,26 @@ COMMENT= Small (under 50k) chat server with many features
HAS_CONFIGURE= yes
USE_RC_SUBR= nakenchat
-OPTIONS_DEFINE= KEEPALIVEOFF USERCHANLISTOFF DEBUG HIDDENCAVES DOTQ FUSERLIST ELITEFILTER
+OPTIONS_DEFINE= NOKEEPALIVE NOUSERCHANLIST DEBUG HIDDENCAVES DOTQ \
+ FUSERLIST ELITEFILTER
-KEEPALIVEOFF_DESC= Disable socket keepalive option
-USERCHANLISTOFF_DESC= Disable userlist based on channel
+NOKEEPALIVE_DESC= Disable socket keepalive option
+NOUSERCHANLIST_DESC= Disable userlist based on channel
DEBUG_DESC= Compile in debug code
HIDDENCAVES_DESC= Enable hidden caves feature
-DOTQ_DESC= compile in .Q option
-FUSERLIST_DESC= support to save current userlist to a file
+DOTQ_DESC= Compile in .Q option
+FUSERLIST_DESC= Support saving current userlist to a file
ELITEFILTER_DESC= Enable the 3li73 filter
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MWITH_KEEPALIVEOFF}
-CONFIGURE_ARGS+= --disable-keepalive
-.endif
-
-.if ${PORT_OPTIONS:MWITH_USERCHANLISTOFF}
-CONFIGURE_ARGS+= --disable-userchanlist
-.endif
-
-.if ${PORT_OPTIONS:MWITH_DEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.endif
+NOKEEPALIVE_CONFIGURE_ON= --disable-keepalive
+NOUSERCHANLIST_CONFIGURE_ON= --disable-userchanlist
+DEBUG_CONFIGURE_ON= --enable-debug
+HIDDENCAVES_CONFIGURE_ON= --enable-hidden-caves
+DOTQ_CONFIGURE_ON= --enable-dotQ
+FUSERLIST_CONFIGURE_ON= --enable-whofile
+ELITEFILTER_CONFIGURE_ON= --enable-elite
-.if ${PORT_OPTIONS:MWITH_HIDDENCAVES}
-CONFIGURE_ARGS+= --enable-hidden-caves
-.endif
-
-.if ${PORT_OPTIONS:MWITH_DOTQ}
-CONFIGURE_ARGS+= --enable-dotQ
-.endif
-
-.if ${PORT_OPTIONS:MWITH_FUSERLIST}
-CONFIGURE_ARGS+= --enable-whofile
-.endif
-
-.if ${PORT_OPTIONS:MWITH_ELITEFILTER}
-CONFIGURE_ARGS+= --enable-elite
-.endif
+.include <bsd.port.options.mk>
post-install:
@if [ ! -f ${PREFIX}/etc/nakenchat.conf ]; then \
diff --git a/net/nakenchat/files/patch-Makefile b/net/nakenchat/files/patch-Makefile
index e6e689795cd1..23561d92b8a2 100644
--- a/net/nakenchat/files/patch-Makefile
+++ b/net/nakenchat/files/patch-Makefile
@@ -1,15 +1,19 @@
--- ./Makefile.orig 2007-06-27 22:06:34.000000000 -0400
+++ ./Makefile 2008-11-23 14:24:11.028905510 -0500
-@@ -30,12 +30,7 @@
+@@ -28,14 +28,9 @@
+ install:
+ @if [ ! -d $(PREFIX)/bin ]; then mkdir $(PREFIX)/bin; fi;
@if [ ! -d $(PREFIX)/etc ]; then mkdir $(PREFIX)/etc; fi;
- cp nakenchat $(PREFIX)/bin
- cp nakenpasswd $(PREFIX)/bin
+- cp nakenchat $(PREFIX)/bin
+- cp nakenpasswd $(PREFIX)/bin
- @echo "cp nakenchat.conf $(PREFIX)/etc"
- @if [ -f $(PREFIX)/etc/nakenchat.conf ]; then \
- echo "$(PREFIX)/etc/nakenchat.conf exists."; \
- else \
- cp nakenchat.conf $(PREFIX)/etc; \
- fi
++ cp src/nakenchat $(PREFIX)/bin
++ cp src/nakenpasswd $(PREFIX)/bin
+ cp nakenchat.conf $(PREFIX)/etc/nakenchat.conf.sample;
clean:
diff --git a/net/nakenchat/pkg-descr b/net/nakenchat/pkg-descr
index 4ad20e408490..3be4dfb8c7c8 100644
--- a/net/nakenchat/pkg-descr
+++ b/net/nakenchat/pkg-descr
@@ -1,11 +1,7 @@
-Small chat server written in C. The compiled code is still under
-50k (at this time around 40k). The chat offers many features
-including private channels, gagging, squelching, banning,
-censoring, and much more. Users can connect to the chat through
-many ways including telnet and a Java applet through a webpage.
+Small chat server written in C. The compiled code is still under 50k (at
+this time around 40k). The chat offers many features including private
+channels, gagging, squelching, banning, censoring, and much more. Users
+can connect to the chat through many ways, including telnet and a Java
+applet through a webpage.
WWW: http://nakenchat.naken.cc/
-
--Michael Kohn
-
-mike@mikekohn.net