aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-30 00:35:50 +0800
committersat <sat@FreeBSD.org>2006-05-30 00:35:50 +0800
commitebad524ecd0f614b512c2644e911d2e3f3a071a8 (patch)
tree41e944081a87d857ce97346ce4a68cf5b36613bb
parenta1157332b8605c33c02b089e3f729faadb0cf691 (diff)
downloadfreebsd-ports-gnome-ebad524ecd0f614b512c2644e911d2e3f3a071a8.tar.gz
freebsd-ports-gnome-ebad524ecd0f614b512c2644e911d2e3f3a071a8.tar.zst
freebsd-ports-gnome-ebad524ecd0f614b512c2644e911d2e3f3a071a8.zip
- Introduce and document USE_XPI - a maintainer-tunable var
Approved by: krion (implicit)
-rw-r--r--www/xpi-adblock/Makefile.xpi15
1 files changed, 13 insertions, 2 deletions
diff --git a/www/xpi-adblock/Makefile.xpi b/www/xpi-adblock/Makefile.xpi
index 571fa7a95743..2f1eaccdd736 100644
--- a/www/xpi-adblock/Makefile.xpi
+++ b/www/xpi-adblock/Makefile.xpi
@@ -29,6 +29,9 @@
# Default: ${PREFIX}/lib/xpi
# XPI_XPIDIR - Name of the directory to install extension's files in.
# Default: ${XPI_LIBDIR}/${XPI_ID}
+# USE_XPI - If set, the port installs one or more xpi extensions.
+# If this is set to a list of apps (wildcards possible) the
+# extensions will be installed for them only.
#
# This Makefile is an alpha-version of the new xpi infrastructure. It currently
# supports Gecko 1.8+ (Firefox 1.5+). Support for Gecko 1.7x (and Seamonkey 1.0)
@@ -71,8 +74,16 @@ USE_ZIP= yes
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
XPI_DISTNAME?= ${PORTNAME}
-WITH_XPI_APPS?= *firefox* *thunderbird* *flock*
-XPI_APPS?= ${WITH_XPI_APPS:S.^.${X11BASE}/lib/.:S.$./extensions.}
+XPI_APPS_ALL= *firefox* *thunderbird* *flock*
+WITH_XPI_APPS?= ${XPI_APPS_ALL}
+
+.if defined(USE_XPI) && ( ${USE_XPI:U} == "YES" || ${USE_XPI} == "*" )
+USE_XPI= ${WITH_XPI_APPS}
+.else
+USE_XPI?= ${WITH_XPI_APPS}
+.endif
+
+XPI_APPS?= ${USE_XPI:S.^.${X11BASE}/lib/.:S.$./extensions.}
XPI_LIBDIR?= ${PREFIX}/lib/xpi
.ifndef XPI_DISTNAMES