aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2015-03-11 03:30:15 +0800
committernox <nox@FreeBSD.org>2015-03-11 03:30:15 +0800
commitec352cb7e6948882126caa8976a1d5967715bbbb (patch)
tree63e1369f6dbabeef2c2dd30dfa30a9407b878135
parentae40186cc4004fc612a75c1e5398df8b5b45187f (diff)
downloadfreebsd-ports-gnome-ec352cb7e6948882126caa8976a1d5967715bbbb.tar.gz
freebsd-ports-gnome-ec352cb7e6948882126caa8976a1d5967715bbbb.tar.zst
freebsd-ports-gnome-ec352cb7e6948882126caa8976a1d5967715bbbb.zip
Catch up with github tree - changelog:
https://github.com/seanbruno/qemu-bsd-user/commits/bsd-user
-rw-r--r--emulators/qemu-sbruno/Makefile5
-rw-r--r--emulators/qemu-sbruno/distinfo8
-rw-r--r--emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c4
3 files changed, 8 insertions, 9 deletions
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index 23b879d18b86..92d17586f32e 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 2.2.50.g20150215
-PORTREVISION= 1
+PORTVERSION= 2.2.50.g20150310
CATEGORIES= emulators
MASTER_SITES= GH GHC \
LOCAL/nox \
@@ -21,7 +20,7 @@ COMMENT?= QEMU CPU Emulator - github bsd-user branch
USE_GITHUB= yes
GH_ACCOUNT= seanbruno
GH_PROJECT= ${PORTNAME}-bsd-user
-GH_COMMIT= 87de5f9
+GH_COMMIT= 6b9c0c2
GH_TAGNAME= ${GH_COMMIT}
HAS_CONFIGURE= yes
USES= gmake pkgconfig bison perl5 python:2,build
diff --git a/emulators/qemu-sbruno/distinfo b/emulators/qemu-sbruno/distinfo
index 1461e94674cc..c6211d271360 100644
--- a/emulators/qemu-sbruno/distinfo
+++ b/emulators/qemu-sbruno/distinfo
@@ -1,4 +1,4 @@
-SHA256 (qemu/2.2.50.g20150215/qemu-2.2.50.g20150215.tar.gz) = 5de67a5ef321cddb090442462de8b652e70a829132152b94dec391026396ab38
-SIZE (qemu/2.2.50.g20150215/qemu-2.2.50.g20150215.tar.gz) = 10709753
-SHA256 (qemu/2.2.50.g20150215/dtc-v1.4.0.tar.gz) = 39d0713efd82a27adc065ecb9ef36401c53d5ee87ae1764e2bb243fcd97488e3
-SIZE (qemu/2.2.50.g20150215/dtc-v1.4.0.tar.gz) = 131893
+SHA256 (qemu/2.2.50.g20150310/qemu-2.2.50.g20150310.tar.gz) = 6ca26cdf99350976ab794778fc4bbf03a6cf2e919139cb6e1fd6b17797975977
+SIZE (qemu/2.2.50.g20150310/qemu-2.2.50.g20150310.tar.gz) = 10709498
+SHA256 (qemu/2.2.50.g20150310/dtc-v1.4.0.tar.gz) = 39d0713efd82a27adc065ecb9ef36401c53d5ee87ae1764e2bb243fcd97488e3
+SIZE (qemu/2.2.50.g20150310/dtc-v1.4.0.tar.gz) = 131893
diff --git a/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c b/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
index 7c29adc0d804..e9a250ca0e20 100644
--- a/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
+++ b/emulators/qemu-sbruno/files/patch-bsd-user-freebsd-os-proc.c
@@ -4,8 +4,8 @@
#error __FreeBSD_version not defined!
#endif
--#if defined(__FreeBSD_version) && __FreeBSD_version >= 1100000
-+#if defined(__FreeBSD_version) && __FreeBSD_version >= 1100000 && defined(PROC_REAP_ACQUIRE)
+-#if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510
++#if defined(__FreeBSD_version) && __FreeBSD_version >= 1001510 && defined(PROC_REAP_ACQUIRE)
#include <sys/procctl.h>