aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2018-08-15 20:49:38 +0800
committerehaupt <ehaupt@FreeBSD.org>2018-08-15 20:49:38 +0800
commitec49a853fa375d9e4badbad9bf625fcca0b343e0 (patch)
tree5466f860b468d091ba45f5c0d0e45b848fbf7755
parent0b896fdf044d363f4bb9284bdd18bdf7ec7f207b (diff)
downloadfreebsd-ports-gnome-ec49a853fa375d9e4badbad9bf625fcca0b343e0.tar.gz
freebsd-ports-gnome-ec49a853fa375d9e4badbad9bf625fcca0b343e0.tar.zst
freebsd-ports-gnome-ec49a853fa375d9e4badbad9bf625fcca0b343e0.zip
- Update to 0.9.8
- Move from SF to GitHub - Update WWW - Pacify portlint - Unbreak on amd64, "Philippe Maechler" <pmaechler-ml@glattnet.ch> notified us via ports@ that the produced config files work fine
-rw-r--r--net-mgmt/docsis/Makefile21
-rw-r--r--net-mgmt/docsis/distinfo5
-rw-r--r--net-mgmt/docsis/files/patch-docsis_decode.c10
-rw-r--r--net-mgmt/docsis/files/patch-src_docsis.c (renamed from net-mgmt/docsis/files/patch-docsis.c)14
-rw-r--r--net-mgmt/docsis/files/patch-src_docsis__decode.c10
-rw-r--r--net-mgmt/docsis/files/patch-src_docsis__snmp.c (renamed from net-mgmt/docsis/files/patch-docsis_snmp.c)6
-rw-r--r--net-mgmt/docsis/files/patch-src_docsis__snmp.h (renamed from net-mgmt/docsis/files/patch-docsis_snmp.h)11
-rw-r--r--net-mgmt/docsis/pkg-descr2
-rw-r--r--net-mgmt/docsis/pkg-plist2
9 files changed, 44 insertions, 37 deletions
diff --git a/net-mgmt/docsis/Makefile b/net-mgmt/docsis/Makefile
index 4732594cd425..cbaa0314ac5e 100644
--- a/net-mgmt/docsis/Makefile
+++ b/net-mgmt/docsis/Makefile
@@ -2,33 +2,36 @@
# $FreeBSD$
PORTNAME= docsis
-PORTVERSION= 0.9.6
+PORTVERSION= 0.9.8
CATEGORIES= net-mgmt
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Binary configuration file encoder/decoder
LICENSE= GPLv2+
-BUILD_DEPENDS= gm4:devel/m4
-LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
+BUILD_DEPENDS= gm4:devel/m4 \
+ flex:textproc/flex
+LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp \
+ libpkg.so:ports-mgmt/pkg
+USES= autoreconf bison libtool ssl
+USE_GITHUB= yes
GNU_CONFIGURE= yes
-USES= bison ssl
PLIST_SUB= MIBS=share/snmp/mibs
-BROKEN_amd64= Produces corrupt files on amd64
-
OPTIONS_DEFINE= DOCS EXAMPLES
+GH_ACCOUNT= rlaager
+GH_TAGNAME= upstream/${PORTVERSION}
+
post-patch:
@${REINPLACE_CMD} -e \
'/^htmldocdir/s|share/docsis|share/doc/docsis|' \
- ${WRKSRC}/doc/Makefile.in
+ ${WRKSRC}/doc/Makefile.am
@${REINPLACE_CMD} -e \
'/^examplesdir/s|docsis/examples|examples/docsis|' \
- ${WRKSRC}/examples/Makefile.in
+ ${WRKSRC}/examples/Makefile.am
.include <bsd.port.mk>
diff --git a/net-mgmt/docsis/distinfo b/net-mgmt/docsis/distinfo
index 301fc91f694d..142e524c7f09 100644
--- a/net-mgmt/docsis/distinfo
+++ b/net-mgmt/docsis/distinfo
@@ -1,2 +1,3 @@
-SHA256 (docsis-0.9.6.tar.gz) = 71633f58d29231b2084ebe993683a723bce813dbd893388563a21197aa3c0ca0
-SIZE (docsis-0.9.6.tar.gz) = 614310
+TIMESTAMP = 1534323098
+SHA256 (rlaager-docsis-0.9.8-upstream-0.9.8_GH0.tar.gz) = ef3ac656c0415580d018e657dec19093781962f657eae65026a7224109121d33
+SIZE (rlaager-docsis-0.9.8-upstream-0.9.8_GH0.tar.gz) = 2888501
diff --git a/net-mgmt/docsis/files/patch-docsis_decode.c b/net-mgmt/docsis/files/patch-docsis_decode.c
deleted file mode 100644
index 0710abb072d4..000000000000
--- a/net-mgmt/docsis/files/patch-docsis_decode.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/docsis_decode.c.orig Mon Aug 1 07:30:42 2005
-+++ src/docsis_decode.c Sun Jun 10 18:24:22 2007
-@@ -22,6 +22,7 @@
-
- #include <math.h>
- #include <ctype.h>
-+#include <string.h>
-
- /* #include "docsis.h" */
- #include "docsis_decode.h"
diff --git a/net-mgmt/docsis/files/patch-docsis.c b/net-mgmt/docsis/files/patch-src_docsis.c
index 61df81a0a836..b683137f7925 100644
--- a/net-mgmt/docsis/files/patch-docsis.c
+++ b/net-mgmt/docsis/files/patch-src_docsis.c
@@ -1,6 +1,6 @@
---- src/docsis.c.orig Mon Aug 15 14:19:04 2005
-+++ src/docsis.c Sun Jun 10 18:14:07 2007
-@@ -20,10 +20,6 @@
+--- src/docsis.c.orig 2015-10-18 20:28:25 UTC
++++ src/docsis.c
+@@ -21,10 +21,6 @@
* DOCSIS is a registered trademark of Cablelabs, http://www.cablelabs.com
*/
@@ -11,11 +11,10 @@
#include <errno.h>
#include <string.h>
#include <sys/types.h>
-@@ -35,6 +31,16 @@
- #include <net-snmp/config_api.h>
+@@ -37,6 +33,16 @@
#include <net-snmp/output_api.h>
#include <net-snmp/mib_api.h>
-+
+
+#undef PACKAGE_BUGREPORT
+#undef PACKAGE_NAME
+#undef PACKAGE_STRING
@@ -25,6 +24,7 @@
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif /* HAVE_CONFIG_H */
-
++
#include "docsis.h"
+ #include "docsis_globals.h"
#include "docsis_symtable.h"
diff --git a/net-mgmt/docsis/files/patch-src_docsis__decode.c b/net-mgmt/docsis/files/patch-src_docsis__decode.c
new file mode 100644
index 000000000000..288fefd93d61
--- /dev/null
+++ b/net-mgmt/docsis/files/patch-src_docsis__decode.c
@@ -0,0 +1,10 @@
+--- src/docsis_decode.c.orig 2015-10-18 20:28:25 UTC
++++ src/docsis_decode.c
+@@ -30,6 +30,7 @@
+
+ #include <math.h>
+ #include <ctype.h>
++#include <string.h>
+
+ /* #include "docsis.h" */
+ #include "docsis_decode.h"
diff --git a/net-mgmt/docsis/files/patch-docsis_snmp.c b/net-mgmt/docsis/files/patch-src_docsis__snmp.c
index 473d115a2e96..97b4f05c7675 100644
--- a/net-mgmt/docsis/files/patch-docsis_snmp.c
+++ b/net-mgmt/docsis/files/patch-src_docsis__snmp.c
@@ -1,6 +1,6 @@
---- src/docsis_snmp.c.orig Wed Oct 12 07:30:20 2005
-+++ src/docsis_snmp.c Sun Jun 10 18:25:36 2007
-@@ -20,6 +20,8 @@
+--- src/docsis_snmp.c.orig 2015-10-18 20:28:25 UTC
++++ src/docsis_snmp.c
+@@ -21,6 +21,8 @@
* DOCSIS is a registered trademark of Cablelabs, http://www.cablelabs.com
*/
diff --git a/net-mgmt/docsis/files/patch-docsis_snmp.h b/net-mgmt/docsis/files/patch-src_docsis__snmp.h
index 951c4f1d7f41..de7986c10dbb 100644
--- a/net-mgmt/docsis/files/patch-docsis_snmp.h
+++ b/net-mgmt/docsis/files/patch-src_docsis__snmp.h
@@ -1,6 +1,6 @@
---- src/docsis_snmp.h.orig Wed Mar 17 08:01:37 2004
-+++ src/docsis_snmp.h Sun Jun 10 18:27:16 2007
-@@ -24,11 +24,19 @@
+--- src/docsis_snmp.h.orig 2015-10-18 20:28:25 UTC
++++ src/docsis_snmp.h
+@@ -25,12 +25,20 @@
#ifndef _DOCSIS_SNMP_H
#define _DOCSIS_SNMP_H
@@ -11,12 +11,13 @@
#include <net-snmp/config_api.h>
#include <net-snmp/output_api.h>
#include <net-snmp/mib_api.h>
-+
+
+#undef PACKAGE_BUGREPORT
+#undef PACKAGE_NAME
+#undef PACKAGE_STRING
+#undef PACKAGE_TARNAME
+#undef PACKAGE_VERSION
-
++
#include "docsis.h"
+ unsigned int encode_vbind ( char *oid_string, char oid_asntype, union t_val *value,
diff --git a/net-mgmt/docsis/pkg-descr b/net-mgmt/docsis/pkg-descr
index 3493a2c9a21d..552e53e4c2d8 100644
--- a/net-mgmt/docsis/pkg-descr
+++ b/net-mgmt/docsis/pkg-descr
@@ -3,4 +3,4 @@ configuration files for DOCSIS-compliant cable modems. DOCSIS stands
for Data over Cable Service Interface Specification and is a standard
developed by Cablelabs.
-WWW: http://docsis.sourceforge.net/
+WWW: https://github.com/rlaager/docsis
diff --git a/net-mgmt/docsis/pkg-plist b/net-mgmt/docsis/pkg-plist
index 2d9fe2d41548..df23620337c1 100644
--- a/net-mgmt/docsis/pkg-plist
+++ b/net-mgmt/docsis/pkg-plist
@@ -41,6 +41,8 @@ bin/docsis
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/docsis20_no_snmp.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/docsis20_stresstest.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/docsis20_stresstest.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/docsis_ipv6.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/docsis_ipv6.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/keyfile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/packetcable_mta.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/packetcable_mta.txt