aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2010-03-11 03:19:49 +0800
committeritetcu <itetcu@FreeBSD.org>2010-03-11 03:19:49 +0800
commitec57c20f40e4b24ab5e2ca2051252f231a81f803 (patch)
tree80f5a9c33ed87e9317ecd07df13d05377fc2736a
parent094b5118e36bfa4771e724704a5ed0af1e6a62fc (diff)
downloadfreebsd-ports-gnome-ec57c20f40e4b24ab5e2ca2051252f231a81f803.tar.gz
freebsd-ports-gnome-ec57c20f40e4b24ab5e2ca2051252f231a81f803.tar.zst
freebsd-ports-gnome-ec57c20f40e4b24ab5e2ca2051252f231a81f803.zip
- update to 2009 RC2
- obey NOPORTDOCS
-rw-r--r--editors/rospell/Makefile13
-rw-r--r--editors/rospell/distinfo6
-rw-r--r--editors/rospell/files/patch-BSDmakefile94
-rw-r--r--editors/rospell/files/patch-src__rospell__qhelp.cpp20
-rw-r--r--editors/rospell/pkg-plist29
5 files changed, 147 insertions, 15 deletions
diff --git a/editors/rospell/Makefile b/editors/rospell/Makefile
index c9906420c597..57b3320d8649 100644
--- a/editors/rospell/Makefile
+++ b/editors/rospell/Makefile
@@ -5,10 +5,12 @@
# $FreeBSD$
PORTNAME= rospell
-DISTVERSION= 2007.02.rc1
-PORTREVISION= 3
+PORTVERSION= 2009.02.r2
+PORTREVISION= 0
CATEGORIES= editors textproc # this should/will be romanian ;)
-MASTER_SITES= SF/${PORTNAME}/OldFiles
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= rospell/rospell/2008.00
+DISTNAME= ${PORTNAME}-2009.00-rc2
MAINTAINER= itetcu@FreeBSD.org
COMMENT= QT-based editor with support for romanian charsets and spell checking
@@ -27,6 +29,11 @@ MAKEFILE= BSDmakefile
MAN1= rospell.1
+.ifdef NOPORTDOCS
+ALL_TARGET= all-bin
+INSTALL_TARGET= install-bin
+.endif
+
.include <bsd.port.pre.mk>
do-configure:
diff --git a/editors/rospell/distinfo b/editors/rospell/distinfo
index 40339e498942..edc3d57c7e75 100644
--- a/editors/rospell/distinfo
+++ b/editors/rospell/distinfo
@@ -1,3 +1,3 @@
-MD5 (rospell-2007.02.rc1.tar.gz) = 8b26c8706e50619e8665ce0cbddbd435
-SHA256 (rospell-2007.02.rc1.tar.gz) = a828fd16ef4fa632ff8407958524dce94607c43190b44ccef9721562f8084422
-SIZE (rospell-2007.02.rc1.tar.gz) = 1623357
+MD5 (rospell-2009.00-rc2.tar.gz) = 309bb5a333bd4f63b0070fd7fb0921a0
+SHA256 (rospell-2009.00-rc2.tar.gz) = 75862b12d625ef19370df6aa638ea7f0f281351bf63b8f564144e65a4a04792d
+SIZE (rospell-2009.00-rc2.tar.gz) = 2708822
diff --git a/editors/rospell/files/patch-BSDmakefile b/editors/rospell/files/patch-BSDmakefile
new file mode 100644
index 000000000000..7c4ff1fd56af
--- /dev/null
+++ b/editors/rospell/files/patch-BSDmakefile
@@ -0,0 +1,94 @@
+--- ./BSDmakefile.orig 2008-02-27 18:28:25.000000000 +0200
++++ ./BSDmakefile 2010-03-10 20:21:40.736207982 +0200
+@@ -16,8 +16,7 @@
+ BINDIR?= ${PREFIX}/bin
+ DATADIR?= ${PREFIX}/share/rospell
+ DOCSDIR?= ${PREFIX}/share/doc/rospell
+-X11BASE?= /usr/X11R6
+-QT_PREFIX?= ${X11BASE}
++QT_PREFIX?= ${LOCALBASE}
+
+ CC?= gcc
+ CXX?= g++
+@@ -34,7 +33,7 @@
+ .else
+ QTCPPFLAGS+= -DNO_DEBUG -DNO_QT_DEBUG -DUSING_QT3
+ .endif
+-QTCFGLIBS?= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -ljpeg\
++QTCFGLIBS?= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${LOCALBASE}/lib -ljpeg\
+ -L${QT_PREFIX}/lib
+ QTCFGLIBS+= -lqt-mt -lXext -lX11 -lm ${PTHREAD_LIBS}
+
+@@ -71,17 +70,23 @@
+ locale.info misc.info signal.info string.info wchar.info time.info stdlib1.info stdlib2.info stdio1.info stdio2.info \
+ stdio3.info usenix.sty usenix.tex \
+ posixh1.info posixh2.info posixh3.info posixh4.info posixh5.info posixh6.info posixh7.info \
+-posixh8.info posixh9.info posixh10.info posixh11.info HANDBOOK HANDBOOK-RO \
+-rospell_ro.qm qt_ro.qm rospell.1
++posixh8.info posixh9.info posixh10.info posixh11.info rospell_ro.qm qt_ro.qm rospell.1
++PKG_DOC= HANDBOOK HANDBOOK-RO
++
+
+ MANPREFIX?= ${PREFIX}
+ MAN1= rospell.1
+
+-all: ${PROGS} ${PKG_DATA}
++all-bin: ${PROGS} ${PKG_DATA}
++
++all-doc: ${PKG_DOC}
++
++all: all-bin all-doc
+
+ dictfiles.h:
+- @${ECHO_CMD} "---> Configuring for PREFIX=${PREFIX}, DATADIR=${DATADIR} ... "
++ @${ECHO_CMD} "---> Configuring for PREFIX=${PREFIX}, DATADIR=${DATADIR}, DOCSDIR=${DOCSDIR} ... "
+ @${ECHO_CMD} "#define INSTALL_PLACE \"${DATADIR}/\"" > dictfiles.h
++ @${ECHO_CMD} "#define DOC_INSTALL_PLACE \"${DOCSDIR}/\"" >> dictfiles.h
+ @${ECHO_CMD} "#define ROSPELL_FREEBSD" >> dictfiles.h
+ @${ECHO_CMD} "---> Done dictfiles.h."
+
+@@ -231,10 +236,7 @@
+ HANDBOOK-RO:
+ cp src/help/handbook/HANDBOOK-RO HANDBOOK-RO
+
+-
+-
+-install: all
+- @${ECHO_CMD} "---> Installing ... "
++install-bin: all-bin
+ @${ECHO_CMD} "----> Installing binary as ${BINDIR}/rospell ... "
+ @${BSD_INSTALL_PROGRAM} rospell ${BINDIR}/
+ @${ECHO_CMD} "----> Done."
+@@ -291,17 +293,23 @@
+ @${BSD_INSTALL_DATA} posixh10.info ${DATADIR}
+ @${BSD_INSTALL_DATA} posixh11.info ${DATADIR}
+ @${BSD_INSTALL_DATA} src/freebsd/posixh.tags ${DATADIR}
+- @${BSD_INSTALL_DATA} HANDBOOK ${DATADIR}
+ @${ECHO_CMD} "----> Done."
+ @${ECHO_CMD} "----> Installing translation files in ${DATADIR} ... "
+- @${BSD_INSTALL_DATA} HANDBOOK-RO ${DATADIR}
+ @${BSD_INSTALL_DATA} rospell_ro.qm ${DATADIR}
+ @${BSD_INSTALL_DATA} qt_ro.qm ${DATADIR}
+ @${ECHO_CMD} "----> Done."
+ @${ECHO_CMD} "----> Installing man page ... "
+ @${BSD_INSTALL_MAN} rospell.1 ${MANPREFIX}/man/man1/rospell.1
+ @${ECHO_CMD} "----> Done."
+- @${ECHO_CMD} "---> Done installing."
++
++install-doc: all-doc
++ @${ECHO_CMD} "----> Installing documentation in ${DOCSDIR} ..."
++ @${MKDIR} ${DOCSDIR}
++ @${BSD_INSTALL_DATA} HANDBOOK ${DOCSDIR}
++ @${BSD_INSTALL_DATA} HANDBOOK-RO ${DOCSDIR}
++ @${ECHO_CMD} "----> Done."
++
++install: install-bin install-doc
+
+ clean:
+ rm -f ${PROGS} ${PKG_DATA}
+@@ -313,4 +321,5 @@
+ @rm ${BINDIR}/rokloc
+ @rm ${MANPREFIX}/man/man1/rospell.1
+ @rm -Rf ${DATADIR}
++ @rm -Rf ${DOCSDIR}
+ @${ECHO_CMD} "---> Done."
diff --git a/editors/rospell/files/patch-src__rospell__qhelp.cpp b/editors/rospell/files/patch-src__rospell__qhelp.cpp
new file mode 100644
index 000000000000..52b880e7b38e
--- /dev/null
+++ b/editors/rospell/files/patch-src__rospell__qhelp.cpp
@@ -0,0 +1,20 @@
+--- ./src/rospell/qhelp.cpp.orig 2008-10-05 18:09:39.000000000 +0300
++++ ./src/rospell/qhelp.cpp 2010-03-10 20:21:18.839368229 +0200
+@@ -37,14 +37,14 @@
+ QString locale_id = QTextCodec::locale();
+ locale_id.truncate(2);
+ locale_id = locale_id.upper();
+- QString handbook_fname = QString(INSTALL_PLACE) + QString("HANDBOOK-") + locale_id;
++ QString handbook_fname = QString(DOC_INSTALL_PLACE) + QString("HANDBOOK-") + locale_id;
+ if (locale_id == "C")
+- handbook_fname = QString(INSTALL_PLACE) + QString("HANDBOOK");
++ handbook_fname = QString(DOC_INSTALL_PLACE) + QString("HANDBOOK");
+ // read the handbook
+ LOG("try to open %s", (const char *) handbook_fname);
+ char *h = UTILS::read_file_malloc((const char *) handbook_fname);
+ if (h == 0) {
+- handbook_fname = QString(INSTALL_PLACE) + QString("HANDBOOK");
++ handbook_fname = QString(DOC_INSTALL_PLACE) + QString("HANDBOOK");
+ LOG("try to open %s", (const char *) handbook_fname);
+ h = UTILS::read_file_malloc((const char *) handbook_fname);
+ if (h == 0) {
diff --git a/editors/rospell/pkg-plist b/editors/rospell/pkg-plist
index 16a6b2c78def..9069dd39f50e 100644
--- a/editors/rospell/pkg-plist
+++ b/editors/rospell/pkg-plist
@@ -3,9 +3,14 @@ bin/rokloc
bin/rospell
%%DATADIR%%/ctype.info
-%%DATADIR%%/dictionary.en
-%%DATADIR%%/dictionary.fixed
-%%DATADIR%%/dictionary.ro
+%%DATADIR%%/de_DE.aff
+%%DATADIR%%/de_DE.dic
+%%DATADIR%%/en_US.aff
+%%DATADIR%%/en_US.dic
+%%DATADIR%%/es_ES.aff
+%%DATADIR%%/es_ES.dic
+%%DATADIR%%/fr_FR.aff
+%%DATADIR%%/fr_FR.dic
%%DATADIR%%/largefile.info
%%DATADIR%%/latexhelp.tags
%%DATADIR%%/latexhelp1.info
@@ -17,6 +22,8 @@ bin/rospell
%%DATADIR%%/misc.info
%%DATADIR%%/posixh.tags
%%DATADIR%%/posixh1.info
+%%DATADIR%%/posixh10.info
+%%DATADIR%%/posixh11.info
%%DATADIR%%/posixh2.info
%%DATADIR%%/posixh3.info
%%DATADIR%%/posixh4.info
@@ -25,19 +32,23 @@ bin/rospell
%%DATADIR%%/posixh7.info
%%DATADIR%%/posixh8.info
%%DATADIR%%/posixh9.info
-%%DATADIR%%/posixh10.info
-%%DATADIR%%/posixh11.info
+%%DATADIR%%/qt_ro.qm
+%%DATADIR%%/ro_RO.aff
+%%DATADIR%%/ro_RO.dic
+%%DATADIR%%/rospell_ro.qm
%%DATADIR%%/signal.info
-%%DATADIR%%/stdlib1.info
-%%DATADIR%%/stdlib2.info
%%DATADIR%%/stdio1.info
%%DATADIR%%/stdio2.info
%%DATADIR%%/stdio3.info
+%%DATADIR%%/stdlib1.info
+%%DATADIR%%/stdlib2.info
%%DATADIR%%/string.info
%%DATADIR%%/time.info
%%DATADIR%%/usenix.sty
%%DATADIR%%/usenix.tex
%%DATADIR%%/wchar.info
-%%DOCSDIR%%/authors.html
+%%PORTDOCS%%%%DOCSDIR%%/HANDBOOK
+%%PORTDOCS%%%%DOCSDIR%%/HANDBOOK-RO
+
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%