aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-09-25 03:10:51 +0800
committermarcus <marcus@FreeBSD.org>2003-09-25 03:10:51 +0800
commitec5f04c6448162945c298498e32dc2cafa9ee335 (patch)
tree1d9109a2cf717419a1a35386f6f9be4eb28b0ff8
parentdd1293042da1ade073b1dea1bdea5267d210b6bb (diff)
downloadfreebsd-ports-gnome-ec5f04c6448162945c298498e32dc2cafa9ee335.tar.gz
freebsd-ports-gnome-ec5f04c6448162945c298498e32dc2cafa9ee335.tar.zst
freebsd-ports-gnome-ec5f04c6448162945c298498e32dc2cafa9ee335.zip
* s/-pthread/${PTHREAD_LIBS}/
* Use gnometarget
-rw-r--r--math/guppi/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 0462219eb5a6..0b566cb503c2 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -20,15 +20,14 @@ LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal
+USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal gnometarget
USE_PYTHON= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-explicit-python-linking
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/libglade-1.0" \
- LIBS="-L${LOCALBASE}/lib -pthread" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
GNUMERIC_IDLDIR="`cd ${PORTSDIR}/math/gnumeric && ${MAKE} -V WRKSRC`/idl"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION="${PORTVERSION}"
# Can't use BUILD_DEPENDS, because then we have `short circuit' for