aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-09 02:47:12 +0800
committerantoine <antoine@FreeBSD.org>2014-09-09 02:47:12 +0800
commitecd925a43c2cab4df51dc9034a529bef7af66190 (patch)
tree2d23bed083097233c5e55bb8a374675b7f79ad2e
parent62dffb33290e80c47b2570f6d3b7388a3ccfc646 (diff)
downloadfreebsd-ports-gnome-ecd925a43c2cab4df51dc9034a529bef7af66190.tar.gz
freebsd-ports-gnome-ecd925a43c2cab4df51dc9034a529bef7af66190.tar.zst
freebsd-ports-gnome-ecd925a43c2cab4df51dc9034a529bef7af66190.zip
- Allow staging as a regular user (the "permission safeness" is not
needed as dirs are already 0755 and files 0644) - USES=python
-rw-r--r--devel/py-coil/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/devel/py-coil/Makefile b/devel/py-coil/Makefile
index 52d92d18d979..bb4984df927b 100644
--- a/devel/py-coil/Makefile
+++ b/devel/py-coil/Makefile
@@ -13,8 +13,8 @@ COMMENT= Powerful configuration language for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USES= python
+USE_PYTHON= distutils
PORTDOCS= README.txt \
TODO.txt
@@ -25,11 +25,7 @@ post-install:
# docs
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-# permission safeness
- @${CHMOD} -R ${SHAREMODE} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/coil/*
- @${CHMOD} -R a+X ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/coil/*
-
.include <bsd.port.mk>