aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-16 06:44:57 +0800
committerclsung <clsung@FreeBSD.org>2006-08-16 06:44:57 +0800
commitedd017ba8018763eb4c0497cc356408ae39428a2 (patch)
tree2719b6d55656679ecda6c185d18051baad584449
parent79cd50355a6383e21b0e674376e992efe95a70f8 (diff)
downloadfreebsd-ports-gnome-edd017ba8018763eb4c0497cc356408ae39428a2.tar.gz
freebsd-ports-gnome-edd017ba8018763eb4c0497cc356408ae39428a2.tar.zst
freebsd-ports-gnome-edd017ba8018763eb4c0497cc356408ae39428a2.zip
Add p5-Config-IniHash 2.8, perl extension for reading and writing INI
files. PR: ports/102064 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-IniHash/Makefile25
-rw-r--r--devel/p5-Config-IniHash/distinfo3
-rw-r--r--devel/p5-Config-IniHash/pkg-descr3
-rw-r--r--devel/p5-Config-IniHash/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0a5762aa6698..5a9fa5a86e46 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -873,6 +873,7 @@
SUBDIR += p5-Config-General
SUBDIR += p5-Config-INI-Simple
SUBDIR += p5-Config-IniFiles
+ SUBDIR += p5-Config-IniHash
SUBDIR += p5-Config-Objective
SUBDIR += p5-Config-Record
SUBDIR += p5-Config-Setting
diff --git a/devel/p5-Config-IniHash/Makefile b/devel/p5-Config-IniHash/Makefile
new file mode 100644
index 000000000000..36431ad92c83
--- /dev/null
+++ b/devel/p5-Config-IniHash/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Config-IniHash
+# Date created: 2006-08-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-IniHash
+PORTVERSION= 2.8
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for reading and writing INI files
+
+RUN_DEPENDS= ${SITE_PERL}/Hash/Case.pm:${PORTSDIR}/devel/p5-Hash-Case \
+ ${SITE_PERL}/Hash/WithDefaults.pm:${PORTSDIR}/devel/p5-Hash-WithDefaults
+
+PERL_CONFIGURE= yes
+
+MAN3= Config::IniHash.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-IniHash/distinfo b/devel/p5-Config-IniHash/distinfo
new file mode 100644
index 000000000000..e4dd11d2ddd1
--- /dev/null
+++ b/devel/p5-Config-IniHash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Config-IniHash-2.8.tar.gz) = fc8dff4d51cd0380f386e9f35bed59a2
+SHA256 (Config-IniHash-2.8.tar.gz) = 58c4fb1fc4378e2cba7912774642db6d2329371e6f1c871a49e0bbdd33ee3a2c
+SIZE (Config-IniHash-2.8.tar.gz) = 5268
diff --git a/devel/p5-Config-IniHash/pkg-descr b/devel/p5-Config-IniHash/pkg-descr
new file mode 100644
index 000000000000..8251072639a8
--- /dev/null
+++ b/devel/p5-Config-IniHash/pkg-descr
@@ -0,0 +1,3 @@
+This module reads and writes INI files.
+
+WWW: http://search.cpan.org/dist/Config-IniHash/
diff --git a/devel/p5-Config-IniHash/pkg-plist b/devel/p5-Config-IniHash/pkg-plist
new file mode 100644
index 000000000000..311bfbad71b1
--- /dev/null
+++ b/devel/p5-Config-IniHash/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/IniHash/.packlist
+%%SITE_PERL%%/Config/IniHash.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/IniHash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config
+@dirrmtry %%SITE_PERL%%/Config