aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-05-07 21:53:08 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-05-07 21:53:08 +0800
commitee16ed0d994efa56de0ac5a32654bd49049bdf30 (patch)
tree51297b61308797191ff4992bce22ae2e40c5d246
parent50b09dbfb2d506eeb892cdfac0b185ca213e3964 (diff)
downloadfreebsd-ports-gnome-ee16ed0d994efa56de0ac5a32654bd49049bdf30.tar.gz
freebsd-ports-gnome-ee16ed0d994efa56de0ac5a32654bd49049bdf30.tar.zst
freebsd-ports-gnome-ee16ed0d994efa56de0ac5a32654bd49049bdf30.zip
- Use shebangfix macro
- Trim header
-rw-r--r--dns/vizone/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/dns/vizone/Makefile b/dns/vizone/Makefile
index 7aab97805bb3..75d0953c0248 100644
--- a/dns/vizone/Makefile
+++ b/dns/vizone/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vizone
-# Date created: 13 Aug 2007
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= vizone
PORTVERSION= 0.1
@@ -13,15 +9,15 @@ MASTER_SITES= CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Updates the serial number in one or more zonefiles
+USES= shebangfix
USE_PERL5_RUN= yes
NO_BUILD= yes
+SHEBANG_FILES= updserial
+
PORTEXAMPLES= example.tld
PLIST_FILES= bin/vizone bin/updserial
-post-patch:
- @${REINPLACE_CMD} -e '1s|.*|#!${PERL}|' ${WRKSRC}/updserial
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/updserial ${PREFIX}/bin