aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-05-12 20:46:10 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-05-12 20:46:10 +0800
commitee72e08ef0d286d28bcf1e296b53aaa5fc15a2ee (patch)
tree77569a46b373d5f714d6a3c9648434f1e4a13675
parent3be50f4ea9a30331b03e5c71559cfd8f52593632 (diff)
downloadfreebsd-ports-gnome-ee72e08ef0d286d28bcf1e296b53aaa5fc15a2ee.tar.gz
freebsd-ports-gnome-ee72e08ef0d286d28bcf1e296b53aaa5fc15a2ee.tar.zst
freebsd-ports-gnome-ee72e08ef0d286d28bcf1e296b53aaa5fc15a2ee.zip
- Strip library
-rw-r--r--databases/p5-Redis-hiredis/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/databases/p5-Redis-hiredis/Makefile b/databases/p5-Redis-hiredis/Makefile
index 74e6d667175e..461603788abe 100644
--- a/databases/p5-Redis-hiredis/Makefile
+++ b/databases/p5-Redis-hiredis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Redis-hiredis
PORTVERSION= 0.11.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:NEOPHENIX
@@ -15,4 +15,9 @@ COMMENT= Simple wrapper around hiredis C client
USES= perl5
USE_PERL5= configure
+post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Redis/hiredis/hiredis.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Redis/hiredis/hiredis.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Redis/hiredis/hiredis.so
+
.include <bsd.port.mk>