aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2018-05-13 02:59:07 +0800
committerJoe Marcus Clarke <marcus@FreeBSD.org>2018-05-13 02:59:07 +0800
commitef15aa321e6c366f2671595d387ee5a7605f6142 (patch)
treed8454f1f155f5b72e23ce157794319488eb0f7b2
parent4c99d3f3ac1bcbe75f3122e6422ff88ea21157a2 (diff)
downloadfreebsd-ports-gnome-ef15aa321e6c366f2671595d387ee5a7605f6142.tar.gz
freebsd-ports-gnome-ef15aa321e6c366f2671595d387ee5a7605f6142.tar.zst
freebsd-ports-gnome-ef15aa321e6c366f2671595d387ee5a7605f6142.zip
Bump version to 2.18.1.
Soften the py-* dependency error around flavors. Now the message is a warning and a suggestion. This is pending more discussion, but this seems like a good compromise for now. PR: 225654 Requested by: antoine
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl12
2 files changed, 7 insertions, 7 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index daadd9554652..c3445fa15e7c 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.18.0
+PORTVERSION= 2.18.1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index d2d887e3b4d1..7d5dd07dad4f 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.459 2018/05/11 21:26:56 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.461 2018/05/12 18:55:45 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 18;
-my $micro = 0;
+my $micro = 1;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1152,13 +1152,13 @@ sub check_depends_syntax {
$makevar{USE_PYTHON} eq 'noflavors' ||
$makevar{USE_PYTHON} eq '') {
if ($m{'fla'} ne '${PY_FLAVOR}') {
- &perror("FATAL", $file, -1, "directory for dependency ".
- "$m{'dep'} must be $m{'dir'}:\@\${PY_FLAVOR}");
+ &perror("WARN", $file, -1, "you may want directory for ".
+ "dependency $m{'dep'} to be $m{'dir'}:\@\${PY_FLAVOR}");
}
} else {
if ($m{'fla'} ne '${FLAVOR}') {
- &perror("FATAL", $file, -1, "directory for dependency ".
- "$m{'dep'} must be $m{'dir'}:\@\${FLAVOR}");
+ &perror("WARN", $file, -1, "you may want directory for ".
+ "dependency $m{'dep'} to be $m{'dir'}:\@\${FLAVOR}");
}
}
}