aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-09-17 22:54:09 +0800
committerDirk Meyer <dinoex@FreeBSD.org>2009-09-17 22:54:09 +0800
commitefc4da3f1c4d128ad3448c8cf3c397aa516f3e28 (patch)
tree406b2edf1c31ccf7aa4660aea4af72c51f682609
parent869f6f713fd94b9612bb770eb8842d0a05992276 (diff)
downloadfreebsd-ports-gnome-efc4da3f1c4d128ad3448c8cf3c397aa516f3e28.tar.gz
freebsd-ports-gnome-efc4da3f1c4d128ad3448c8cf3c397aa516f3e28.tar.zst
freebsd-ports-gnome-efc4da3f1c4d128ad3448c8cf3c397aa516f3e28.zip
- enable support for plugins.
- new option WITHOUT_PLUGINS Suggested by: rdivacky Feature safe: yes
-rw-r--r--devel/gold/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/devel/gold/Makefile b/devel/gold/Makefile
index 36d503942455..1fe69df459d0 100644
--- a/devel/gold/Makefile
+++ b/devel/gold/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gold
PORTVERSION= 1.9.0.2009.09.16
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.dinoex.de/pub/approved/
DISTNAME= binutils-${PORTNAME}-${PORTVERSION}
@@ -23,6 +24,9 @@ USE_PERL5_BUILD= yes
WRKSRC= ${WRKDIR}/binutils
PLIST_FILES= bin/ld-new
+OPTIONS= PLUGINS "Support fpr plugins" on \
+ NLS "Native language support" off
+
.include <bsd.port.pre.mk>
.if defined(WITH_NLS)
@@ -32,6 +36,10 @@ CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --disable-nls
.endif
+.if !defined(WITHOUT_PLUGINS)
+CONFIGURE_ARGS+= --enable-plugin
+.endif
+
do-configure:
.for i in . libiberty gold
-cd ${WRKSRC}/${i} && \