aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-19 09:08:19 +0800
committerclsung <clsung@FreeBSD.org>2006-07-19 09:08:19 +0800
commitf04a35c6abda314003d6cd52405ba2c460210097 (patch)
treed3ad5212740332b8bdf819e3a506e3b054448ac9
parent6981de2e1726432cbd835fbd8b9886a8ddd96195 (diff)
downloadfreebsd-ports-gnome-f04a35c6abda314003d6cd52405ba2c460210097.tar.gz
freebsd-ports-gnome-f04a35c6abda314003d6cd52405ba2c460210097.tar.zst
freebsd-ports-gnome-f04a35c6abda314003d6cd52405ba2c460210097.zip
Add p5-Time-Duration-Parse 0.02, parse string that represents time
duration. PR: ports/100470 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Time-Duration-Parse/Makefile30
-rw-r--r--devel/p5-Time-Duration-Parse/distinfo3
-rw-r--r--devel/p5-Time-Duration-Parse/pkg-descr13
-rw-r--r--devel/p5-Time-Duration-Parse/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index be87a278d179..cc308b16f8d8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1365,6 +1365,7 @@
SUBDIR += p5-Tie-iCal
SUBDIR += p5-Time-Clock
SUBDIR += p5-Time-Duration
+ SUBDIR += p5-Time-Duration-Parse
SUBDIR += p5-Time-HiRes
SUBDIR += p5-Time-Local
SUBDIR += p5-Time-Object
diff --git a/devel/p5-Time-Duration-Parse/Makefile b/devel/p5-Time-Duration-Parse/Makefile
new file mode 100644
index 000000000000..a6b0d684cb87
--- /dev/null
+++ b/devel/p5-Time-Duration-Parse/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Time-Duration-Parse
+# Date created: 2006-07-18
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Time-Duration-Parse
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Time
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Parse string that represents time duration
+
+RUN_DEPENDS= ${SITE_PERL}/Exporter/Lite.pm:${PORTSDIR}/devel/p5-Exporter-Lite
+
+PERL_CONFIGURE= yes
+
+MAN3= Time::Duration::Parse.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Time-Duration-Parse/distinfo b/devel/p5-Time-Duration-Parse/distinfo
new file mode 100644
index 000000000000..a99940268e21
--- /dev/null
+++ b/devel/p5-Time-Duration-Parse/distinfo
@@ -0,0 +1,3 @@
+MD5 (Time-Duration-Parse-0.02.tar.gz) = 56e1c1674a5180d32927a130fd739d96
+SHA256 (Time-Duration-Parse-0.02.tar.gz) = 620fcf34768ee636beeb6600d966f272ac10a92907f0dae384f9ae32275bdf5a
+SIZE (Time-Duration-Parse-0.02.tar.gz) = 17725
diff --git a/devel/p5-Time-Duration-Parse/pkg-descr b/devel/p5-Time-Duration-Parse/pkg-descr
new file mode 100644
index 000000000000..87ea105296ae
--- /dev/null
+++ b/devel/p5-Time-Duration-Parse/pkg-descr
@@ -0,0 +1,13 @@
+Time::Duration::Parse is a module to parse human readable duration
+strings like 2 minutes and 3 seconds to seconds.
+
+It does the opposite of duration_exact function in Time::Duration and
+is roundtrip safe. So, the following is always true.
+
+ use Time::Duration::Parse;
+ use Time::Duration;
+
+ my $seconds = int rand 100000;
+ is( parse_duration(duration_exact($seconds)), $seconds );
+
+WWW: http://search.cpan.org/dist/Time-Duration-Parse/
diff --git a/devel/p5-Time-Duration-Parse/pkg-plist b/devel/p5-Time-Duration-Parse/pkg-plist
new file mode 100644
index 000000000000..2287f607713f
--- /dev/null
+++ b/devel/p5-Time-Duration-Parse/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Duration/Parse/.packlist
+%%SITE_PERL%%/Time/Duration/Parse.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Duration/Parse
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Duration
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time
+@dirrmtry %%SITE_PERL%%/Time/Duration
+@dirrmtry %%SITE_PERL%%/Time