aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-09-06 13:28:49 +0800
committerswills <swills@FreeBSD.org>2012-09-06 13:28:49 +0800
commitf16fba0ff22f34acdb3de4e82da81b0fe4ba697e (patch)
tree755491c9a2f01c06ed96df901f8b39288972f5df
parent0bd4504c1ad242dbdb7b203b782e835cc110ccab (diff)
downloadfreebsd-ports-gnome-f16fba0ff22f34acdb3de4e82da81b0fe4ba697e.tar.gz
freebsd-ports-gnome-f16fba0ff22f34acdb3de4e82da81b0fe4ba697e.tar.zst
freebsd-ports-gnome-f16fba0ff22f34acdb3de4e82da81b0fe4ba697e.zip
- Convert ruby-gnome ports to proper master/slave setup
Reviewed by: gjb
-rw-r--r--accessibility/ruby-atk/Makefile5
-rw-r--r--devel/ruby-gio2/Makefile5
-rw-r--r--devel/ruby-glib2/Makefile5
-rw-r--r--graphics/ruby-gdk_pixbuf2/Makefile5
-rw-r--r--graphics/ruby-rsvg2/Makefile5
-rw-r--r--x11-toolkits/ruby-goocanvas/Makefile5
-rw-r--r--x11-toolkits/ruby-gstreamer/Makefile5
-rw-r--r--x11-toolkits/ruby-gtk2/Makefile5
-rw-r--r--x11-toolkits/ruby-gtksourceview2/Makefile5
-rw-r--r--x11-toolkits/ruby-pango/Makefile5
-rw-r--r--x11-toolkits/ruby-poppler/Makefile5
-rw-r--r--x11-toolkits/ruby-vte/Makefile5
12 files changed, 48 insertions, 12 deletions
diff --git a/accessibility/ruby-atk/Makefile b/accessibility/ruby-atk/Makefile
index 8f8a60009353..3f60ead372d5 100644
--- a/accessibility/ruby-atk/Makefile
+++ b/accessibility/ruby-atk/Makefile
@@ -27,7 +27,10 @@ USE_GNOME= atk
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+
+.include "${MASTERDIR}/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/atk
INSTALL_TARGET= site-install install
diff --git a/devel/ruby-gio2/Makefile b/devel/ruby-gio2/Makefile
index 22c937f0e687..0e56c16dead4 100644
--- a/devel/ruby-gio2/Makefile
+++ b/devel/ruby-gio2/Makefile
@@ -26,7 +26,10 @@ USE_GNOME= glib20
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+
+.include "${MASTERDIR}/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
INSTALL_TARGET= site-install install
diff --git a/devel/ruby-glib2/Makefile b/devel/ruby-glib2/Makefile
index 655ee5aaa453..04523011ae75 100644
--- a/devel/ruby-glib2/Makefile
+++ b/devel/ruby-glib2/Makefile
@@ -26,8 +26,11 @@ USE_GNOME= glib20
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+.include "${MASTERDIR}/Makefile.common"
+
WRKSRC= ${RUBY_GNOME_WRKSRC}/glib2
INSTALL_TARGET= site-install install
diff --git a/graphics/ruby-gdk_pixbuf2/Makefile b/graphics/ruby-gdk_pixbuf2/Makefile
index 9074e80621ab..0f6c54c69e7f 100644
--- a/graphics/ruby-gdk_pixbuf2/Makefile
+++ b/graphics/ruby-gdk_pixbuf2/Makefile
@@ -27,8 +27,11 @@ USE_GNOME= gtk20
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+.include "${MASTERDIR}/Makefile.common"
+
WRKSRC= ${RUBY_GNOME_WRKSRC}/gdk_pixbuf2
INSTALL_TARGET= site-install install
diff --git a/graphics/ruby-rsvg2/Makefile b/graphics/ruby-rsvg2/Makefile
index 8e1d66089835..83eae81e0481 100644
--- a/graphics/ruby-rsvg2/Makefile
+++ b/graphics/ruby-rsvg2/Makefile
@@ -27,7 +27,10 @@ USE_GNOME= librsvg2
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+
+.include "${MASTERDIR}/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/rsvg2
INSTALL_TARGET= site-install install
diff --git a/x11-toolkits/ruby-goocanvas/Makefile b/x11-toolkits/ruby-goocanvas/Makefile
index 9d3b46e8f1d5..c80bd11ecac3 100644
--- a/x11-toolkits/ruby-goocanvas/Makefile
+++ b/x11-toolkits/ruby-goocanvas/Makefile
@@ -27,8 +27,11 @@ USE_RUBY= yes
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+.include "${MASTERDIR}/Makefile.common"
+
WRKSRC= ${RUBY_GNOME_WRKSRC}/goocanvas
INSTALL_TARGET= site-install install
diff --git a/x11-toolkits/ruby-gstreamer/Makefile b/x11-toolkits/ruby-gstreamer/Makefile
index ee36967d7081..6a0f7e3c61d2 100644
--- a/x11-toolkits/ruby-gstreamer/Makefile
+++ b/x11-toolkits/ruby-gstreamer/Makefile
@@ -27,8 +27,11 @@ USE_GSTREAMER= yes
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+.include "${MASTERDIR}/Makefile.common"
+
WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
INSTALL_TARGET= site-install install
diff --git a/x11-toolkits/ruby-gtk2/Makefile b/x11-toolkits/ruby-gtk2/Makefile
index 25f5ffb2d655..ffc77b318c70 100644
--- a/x11-toolkits/ruby-gtk2/Makefile
+++ b/x11-toolkits/ruby-gtk2/Makefile
@@ -29,8 +29,11 @@ USE_GNOME= gtk20
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+.include "${MASTERDIR}/Makefile.common"
+
WRKSRC= ${RUBY_GNOME_WRKSRC}/gtk2
INSTALL_TARGET= site-install install
diff --git a/x11-toolkits/ruby-gtksourceview2/Makefile b/x11-toolkits/ruby-gtksourceview2/Makefile
index 03cdd251f56e..50b37b779dfc 100644
--- a/x11-toolkits/ruby-gtksourceview2/Makefile
+++ b/x11-toolkits/ruby-gtksourceview2/Makefile
@@ -25,7 +25,10 @@ USE_GNOME= gtksourceview2
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+
+.include "${MASTERDIR}/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/gtksourceview2
INSTALL_TARGET= site-install install
diff --git a/x11-toolkits/ruby-pango/Makefile b/x11-toolkits/ruby-pango/Makefile
index 5958c47cec03..053f9b58ae7e 100644
--- a/x11-toolkits/ruby-pango/Makefile
+++ b/x11-toolkits/ruby-pango/Makefile
@@ -29,8 +29,11 @@ USE_GNOME= pango
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+.include "${MASTERDIR}/Makefile.common"
+
WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
INSTALL_TARGET= site-install install
diff --git a/x11-toolkits/ruby-poppler/Makefile b/x11-toolkits/ruby-poppler/Makefile
index e04d765b2512..0a4a6b1ee7a2 100644
--- a/x11-toolkits/ruby-poppler/Makefile
+++ b/x11-toolkits/ruby-poppler/Makefile
@@ -25,7 +25,10 @@ USE_RUBY= yes
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+
+.include "${MASTERDIR}/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
INSTALL_TARGET= site-install install
diff --git a/x11-toolkits/ruby-vte/Makefile b/x11-toolkits/ruby-vte/Makefile
index 6c176ab21349..daa689fe91eb 100644
--- a/x11-toolkits/ruby-vte/Makefile
+++ b/x11-toolkits/ruby-vte/Makefile
@@ -25,7 +25,10 @@ USE_GNOME= vte
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-pkg-config-dir=${LOCALBASE}/libdata/pkgconfig
-.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+MASTERDIR= ${.CURDIR}/../../x11/ruby-gnome2
+PKGDIR= ${.CURDIR}
+
+.include "${MASTERDIR}/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
INSTALL_TARGET= site-install install