aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormelifaro <melifaro@FreeBSD.org>2013-01-12 21:55:20 +0800
committermelifaro <melifaro@FreeBSD.org>2013-01-12 21:55:20 +0800
commitf214a1c8c2b7e5b4130cc2eefc3d5157c0cc5c10 (patch)
treebc62fdcde1ebb4707e5d4536a9e9e35e0b22cf5b
parent4764939f990b0c7f0d8ed6d82248b30e824b0723 (diff)
downloadfreebsd-ports-gnome-f214a1c8c2b7e5b4130cc2eefc3d5157c0cc5c10.tar.gz
freebsd-ports-gnome-f214a1c8c2b7e5b4130cc2eefc3d5157c0cc5c10.tar.zst
freebsd-ports-gnome-f214a1c8c2b7e5b4130cc2eefc3d5157c0cc5c10.zip
Fix building bird with clang
PR: ports/173942 Submitted by: Olivier Cochard-Labbe <olivier at cochard.me> Approved by: az
-rw-r--r--net/bird/Makefile2
-rw-r--r--net/bird6/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/bird/Makefile b/net/bird/Makefile
index c4d595bc8db8..d1b12486fbf0 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GCC= 4.2+
+USE_CSTD= gnu89
OPTIONS_DEFINE= FIBS FIREWALL AGG
FIBS_DESC= Enable multiple fib support
diff --git a/net/bird6/Makefile b/net/bird6/Makefile
index da0afb4254a7..473de9aa4d8d 100644
--- a/net/bird6/Makefile
+++ b/net/bird6/Makefile
@@ -19,7 +19,7 @@ USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ipv6
-USE_GCC= 4.2+
+USE_CSTD= gnu89
MAKE_JOBS_UNSAFE= yes