aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2016-01-11 15:29:16 +0800
committermiwi <miwi@FreeBSD.org>2016-01-11 15:29:16 +0800
commitf341ee02b514f85a383abca7fef324a8051054fd (patch)
treea5fd1a041e147b1ff5f1d03cdf0835029b3217df
parentc6ee4e001a9e18de87957317195830996860d02c (diff)
downloadfreebsd-ports-gnome-f341ee02b514f85a383abca7fef324a8051054fd.tar.gz
freebsd-ports-gnome-f341ee02b514f85a383abca7fef324a8051054fd.tar.zst
freebsd-ports-gnome-f341ee02b514f85a383abca7fef324a8051054fd.zip
This is is a set of Python bindings for the scrypt key derivation function.
Scrypt is useful when encrypting password as it is possible to specify a minimum amount of time to use when encrypting and decrypting. If, for example, a password takes 0.05 seconds to verify, a user won't notice the slight delay when signing in, but doing a brute force search of several billion passwords will take a considerable amount of time. This is in contrast to more traditional hash functions such as MD5 or the SHA family which can be implemented extremely fast on cheap hardware. WWW: https://pypi.python.org/pypi/scrypt/ PR: 206102 Submitted by: Yuri Victorovich <yuri@rawbw.com>
-rw-r--r--security/Makefile1
-rw-r--r--security/py-scrypt/Makefile26
-rw-r--r--security/py-scrypt/distinfo2
-rw-r--r--security/py-scrypt/pkg-descr11
4 files changed, 40 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 18c2718b9917..59db289a242b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -798,6 +798,7 @@
SUBDIR += py-Products.PlonePAS
SUBDIR += py-Products.PluggableAuthService
SUBDIR += py-RestrictedPython
+ SUBDIR += py-scrypt
SUBDIR += py-SecretStorage
SUBDIR += py-acme
SUBDIR += py-artifacts
diff --git a/security/py-scrypt/Makefile b/security/py-scrypt/Makefile
new file mode 100644
index 000000000000..c73dee81ff75
--- /dev/null
+++ b/security/py-scrypt/Makefile
@@ -0,0 +1,26 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= scrypt
+PORTVERSION= 0.7.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Bindings for the scrypt key derivation function library
+
+LICENSE= BSD2CLAUSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_scrypt.so
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/security/py-scrypt/distinfo b/security/py-scrypt/distinfo
new file mode 100644
index 000000000000..bf9744cebeba
--- /dev/null
+++ b/security/py-scrypt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (scrypt-0.7.1.tar.gz) = f5f68c300c816178384b6531f071a07e705beb1ecd9b37ba8fe3960c20f61da3
+SIZE (scrypt-0.7.1.tar.gz) = 30382
diff --git a/security/py-scrypt/pkg-descr b/security/py-scrypt/pkg-descr
new file mode 100644
index 000000000000..157a58ff9c7f
--- /dev/null
+++ b/security/py-scrypt/pkg-descr
@@ -0,0 +1,11 @@
+This is is a set of Python bindings for the scrypt key derivation function.
+
+Scrypt is useful when encrypting password as it is possible to specify a
+minimum amount of time to use when encrypting and decrypting. If, for example,
+a password takes 0.05 seconds to verify, a user won't notice the slight delay
+when signing in, but doing a brute force search of several billion passwords
+will take a considerable amount of time. This is in contrast to more
+traditional hash functions such as MD5 or the SHA family which can be
+implemented extremely fast on cheap hardware.
+
+WWW: https://pypi.python.org/pypi/scrypt/