aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-06-03 06:24:47 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-06-03 06:24:47 +0800
commitf35e6ed22e539007ce15a07e13532453346f2052 (patch)
tree0029aebf104c7eda2e8fdb2eafa9880a2acb539b
parent2463e6594de28e2de793cc4f9db36acac6a5062a (diff)
downloadfreebsd-ports-gnome-f35e6ed22e539007ce15a07e13532453346f2052.tar.gz
freebsd-ports-gnome-f35e6ed22e539007ce15a07e13532453346f2052.tar.zst
freebsd-ports-gnome-f35e6ed22e539007ce15a07e13532453346f2052.zip
Add rubygem-ed25519 1.2.4
ed25519.rb is a Ruby binding to the Ed25519 elliptic curve public-key signature system described in RFC 8032. Two implementations are provided: a MRI C extension which uses the "ref10" implementation from the SUPERCOP benchmark suite, and a pure Java version based on str4d/ed25519-java. Ed25519 is one of two notable algorithms implemented atop the Curve25519 elliptic curve. The x25519 gem is a related project of this one, and implements the X25519 Diffie-Hellman key exchange algorithm on the Montgomery form of Curve25519. WWW: https://github.com/crypto-rb/ed25519
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-ed25519/Makefile18
-rw-r--r--security/rubygem-ed25519/distinfo3
-rw-r--r--security/rubygem-ed25519/pkg-descr13
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index db97c08b47df..7d3c8f6d4b03 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1103,6 +1103,7 @@
SUBDIR += rubygem-doorkeeper-openid_connect12
SUBDIR += rubygem-doorkeeper-rails5
SUBDIR += rubygem-doorkeeper-rails50
+ SUBDIR += rubygem-ed25519
SUBDIR += rubygem-encryptor
SUBDIR += rubygem-ezcrypto
SUBDIR += rubygem-googleauth
diff --git a/security/rubygem-ed25519/Makefile b/security/rubygem-ed25519/Makefile
new file mode 100644
index 000000000000..344a06fc5668
--- /dev/null
+++ b/security/rubygem-ed25519/Makefile
@@ -0,0 +1,18 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ed25519
+PORTVERSION= 1.2.4
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby binding to the Ed25519 (RFC 8032)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-ed25519/distinfo b/security/rubygem-ed25519/distinfo
new file mode 100644
index 000000000000..fcc31a67f16e
--- /dev/null
+++ b/security/rubygem-ed25519/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527946165
+SHA256 (rubygem/ed25519-1.2.4.gem) = dc62c3491e9484d566519ab2bfca1406c7527694c902e6d05074c3a33ecab3b8
+SIZE (rubygem/ed25519-1.2.4.gem) = 137216
diff --git a/security/rubygem-ed25519/pkg-descr b/security/rubygem-ed25519/pkg-descr
new file mode 100644
index 000000000000..d74af08184ac
--- /dev/null
+++ b/security/rubygem-ed25519/pkg-descr
@@ -0,0 +1,13 @@
+ed25519.rb is a Ruby binding to the Ed25519 elliptic curve public-key signature
+system described in RFC 8032.
+
+Two implementations are provided: a MRI C extension which uses the "ref10"
+implementation from the SUPERCOP benchmark suite, and a pure Java version based
+on str4d/ed25519-java.
+
+Ed25519 is one of two notable algorithms implemented atop the Curve25519
+elliptic curve. The x25519 gem is a related project of this one, and implements
+the X25519 Diffie-Hellman key exchange algorithm on the Montgomery form of
+Curve25519.
+
+WWW: https://github.com/crypto-rb/ed25519