aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2008-05-22 05:24:39 +0800
committerleeym <leeym@FreeBSD.org>2008-05-22 05:24:39 +0800
commitf38f4bb4ed590f5a0526fe0130c4eacec817fdd3 (patch)
tree4bcff3c8a2e48defd49df7c56887a629de946135
parent9062d329b5373dd16f14337fe5996ce7b2982bfb (diff)
downloadfreebsd-ports-gnome-f38f4bb4ed590f5a0526fe0130c4eacec817fdd3.tar.gz
freebsd-ports-gnome-f38f4bb4ed590f5a0526fe0130c4eacec817fdd3.tar.zst
freebsd-ports-gnome-f38f4bb4ed590f5a0526fe0130c4eacec817fdd3.zip
- add CryptoFS 0.6.0
CryptoFS is a encrypted filesystem for Filesystem in Userspace (FUSE) and the Linux Userland FileSystem (LUFS). Visit http://fuse.sourceforge.net/ for more information on FUSE or http://lufs.sourceforge.net/lufs/ for more information on LUFS. CryptoFS will use a normal directory to store files encrypted. The mountpoint will contain the decrypted files. Every file stored in this mountpoint will be written encrypted (data and filename) to the directory that was mounted. If you unmount the directory the encrypted data can only be access by mounting the directory with the correct key again. Like other FUSE/LUFS filesystems it does not need root access or any complicated setup like creating a filesystem on a encrypted disk using the loop device. CryptoFS can be build for FUSE and LUFS. When you build for FUSE you get a program to mount the filesystem. For LUFS a shared library will be built that can be used by LUFS's lufsd. Both methods can use the same encrypted directory. WWW: http://reboot.animeirc.de/cryptofs/
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-cryptofs/Makefile35
-rw-r--r--sysutils/fusefs-cryptofs/distinfo3
-rw-r--r--sysutils/fusefs-cryptofs/pkg-descr19
4 files changed, 58 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index eb8b232173cc..79c80555edc6 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -224,6 +224,7 @@
SUBDIR += ftrace
SUBDIR += ftwin
SUBDIR += fusefs-chironfs
+ SUBDIR += fusefs-cryptofs
SUBDIR += fusefs-curlftpfs
SUBDIR += fusefs-encfs
SUBDIR += fusefs-funionfs
diff --git a/sysutils/fusefs-cryptofs/Makefile b/sysutils/fusefs-cryptofs/Makefile
new file mode 100644
index 000000000000..2a125ae884df
--- /dev/null
+++ b/sysutils/fusefs-cryptofs/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: fusefs-cryptofs
+# Date created: 2008-05-21
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptofs
+PORTVERSION= 0.6.0
+CATEGORIES= sysutils
+MASTER_SITES= http://reboot.animeirc.de/cryptofs/
+PKGNAMEPREFIX= fusefs-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A encrypted filesystem for FUSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+LIB_DEPENDS= gcrypt.15:${PORTSDIR}/security/libgcrypt \
+ glib-2.0:${PORTSDIR}/devel/glib20
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget
+
+PLIST_FILES= bin/cryptofs
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README cryptofs.conf
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-cryptofs/distinfo b/sysutils/fusefs-cryptofs/distinfo
new file mode 100644
index 000000000000..ae3e17bebd40
--- /dev/null
+++ b/sysutils/fusefs-cryptofs/distinfo
@@ -0,0 +1,3 @@
+MD5 (cryptofs-0.6.0.tar.bz2) = 50737307cb91c5936be5fb41133957de
+SHA256 (cryptofs-0.6.0.tar.bz2) = 163174257c32ac9b92195bcd050df9845c35c9eb0bc8860f32608fe541073b03
+SIZE (cryptofs-0.6.0.tar.bz2) = 242440
diff --git a/sysutils/fusefs-cryptofs/pkg-descr b/sysutils/fusefs-cryptofs/pkg-descr
new file mode 100644
index 000000000000..9ee076b12461
--- /dev/null
+++ b/sysutils/fusefs-cryptofs/pkg-descr
@@ -0,0 +1,19 @@
+CryptoFS is a encrypted filesystem for Filesystem in Userspace (FUSE) and
+the Linux Userland FileSystem (LUFS). Visit http://fuse.sourceforge.net/
+for more information on FUSE or http://lufs.sourceforge.net/lufs/ for more
+information on LUFS.
+
+CryptoFS will use a normal directory to store files encrypted. The
+mountpoint will contain the decrypted files. Every file stored in this
+mountpoint will be written encrypted (data and filename) to the directory
+that was mounted. If you unmount the directory the encrypted data can only
+be access by mounting the directory with the correct key again. Like other
+FUSE/LUFS filesystems it does not need root access or any complicated setup
+like creating a filesystem on a encrypted disk using the loop device.
+
+CryptoFS can be build for FUSE and LUFS. When you build for FUSE you get a
+program to mount the filesystem. For LUFS a shared library will be built
+that can be used by LUFS's lufsd. Both methods can use the same encrypted
+directory.
+
+WWW: http://reboot.animeirc.de/cryptofs/