aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-04-06 09:38:55 +0800
committerjbeich <jbeich@FreeBSD.org>2016-04-06 09:38:55 +0800
commitf3b8b2f5cbca0c0008386f268b36235faf51e8fa (patch)
treebadddd54eefc6f08b8aad6d5502a5fae004bbbab
parent3ef8e9638bce48de1d1e9f7cda36278f673f8b1f (diff)
downloadfreebsd-ports-gnome-f3b8b2f5cbca0c0008386f268b36235faf51e8fa.tar.gz
freebsd-ports-gnome-f3b8b2f5cbca0c0008386f268b36235faf51e8fa.tar.zst
freebsd-ports-gnome-f3b8b2f5cbca0c0008386f268b36235faf51e8fa.zip
multimedia/ffms2: add new port
FFmpegSource (usually known as FFMS or FFMS2) is a cross-platform wrapper library around FFmpeg/libav. It gives you an easy, convenient way to say "open and decompress this media file for me, I don't care how you do it" and get frame- and sample-accurate access (usually), without having to bother with the sometimes less than straightforward and less than perfectly documented libav API. https://github.com/FFMS/ffms2
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/ffms2/Makefile25
-rw-r--r--multimedia/ffms2/distinfo2
-rw-r--r--multimedia/ffms2/pkg-descr8
-rw-r--r--multimedia/ffms2/pkg-plist10
5 files changed, 46 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index a137c45b7d54..5ad6e7ac484c 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -59,6 +59,7 @@
SUBDIR += ffmpeg0
SUBDIR += ffmpeg2theora
SUBDIR += ffmpegthumbnailer
+ SUBDIR += ffms2
SUBDIR += flvmeta
SUBDIR += flvstreamer
SUBDIR += flvtool++
diff --git a/multimedia/ffms2/Makefile b/multimedia/ffms2/Makefile
new file mode 100644
index 000000000000..d4b14ece7aa7
--- /dev/null
+++ b/multimedia/ffms2/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= ffms2
+DISTVERSION= 2.22
+CATEGORIES= multimedia
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= FFmpeg-based source library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
+
+USE_GITHUB= yes
+GH_ACCOUNT= FFMS
+
+USES= compiler:c++11-lib gmake libtool pathfix pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules --enable-static
+CPPFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/ffms2/distinfo b/multimedia/ffms2/distinfo
new file mode 100644
index 000000000000..5d8aef2faa6f
--- /dev/null
+++ b/multimedia/ffms2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (FFMS-ffms2-2.22_GH0.tar.gz) = 7c5202fa2e49186fb3bb815e5b12ca71f05ec09cb707ffd9465852e21a06fdad
+SIZE (FFMS-ffms2-2.22_GH0.tar.gz) = 487244
diff --git a/multimedia/ffms2/pkg-descr b/multimedia/ffms2/pkg-descr
new file mode 100644
index 000000000000..f56e74ae28e3
--- /dev/null
+++ b/multimedia/ffms2/pkg-descr
@@ -0,0 +1,8 @@
+FFmpegSource (usually known as FFMS or FFMS2) is a cross-platform
+wrapper library around FFmpeg/libav. It gives you an easy, convenient
+way to say "open and decompress this media file for me, I don't care
+how you do it" and get frame- and sample-accurate access (usually),
+without having to bother with the sometimes less than straightforward
+and less than perfectly documented libav API.
+
+WWW: https://github.com/FFMS/ffms2
diff --git a/multimedia/ffms2/pkg-plist b/multimedia/ffms2/pkg-plist
new file mode 100644
index 000000000000..1e3113cd3e6d
--- /dev/null
+++ b/multimedia/ffms2/pkg-plist
@@ -0,0 +1,10 @@
+bin/ffmsindex
+include/ffms.h
+include/ffmscompat.h
+lib/libffms2.a
+lib/libffms2.so
+lib/libffms2.so.4
+lib/libffms2.so.4.0.0
+libdata/pkgconfig/ffms2.pc
+%%PORTDOCS%%%%DOCSDIR%%/ffms2-api.md
+%%PORTDOCS%%%%DOCSDIR%%/ffms2-changelog.md