aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-07-09 01:14:24 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-07-09 01:14:24 +0800
commitf3b93777e3abe591d437950b52a44bca3763009f (patch)
treef74e76774dd76664a832b7f5eb9f98e43950dfc7
parent23e3856f1e3db48e5c13bf9e0ee38219d63bdfaf (diff)
downloadfreebsd-ports-gnome-f3b93777e3abe591d437950b52a44bca3763009f.tar.gz
freebsd-ports-gnome-f3b93777e3abe591d437950b52a44bca3763009f.tar.zst
freebsd-ports-gnome-f3b93777e3abe591d437950b52a44bca3763009f.zip
- Disconnect tests from the build fixing build on 8.x
PR: 201314 Submitted by: cyberbotx@cyberbotx.com (maintainer)
-rw-r--r--graphics/libspiro/files/patch-Makefile.am38
-rw-r--r--graphics/libspiro/files/patch-tests_Makefile.am11
2 files changed, 34 insertions, 15 deletions
diff --git a/graphics/libspiro/files/patch-Makefile.am b/graphics/libspiro/files/patch-Makefile.am
index bb8529f48d04..6d1690dc35bb 100644
--- a/graphics/libspiro/files/patch-Makefile.am
+++ b/graphics/libspiro/files/patch-Makefile.am
@@ -1,11 +1,41 @@
---- Makefile.am.orig 2015-01-31 19:29:34 UTC
+--- Makefile.am.orig 2015-07-02 13:50:20 UTC
+++ Makefile.am
-@@ -2,7 +2,7 @@
+@@ -1,8 +1,8 @@
+ # Makefile.am - Top level automakefile for libspiro
- SUBDIRS = . tests
+-SUBDIRS = . tests
++SUBDIRS = .
-pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = ${PREFIX}/libdata/pkgconfig
++pkgconfigdir = ${PREFIX}/libdata/pkgconfig
pkgconfig_DATA = libspiro.pc
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+@@ -13,7 +13,7 @@ AM_LDFLAGS = $(WLSLIB) $(LS_LIB) -no-und
+ LIBTOOL_DEPS = @LIBTOOL_DEPS@
+
+ DISTCLEANFILES = libspiro.pc
+-DISTCHECK_CONFIGURE_FLAGS = --enable-verbose_lib --enable-test_inputs
++DISTCHECK_CONFIGURE_FLAGS = --enable-verbose_lib --disable-test_inputs
+
+ lib_LTLIBRARIES = libspiro.la
+
+@@ -26,17 +26,10 @@ EXTRA_DIST = bezctx.md get-spiro-src.sh
+ java/ShowPlate.java java/Spiro.java java/SpiroBezierContext.java \
+ java/SpiroCanvas.java java/SpiroCP.java java/SpiroGeneralPath.java \
+ java/SpiroPointType.java README-GeorgeWilliams fontforge-debug.txt \
+- fontforge.sh m4/ax_check_compile_flag.m4 tests/call-test.c
++ fontforge.sh m4/ax_check_compile_flag.m4
+
+ include_HEADERS = bezctx.h bezctx_intf.h spiro.h spiroentrypoints.h
+
+ libtool: $(LIBTOOL_DEPS)
+ $(SHELL) ./config.status libtool
+
+-# test: run all tests in cwd and subdirs
+-test: ${TEST_PROGS}
+-
+-.PHONY: test
+-# run make test as part of make check
+-check-local: test
+-
diff --git a/graphics/libspiro/files/patch-tests_Makefile.am b/graphics/libspiro/files/patch-tests_Makefile.am
deleted file mode 100644
index a38765590dfa..000000000000
--- a/graphics/libspiro/files/patch-tests_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- tests/Makefile.am.orig 2015-07-02 13:50:20 UTC
-+++ tests/Makefile.am
-@@ -1,7 +1,7 @@
- # Common CPPFLAGS
- AM_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir)
-
--AM_CFLAGS = -I$(top_srcdir) -I$(top_builddir) $(DEP_CFLAGS) $(BABL_CFLAGS) -lm
-+AM_CFLAGS = -I$(top_srcdir) -I$(top_builddir) $(DEP_CFLAGS) $(BABL_CFLAGS) -lm -lcompat
-
- DEPS = $(top_builddir)/.libs/libspiro.la
-