aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-17 05:50:40 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-17 05:50:40 +0800
commitf534f1ef7e6dbe918be27755bd0245fc420a1cf9 (patch)
treea824a4290af60f94d1d3ef0b24088b6b2434ab1d
parent23b8fda4663eff3018be19a713a6135650aca15c (diff)
downloadfreebsd-ports-gnome-f534f1ef7e6dbe918be27755bd0245fc420a1cf9.tar.gz
freebsd-ports-gnome-f534f1ef7e6dbe918be27755bd0245fc420a1cf9.tar.zst
freebsd-ports-gnome-f534f1ef7e6dbe918be27755bd0245fc420a1cf9.zip
Pang Zero is a clone of Super Pang, a fast-paced action game that involves
popping balloons with a harpoon. The intention of our effort is to create a fun, open-source game that many (currently up to 6) people can play together. WWW: http://apocalypse.rulez.org/pangzero PR: ports/179092 Submitted by: nemysis (self) Approved by: wg/pawel (mentors)
-rw-r--r--games/Makefile1
-rw-r--r--games/pangzero/Makefile50
-rw-r--r--games/pangzero/distinfo4
-rw-r--r--games/pangzero/files/pangzero.in7
-rw-r--r--games/pangzero/pkg-descr6
-rw-r--r--games/pangzero/pkg-plist103
6 files changed, 171 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 743c36d043fa..7f0422791744 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -699,6 +699,7 @@
SUBDIR += pairs
SUBDIR += palapeli
SUBDIR += palomino
+ SUBDIR += pangzero
SUBDIR += passage
SUBDIR += patapizza-tetris
SUBDIR += pathological
diff --git a/games/pangzero/Makefile b/games/pangzero/Makefile
new file mode 100644
index 000000000000..bed8c0c6e167
--- /dev/null
+++ b/games/pangzero/Makefile
@@ -0,0 +1,50 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pangzero
+PORTVERSION= 1.3
+CATEGORIES= games
+MASTER_SITES= SF \
+ SF/nemysisfreebsdp/Apocalypse/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Clone of Super Pang
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= p5-Carp>=0:${PORTSDIR}/devel/p5-Carp \
+ p5-SDL>=0:${PORTSDIR}/devel/p5-SDL
+
+USES= perl5
+NO_BUILD= yes
+
+PORTDOCS= AUTHORS ChangeLog README
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="Pang Zero" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ActionGame;" false
+
+.include <bsd.port.options.mk>
+
+post-extract:
+ @${FIND} ${WRKSRC} -name "Makefile*" -delete
+.for f in *.png *.jpg
+ @${CP} -a ${WRKDIR}/${f} ${WRKSRC}/data
+.endfor
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "bin data" ${STAGEDIR}${DATADIR})
+
+ ${LN} -sf ${DATADIR}/data/icon.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/pangzero/distinfo b/games/pangzero/distinfo
new file mode 100644
index 000000000000..934d6c202691
--- /dev/null
+++ b/games/pangzero/distinfo
@@ -0,0 +1,4 @@
+SHA256 (pangzero-1.3.tar.gz) = 9e18c8d3aa06667f2b88ca98c6c59198e37e7b1c6c31aaff25c9bc66b70fd962
+SIZE (pangzero-1.3.tar.gz) = 3049841
+SHA256 (pangzero_icons.tar.gz) = 1bd181638ca45889e178b59aaa9147daba56ca91513adad9c3439102a3388645
+SIZE (pangzero_icons.tar.gz) = 765952
diff --git a/games/pangzero/files/pangzero.in b/games/pangzero/files/pangzero.in
new file mode 100644
index 000000000000..751796373579
--- /dev/null
+++ b/games/pangzero/files/pangzero.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"/bin
+exec /usr/bin/env perl ./pangzero "${@}"
diff --git a/games/pangzero/pkg-descr b/games/pangzero/pkg-descr
new file mode 100644
index 000000000000..89908fb4ebe5
--- /dev/null
+++ b/games/pangzero/pkg-descr
@@ -0,0 +1,6 @@
+Pang Zero is a clone of Super Pang, a fast-paced action game that involves
+popping balloons with a harpoon. The intention of our effort is to create
+a fun, open-source game that many (currently up to 6) people can play
+together.
+
+WWW: http://apocalypse.rulez.org/pangzero
diff --git a/games/pangzero/pkg-plist b/games/pangzero/pkg-plist
new file mode 100644
index 000000000000..56790e27715a
--- /dev/null
+++ b/games/pangzero/pkg-plist
@@ -0,0 +1,103 @@
+bin/pangzero
+%%DATADIR%%/bin/pangzero
+%%DATADIR%%/data/Balls-Bouncy16.png
+%%DATADIR%%/data/Balls-Bouncy32.png
+%%DATADIR%%/data/Balls-Bouncy64.png
+%%DATADIR%%/data/Balls-Death64.png
+%%DATADIR%%/data/Balls-EarthQ16.png
+%%DATADIR%%/data/Balls-EarthQ32.png
+%%DATADIR%%/data/Balls-EarthQ64.png
+%%DATADIR%%/data/Balls-Fragile128.png
+%%DATADIR%%/data/Balls-Fragile16.png
+%%DATADIR%%/data/Balls-Fragile32.png
+%%DATADIR%%/data/Balls-Fragile64.png
+%%DATADIR%%/data/Balls-Fragile96.png
+%%DATADIR%%/data/Balls-Red128.png
+%%DATADIR%%/data/Balls-Red16.png
+%%DATADIR%%/data/Balls-Red32.png
+%%DATADIR%%/data/Balls-Red64.png
+%%DATADIR%%/data/Balls-Red96.png
+%%DATADIR%%/data/Balls-Seeker32.png
+%%DATADIR%%/data/Balls-Seeker64.png
+%%DATADIR%%/data/Balls-Snow128.png
+%%DATADIR%%/data/Balls-Snow16.png
+%%DATADIR%%/data/Balls-Snow32.png
+%%DATADIR%%/data/Balls-Snow64.png
+%%DATADIR%%/data/Balls-Snow96.png
+%%DATADIR%%/data/Balls-SuperClock64.png
+%%DATADIR%%/data/Balls-SuperClock96.png
+%%DATADIR%%/data/Balls-SuperStar64.png
+%%DATADIR%%/data/Balls-SuperStar96.png
+%%DATADIR%%/data/Balls-Upside128.png
+%%DATADIR%%/data/Balls-Upside16.png
+%%DATADIR%%/data/Balls-Upside32.png
+%%DATADIR%%/data/Balls-Upside64.png
+%%DATADIR%%/data/Balls-Upside96.png
+%%DATADIR%%/data/Balls-Water16.png
+%%DATADIR%%/data/Balls-Water32.png
+%%DATADIR%%/data/Balls-Water64.png
+%%DATADIR%%/data/Balls-Water96.png
+%%DATADIR%%/data/Balls-XMAS128.png
+%%DATADIR%%/data/Hexa-16.png
+%%DATADIR%%/data/Hexa-32.png
+%%DATADIR%%/data/Hexa-64.png
+%%DATADIR%%/data/Quad.png
+%%DATADIR%%/data/UPiPang.mid
+%%DATADIR%%/data/UPiPang.mp3
+%%DATADIR%%/data/ball.png
+%%DATADIR%%/data/bonus.png
+%%DATADIR%%/data/border-lighted-theme.png
+%%DATADIR%%/data/border-xmas-theme.png
+%%DATADIR%%/data/border.png
+%%DATADIR%%/data/brandybun3.png
+%%DATADIR%%/data/christmas_candle.jpg
+%%DATADIR%%/data/christmas_house.jpg
+%%DATADIR%%/data/christmas_houses.jpg
+%%DATADIR%%/data/christmas_tree.jpg
+%%DATADIR%%/data/christmas_trees.jpg
+%%DATADIR%%/data/desert2.png
+%%DATADIR%%/data/fireplace.jpg
+%%DATADIR%%/data/font2.png
+%%DATADIR%%/data/gameover.png
+%%DATADIR%%/data/glossyfont.png
+%%DATADIR%%/data/gun.voc
+%%DATADIR%%/data/guy.png
+%%DATADIR%%/data/guyChristmas.png
+%%DATADIR%%/data/guy_danigm.png
+%%DATADIR%%/data/guy_pix.png
+%%DATADIR%%/data/guy_pux.png
+%%DATADIR%%/data/guy_r2.png
+%%DATADIR%%/data/guy_sonic.png
+%%DATADIR%%/data/harpoon.png
+%%DATADIR%%/data/hexa.png
+%%DATADIR%%/data/icon.ico
+%%DATADIR%%/data/icon.png
+%%DATADIR%%/data/l1.jpg
+%%DATADIR%%/data/l2.jpg
+%%DATADIR%%/data/l3.jpg
+%%DATADIR%%/data/l4.jpg
+%%DATADIR%%/data/l5.jpg
+%%DATADIR%%/data/l6.jpg
+%%DATADIR%%/data/l7.jpg
+%%DATADIR%%/data/l8.jpg
+%%DATADIR%%/data/l9.jpg
+%%DATADIR%%/data/level.png
+%%DATADIR%%/data/level.voc
+%%DATADIR%%/data/level_empty.png
+%%DATADIR%%/data/magic.voc
+%%DATADIR%%/data/meltdown.png
+%%DATADIR%%/data/meow.voc
+%%DATADIR%%/data/pangzero.png
+%%DATADIR%%/data/paused.png
+%%DATADIR%%/data/pop.voc
+%%DATADIR%%/data/pop3.voc
+%%DATADIR%%/data/quake.voc
+%%DATADIR%%/data/santa.png
+%%DATADIR%%/data/shoot.voc
+%%DATADIR%%/data/super.voc
+%%DATADIR%%/data/xmas-dawn.jpg
+%%DATADIR%%/data/xmas-night.jpg
+share/pixmaps/pangzero.png
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%