aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2015-08-14 02:59:59 +0800
committermi <mi@FreeBSD.org>2015-08-14 02:59:59 +0800
commitf597eec1b3a1205e70f6b8630d6a596742b0a4ce (patch)
tree85e841b506cd163a26b0b23b9f256fea96bff8a8
parent02f0bb1028391d52b603fcd29743471508bc6a6b (diff)
downloadfreebsd-ports-gnome-f597eec1b3a1205e70f6b8630d6a596742b0a4ce.tar.gz
freebsd-ports-gnome-f597eec1b3a1205e70f6b8630d6a596742b0a4ce.tar.zst
freebsd-ports-gnome-f597eec1b3a1205e70f6b8630d6a596742b0a4ce.zip
Stop using the "legacy" fmake, adjust the Makefile to work
with the newer bmake. PR: 201208 Submitted by: amdmi3
-rw-r--r--x11-fonts/cyr-rfx/Makefile2
-rw-r--r--x11-fonts/cyr-rfx/files/Makefile.bdf2pcf7
2 files changed, 4 insertions, 5 deletions
diff --git a/x11-fonts/cyr-rfx/Makefile b/x11-fonts/cyr-rfx/Makefile
index f27d02772658..17f488b9df95 100644
--- a/x11-fonts/cyr-rfx/Makefile
+++ b/x11-fonts/cyr-rfx/Makefile
@@ -16,7 +16,7 @@ COMMENT= Cyrillic X11 bitmap fonts from CYR-RFX project
BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
-USES= fonts fmake
+USES= fonts
USE_XORG= x11
CYR_RFX_ENCODING?= koi8-o
diff --git a/x11-fonts/cyr-rfx/files/Makefile.bdf2pcf b/x11-fonts/cyr-rfx/files/Makefile.bdf2pcf
index d5eb06029a96..93a1445e1839 100644
--- a/x11-fonts/cyr-rfx/files/Makefile.bdf2pcf
+++ b/x11-fonts/cyr-rfx/files/Makefile.bdf2pcf
@@ -1,6 +1,5 @@
-VPATH= ${.CURDIR}/75dpi:${.CURDIR}/misc
-BDFS!= echo ${VPATH:S,:,/*.bdf ,}/*.bdf
-PCFS= ${BDFS:T:S/.bdf/.pcf.gz/}
+BDFS!= echo 75dpi/*.bdf misc/*.bdf
+PCFS= ${BDFS:S/.bdf/.pcf.gz/}
.SUFFIXES: .bdf .pcf.gz
@@ -9,7 +8,7 @@ all: fonts.dir fonts.alias ${PCFS}
fonts.dir: ${PCFS}
mkfontdir .
-fonts.alias: ${VPATH:S,:,/fonts.alias ,}/fonts.alias
+fonts.alias: 75dpi/fonts.alias misc/fonts.alias
cat ${.ALLSRC} > ${.TARGET}
.bdf.pcf.gz: