aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-07-10 06:15:01 +0800
committerrakuco <rakuco@FreeBSD.org>2013-07-10 06:15:01 +0800
commitf6106d97f120148f46c2ec3681031be416572d32 (patch)
tree841d04c234607276a1bddd24bcc489df31b34b97
parent753ce7f8fa3c566a19f1517188484c67ad7b203e (diff)
downloadfreebsd-ports-gnome-f6106d97f120148f46c2ec3681031be416572d32.tar.gz
freebsd-ports-gnome-f6106d97f120148f46c2ec3681031be416572d32.tar.zst
freebsd-ports-gnome-f6106d97f120148f46c2ec3681031be416572d32.zip
Add upstream commit that fixes a plasma-desktop crash in x11/kde4-workspace.
The upstream bug report can be found in [1], the commit itself is in [2]. [1] https://bugreports.qt-project.org/browse/QTBUG-29082 [2] http://qt.gitorious.org/qt/qtbase/commit/f0221d359499f675115da1f47dd3669a4383653d Submitted by: avg
-rw-r--r--devel/qt4-corelib/Makefile2
-rw-r--r--devel/qt4-corelib/files/patch-src__corelib__animation__qpropertyanimation.cpp16
2 files changed, 17 insertions, 1 deletions
diff --git a/devel/qt4-corelib/Makefile b/devel/qt4-corelib/Makefile
index 20d25aa7324b..ff3637219380 100644
--- a/devel/qt4-corelib/Makefile
+++ b/devel/qt4-corelib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= corelib
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
diff --git a/devel/qt4-corelib/files/patch-src__corelib__animation__qpropertyanimation.cpp b/devel/qt4-corelib/files/patch-src__corelib__animation__qpropertyanimation.cpp
new file mode 100644
index 000000000000..69543b919312
--- /dev/null
+++ b/devel/qt4-corelib/files/patch-src__corelib__animation__qpropertyanimation.cpp
@@ -0,0 +1,16 @@
+--- src/corelib/animation/qpropertyanimation.cpp.orig
++++ src/corelib/animation/qpropertyanimation.cpp
+@@ -136,8 +136,11 @@ void QPropertyAnimationPrivate::updateProperty(const QVariant &newValue)
+
+ if (newValue.userType() == propertyType) {
+ //no conversion is needed, we directly call the QMetaObject::metacall
+- void *data = const_cast<void*>(newValue.constData());
+- QMetaObject::metacall(targetValue, QMetaObject::WriteProperty, propertyIndex, &data);
++ //check QMetaProperty::write for an explanation of these
++ int status = -1;
++ int flags = 0;
++ void *argv[] = { const_cast<void *>(newValue.constData()), const_cast<QVariant *>(&newValue), &status, &flags };
++ QMetaObject::metacall(targetValue, QMetaObject::WriteProperty, propertyIndex, argv);
+ } else {
+ targetValue->setProperty(propertyName.constData(), newValue);
+ }