aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-01-13 03:48:01 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-01-13 03:48:01 +0800
commitf725cd01550b5ed6fa0ea6a1b0b007a9574599d2 (patch)
tree0eba94182b3111b743074c3caf01849fcf9412eb
parent0c1bd06c7a02f3e3fd91087fdb1c4e1e88a3db3f (diff)
downloadfreebsd-ports-gnome-f725cd01550b5ed6fa0ea6a1b0b007a9574599d2.tar.gz
freebsd-ports-gnome-f725cd01550b5ed6fa0ea6a1b0b007a9574599d2.tar.zst
freebsd-ports-gnome-f725cd01550b5ed6fa0ea6a1b0b007a9574599d2.zip
Add tapidbus 0.2.1, an abstraction layer for interprocess communication.
PR: ports/91671 Submitted by: Babak Farrokhi
-rw-r--r--net/Makefile1
-rw-r--r--net/tapidbus/Makefile33
-rw-r--r--net/tapidbus/distinfo3
-rw-r--r--net/tapidbus/files/patch-Makefile.am11
-rw-r--r--net/tapidbus/files/patch-configure12
-rw-r--r--net/tapidbus/pkg-descr3
-rw-r--r--net/tapidbus/pkg-plist7
7 files changed, 70 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 09c398b5ab21..65b2bc43151e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -741,6 +741,7 @@
SUBDIR += tac_plus-libradius
SUBDIR += tac_plus4
SUBDIR += tacshell
+ SUBDIR += tapidbus
SUBDIR += tcpcat
SUBDIR += tcpdstat
SUBDIR += tcpdump
diff --git a/net/tapidbus/Makefile b/net/tapidbus/Makefile
new file mode 100644
index 000000000000..bfcd6062daaa
--- /dev/null
+++ b/net/tapidbus/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: tapidbus
+# Date created: 2006-01-11
+# Whom: Babak Farrokhi
+#
+# $FreeBSD$
+#
+
+PORTNAME= tapidbus
+PORTVERSION= 0.2.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tapioca-voip
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Abstraction layer for interprocess communication
+
+LIB_DEPENDS= dbus-1.2:${PORTSDIR}/devel/dbus
+
+USE_AUTOTOOLS= libtool:15
+USE_GMAKE= yes
+USE_GNOME= pkgconfig glib20 gnomehack
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV+= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\-O2||' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/net/tapidbus/distinfo b/net/tapidbus/distinfo
new file mode 100644
index 000000000000..33f602dc86a9
--- /dev/null
+++ b/net/tapidbus/distinfo
@@ -0,0 +1,3 @@
+MD5 (tapidbus-0.2.1.tar.gz) = d704c2df28d2d1eea6c31b50cc07b057
+SHA256 (tapidbus-0.2.1.tar.gz) = 7144c94faa370c7792164db707a02b8508ec2507c0c84ba64f0b3f0ebac23949
+SIZE (tapidbus-0.2.1.tar.gz) = 327946
diff --git a/net/tapidbus/files/patch-Makefile.am b/net/tapidbus/files/patch-Makefile.am
new file mode 100644
index 000000000000..3c8bff2ab4ac
--- /dev/null
+++ b/net/tapidbus/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig Thu Jan 12 17:32:26 2006
++++ Makefile.am Thu Jan 12 17:33:19 2006
+@@ -9,7 +9,7 @@
+ %-@TAPIDBUS_MAJORMINOR@.pc: %.pc
+ cp $< $@
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = $(pcfiles)
+
+ include aminclude.am
diff --git a/net/tapidbus/files/patch-configure b/net/tapidbus/files/patch-configure
new file mode 100644
index 000000000000..2fc05fca8e70
--- /dev/null
+++ b/net/tapidbus/files/patch-configure
@@ -0,0 +1,12 @@
+--- configure.orig Wed Jan 11 17:28:18 2006
++++ configure Wed Jan 11 17:28:48 2006
+@@ -19213,7 +19213,8 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+-
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
++
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+
diff --git a/net/tapidbus/pkg-descr b/net/tapidbus/pkg-descr
new file mode 100644
index 000000000000..ce5f1d5fbf07
--- /dev/null
+++ b/net/tapidbus/pkg-descr
@@ -0,0 +1,3 @@
+An abstraction layer that uses dbus for interprocess communication.
+
+WWW: http://tapioca-voip.sourceforge.net/
diff --git a/net/tapidbus/pkg-plist b/net/tapidbus/pkg-plist
new file mode 100644
index 000000000000..fc185fabdee3
--- /dev/null
+++ b/net/tapidbus/pkg-plist
@@ -0,0 +1,7 @@
+include/tapidbus-0.2/tapidbus/tapidbus.h
+lib/libtapidbus-0.2.a
+lib/libtapidbus-0.2.so
+lib/libtapidbus-0.2.so.0
+libdata/pkgconfig/tapidbus-0.2.pc
+@dirrm include/tapidbus-0.2/tapidbus
+@dirrm include/tapidbus-0.2