aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-03-29 15:04:47 +0800
committerkris <kris@FreeBSD.org>2004-03-29 15:04:47 +0800
commitf73f31dac4abb6adbd73cc70f3f4f79cec0606d3 (patch)
treec58bc93426ceb849c5e5834a5b63190244b1ffb0
parenteb800addf0822555abd6a184f988186555151f9d (diff)
downloadfreebsd-ports-gnome-f73f31dac4abb6adbd73cc70f3f4f79cec0606d3.tar.gz
freebsd-ports-gnome-f73f31dac4abb6adbd73cc70f3f4f79cec0606d3.tar.zst
freebsd-ports-gnome-f73f31dac4abb6adbd73cc70f3f4f79cec0606d3.zip
BROKEN on !i386 and !alpha: Does not build
-rw-r--r--devel/avr-gcc-3/Makefile8
-rw-r--r--devel/avr-gcc/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index b80381b0e6fa..122778bce0cf 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -48,6 +48,12 @@ MAN1= cpp.1 avr-gcc.1 avr-g++.1 gcov.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
INFO= cpp gcc gccint cppinternals
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Does not build on !i386 and !alpha"
+.endif
+
# Since the pod2man in FreeBSD 4-stable's /usr/bin cannot be used, we
# help out by extracting precompiled manpages there.
pre-build:
@@ -58,4 +64,4 @@ pre-build:
${TAR} -xvzf ${DISTDIR}/${MAN_AUX} ; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index b80381b0e6fa..122778bce0cf 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -48,6 +48,12 @@ MAN1= cpp.1 avr-gcc.1 avr-g++.1 gcov.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
INFO= cpp gcc gccint cppinternals
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Does not build on !i386 and !alpha"
+.endif
+
# Since the pod2man in FreeBSD 4-stable's /usr/bin cannot be used, we
# help out by extracting precompiled manpages there.
pre-build:
@@ -58,4 +64,4 @@ pre-build:
${TAR} -xvzf ${DISTDIR}/${MAN_AUX} ; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>