aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-06-25 07:02:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-06-25 07:02:07 +0800
commitf748d481791434127e0fd9ddf496073a331a0663 (patch)
tree32f9cbad951f64c722303676030020d86ed19649
parentbb5e82d02d4fe0c356bcf9fde596a7c1b175c04f (diff)
downloadfreebsd-ports-gnome-f748d481791434127e0fd9ddf496073a331a0663.tar.gz
freebsd-ports-gnome-f748d481791434127e0fd9ddf496073a331a0663.tar.zst
freebsd-ports-gnome-f748d481791434127e0fd9ddf496073a331a0663.zip
- Bump PORTREVISION for multimedia/quvi shlib change
-rw-r--r--multimedia/cclive/Makefile4
-rw-r--r--multimedia/cclive/files/patch-quvi81
2 files changed, 83 insertions, 2 deletions
diff --git a/multimedia/cclive/Makefile b/multimedia/cclive/Makefile
index f7f05425884c..b5e7850cf371 100644
--- a/multimedia/cclive/Makefile
+++ b/multimedia/cclive/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cclive
PORTVERSION= 0.7.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia net
MASTER_SITES= SF/${PORTNAME}/0.7 \
GOOGLE_CODE
@@ -18,7 +18,7 @@ COMMENT= Lightweight command line video extraction tool
LIB_DEPENDS= boost_system.4:${PORTSDIR}/devel/boost-libs \
curl.6:${PORTSDIR}/ftp/curl \
pcre.0:${PORTSDIR}/devel/pcre \
- quvi.5:${PORTSDIR}/multimedia/quvi
+ quvi.6:${PORTSDIR}/multimedia/quvi
MAN1= cclive.1
PLIST_FILES= bin/cclive
diff --git a/multimedia/cclive/files/patch-quvi b/multimedia/cclive/files/patch-quvi
new file mode 100644
index 000000000000..2bb7169e7d77
--- /dev/null
+++ b/multimedia/cclive/files/patch-quvi
@@ -0,0 +1,81 @@
+--- include/quvicpp/quvicpp.h.orig 2011-03-15 18:17:23.000000000 +0800
++++ include/quvicpp/quvicpp.h 2011-06-25 07:00:00.000000000 +0800
+@@ -60,12 +60,10 @@
+ void verify (const bool);
+ void shortened (const bool);
+ void statusfunc (quvi_callback_status);
+- void writefunc (quvi_callback_write);
+ private:
+ void _swap (const options&);
+ private:
+ quvi_callback_status _statusfunc;
+- quvi_callback_write _writefunc;
+ std::string _format;
+ bool _verify;
+ bool _shortened;
+--- src/quvicpp/link.cpp.orig 2011-03-15 18:17:23.000000000 +0800
++++ src/quvicpp/link.cpp 2011-06-25 07:00:00.000000000 +0800
+@@ -36,7 +36,7 @@
+ dst = tmp; \
+ } while (0)
+ _wrap(QUVIPROP_VIDEOURL, _url, char*);
+- _wrap(QUVIPROP_VIDEOFILECONTENTTYPE, _contentType, char*);
++ _wrap(QUVIPROP_MEDIACONTENTTYPE, _contentType, char*);
+ _wrap(QUVIPROP_VIDEOFILESUFFIX, _suffix, char*);
+ _wrap(QUVIPROP_VIDEOFILELENGTH, _length, double);
+ #undef _wrap
+--- src/quvicpp/options.cpp.orig 2011-03-15 18:17:23.000000000 +0800
++++ src/quvicpp/options.cpp 2011-06-25 07:00:00.000000000 +0800
+@@ -25,7 +25,6 @@
+
+ options::options ()
+ : _statusfunc(NULL),
+- _writefunc(NULL),
+ _format("default"),
+ _verify(true),
+ _shortened(true)
+@@ -35,7 +34,6 @@
+
+ options::options (const options& opts)
+ : _statusfunc(NULL),
+- _writefunc(NULL),
+ _format("default"),
+ _verify(true),
+ _shortened(true)
+@@ -58,7 +56,6 @@
+ options::~options ()
+ {
+ _statusfunc = NULL;
+- _writefunc = NULL;
+ }
+
+ // Swap.
+@@ -70,7 +67,6 @@
+ _verify = qo._verify;
+ _shortened = qo._shortened;
+ _statusfunc = qo._statusfunc;
+- _writefunc = qo._writefunc;
+ }
+
+ // Set.
+@@ -91,10 +87,6 @@
+ {
+ _statusfunc = cb;
+ }
+-void options::writefunc (quvi_callback_write cb)
+-{
+- _writefunc = cb;
+-}
+
+ } // End namespace.
+
+--- src/quvicpp/query.cpp.orig 2011-03-15 18:17:23.000000000 +0800
++++ src/quvicpp/query.cpp 2011-06-25 07:00:00.000000000 +0800
+@@ -100,7 +100,6 @@
+ quvi_setopt(_quvi, QUVIOPT_FORMAT, opts._format.c_str());
+
+ quvi_setopt(_quvi, QUVIOPT_STATUSFUNCTION, opts._statusfunc);
+- quvi_setopt(_quvi, QUVIOPT_WRITEFUNCTION, opts._writefunc);
+ #ifdef _0
+ quvi_setopt(_quvi, QUVIOPT_NOVERIFY, opts._verify ? 1L:0L);
+ #endif