aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-12-22 18:59:48 +0800
committerkoobs <koobs@FreeBSD.org>2014-12-22 18:59:48 +0800
commitf815875498886e461c8d22a03fb46645f360233c (patch)
tree834ce23bb50f5843cd39446c8734f4ed462aead2
parentefc06ba4878d949f3ba858f4a65e8611010165ce (diff)
downloadfreebsd-ports-gnome-f815875498886e461c8d22a03fb46645f360233c.tar.gz
freebsd-ports-gnome-f815875498886e461c8d22a03fb46645f360233c.tar.zst
freebsd-ports-gnome-f815875498886e461c8d22a03fb46645f360233c.zip
[NEW] devel/py-future: Clean single-source support for Python 3 and 2
future is the missing compatibility layer between Python 2 and Python 3. It allows you to use a single, clean Python 3.x-compatible codebase to support both Python 2 and Python 3 with minimal overhead. WWW: https://python-future.org/ PR: 193094 Submitted by: Muhammad Moinur Rahman <5u623l20 at gmail com> (with changes)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-future/Makefile22
-rw-r--r--devel/py-future/distinfo2
-rw-r--r--devel/py-future/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7596410f8561..48bc32f7c5b5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3742,6 +3742,7 @@
SUBDIR += py-fudge
SUBDIR += py-funcparserlib
SUBDIR += py-fusefs
+ SUBDIR += py-future
SUBDIR += py-futures
SUBDIR += py-game
SUBDIR += py-gamin
diff --git a/devel/py-future/Makefile b/devel/py-future/Makefile
new file mode 100644
index 000000000000..04eb3c4a0423
--- /dev/null
+++ b/devel/py-future/Makefile
@@ -0,0 +1,22 @@
+# Created by: Muhammad Moinur Rahman<5u623l20@gmail.com>
+# $FreeBSD$
+
+PORTNAME= future
+PORTVERSION= 0.14.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Clean single-source support for Python 3 and 2
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/devel/py-future/distinfo b/devel/py-future/distinfo
new file mode 100644
index 000000000000..4aeac6ea0936
--- /dev/null
+++ b/devel/py-future/distinfo
@@ -0,0 +1,2 @@
+SHA256 (future-0.14.3.tar.gz) = 62857d51881d97dd5492b9295b9f51d92108a52a4c88e2c40054c1d3e5995be9
+SIZE (future-0.14.3.tar.gz) = 1485390
diff --git a/devel/py-future/pkg-descr b/devel/py-future/pkg-descr
new file mode 100644
index 000000000000..5f900133dc23
--- /dev/null
+++ b/devel/py-future/pkg-descr
@@ -0,0 +1,6 @@
+future is the missing compatibility layer between Python 2 and Python 3.
+
+It allows you to use a single, clean Python 3.x-compatible codebase to
+support both Python 2 and Python 3 with minimal overhead.
+
+WWW: https://python-future.org/