aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-06-27 17:11:05 +0800
committernovel <novel@FreeBSD.org>2006-06-27 17:11:05 +0800
commitf842b48eb2d57ff148f16d49dc26973d4df19e92 (patch)
treea5670546a15725f35d8aa6fae94e466fd6db91d6
parent6144e88d9282687ed0a3277ffab221f36a6cfe44 (diff)
downloadfreebsd-ports-gnome-f842b48eb2d57ff148f16d49dc26973d4df19e92.tar.gz
freebsd-ports-gnome-f842b48eb2d57ff148f16d49dc26973d4df19e92.tar.zst
freebsd-ports-gnome-f842b48eb2d57ff148f16d49dc26973d4df19e92.zip
Date_Holidays helps you calculating the dates and titles of holidays
and other special celebrations. The calculation is driver-based so it is easy to add new drivers that calculate a country's holidays. The methods of the class can be used to get a holiday's date and title in various languages. WWW: http://pear.php.net/package/Date_Holidays PR: ports/99069 Submitted by: Thomas Abthorpe <thomas@goodking.ca>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-Date_Holidays/Makefile78
-rw-r--r--devel/pear-Date_Holidays/distinfo3
-rw-r--r--devel/pear-Date_Holidays/pkg-descr7
4 files changed, 89 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 34e830c9fbb0..d7c0bd72e294 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1393,6 +1393,7 @@
SUBDIR += pear-Console_Getargs
SUBDIR += pear-Console_Table
SUBDIR += pear-Date
+ SUBDIR += pear-Date_Holidays
SUBDIR += pear-Event_Dispatcher
SUBDIR += pear-FSM
SUBDIR += pear-HTML_BBCodeParser
diff --git a/devel/pear-Date_Holidays/Makefile b/devel/pear-Date_Holidays/Makefile
new file mode 100644
index 000000000000..cc537ba47434
--- /dev/null
+++ b/devel/pear-Date_Holidays/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: pear-Date_Holidays
+# Date created: 2006-06-16
+# Whom: Thomas Abthorpe <thomas@goodking.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Date_Holidays
+PORTVERSION= 0.16.0
+CATEGORIES= devel www pear
+
+MAINTAINER= thomas@goodking.ca
+COMMENT= PEAR driver based class to calculate holidays
+
+BUILD_DEPENDS= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date \
+ ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
+ ${PEARDIR}/Console/Getargs.php:${PORTSDIR}/devel/pear-Console_Getargs
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Date
+FILES= Holidays.php \
+ Holidays/Driver/Christian.php \
+ Holidays/Driver/Composite.php \
+ Holidays/Driver/Germany.php \
+ Holidays/Driver/Jewish.php \
+ Holidays/Driver/PHPdotNet.php \
+ Holidays/Driver/Sweden.php \
+ Holidays/Driver/UNO.php \
+ Holidays/Driver/USA.php \
+ Holidays/Filter/Germany/BadenWuerttemberg.php \
+ Holidays/Filter/Germany/Bavaria.php \
+ Holidays/Filter/Germany/Berlin.php \
+ Holidays/Filter/Germany/Brandenburg.php \
+ Holidays/Filter/Germany/Bremen.php \
+ Holidays/Filter/Germany/Hamburg.php \
+ Holidays/Filter/Germany/Hesse.php \
+ Holidays/Filter/Germany/LowerSaxony.php \
+ Holidays/Filter/Germany/MecklenburgWesternPomerania.php \
+ Holidays/Filter/Germany/NorthRhineWestphalia.php \
+ Holidays/Filter/Germany/Official.php \
+ Holidays/Filter/Germany/RhinelandPalatinate.php \
+ Holidays/Filter/Germany/Saarland.php \
+ Holidays/Filter/Germany/Saxony.php \
+ Holidays/Filter/Germany/SaxonyAnhalt.php \
+ Holidays/Filter/Germany/SchleswigHolstein.php \
+ Holidays/Filter/Germany/Thuringia.php \
+ Holidays/Filter/Blacklist.php \
+ Holidays/Filter/Composite.php \
+ Holidays/Filter/Whitelist.php \
+ Holidays/Driver.php \
+ Holidays/Filter.php \
+ Holidays/Holiday.php
+EXAMPLES= addingTranslations.php languagefile-with-properties.xml \
+ creating_drivers.php usingCompositeDriver.php \
+ fetchingInstalledDrivers.php usingStandaloneDriver.php
+TESTS= AllTests.php \
+ Date_Holidays_Driver_Christian_TestSuite.php \
+ Date_Holidays_Driver_Germany_TestSuite.php \
+ Date_Holidays_Driver_Jewish_TestSuite.php \
+ Date_Holidays_Driver_PHPdotNet_TestSuite.php \
+ Date_Holidays_Driver_Sweden_TestSuite.php \
+ Date_Holidays_Driver_TestSuite.php \
+ Date_Holidays_Driver_UNO_TestSuite.php \
+ Date_Holidays_Driver_USA_TestSuite.php \
+ Date_Holidays_TestSuite.php \
+ Example.php
+
+LATEST_LINK= pear-Date_Holidays
+OPTIONS= PEAR_CONSOLE_GETARGS "devel/pear-Console_Getargs" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(PEAR_CONSOLE_GETARGS) || defined(WITH_PEAR_CONSOLE_GETARGS)
+BUILD_DEPENDS+=${PEARDIR}/Console/Getargs.php:${PORTSDIR}/devel/pear-Console_Getargs
+.endif
+
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Date_Holidays/distinfo b/devel/pear-Date_Holidays/distinfo
new file mode 100644
index 000000000000..40cbf1ec2b19
--- /dev/null
+++ b/devel/pear-Date_Holidays/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Date_Holidays-0.16.0.tgz) = 6c7ea772a822ab00a1243769238798d0
+SHA256 (PEAR/Date_Holidays-0.16.0.tgz) = db39a19237373ad56d285d6e8e754f75851af2379b5de20eb09667df47813093
+SIZE (PEAR/Date_Holidays-0.16.0.tgz) = 54864
diff --git a/devel/pear-Date_Holidays/pkg-descr b/devel/pear-Date_Holidays/pkg-descr
new file mode 100644
index 000000000000..59bcf383010b
--- /dev/null
+++ b/devel/pear-Date_Holidays/pkg-descr
@@ -0,0 +1,7 @@
+Date_Holidays helps you calculating the dates and titles of holidays
+and other special celebrations. The calculation is driver-based so
+it is easy to add new drivers that calculate a country's holidays.
+The methods of the class can be used to get a holiday's date and
+title in various languages.
+
+WWW: http://pear.php.net/package/Date_Holidays