aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2004-01-11 23:54:05 +0800
committernobutaka <nobutaka@FreeBSD.org>2004-01-11 23:54:05 +0800
commitf85e865a838beb0e4630619216ac84e4e2a50914 (patch)
tree8c2fcb29127b3d39cc0119b05771e16b85a58dd9
parentdbd8f8220039f40795830d12838f9596f9ea1f96 (diff)
downloadfreebsd-ports-gnome-f85e865a838beb0e4630619216ac84e4e2a50914.tar.gz
freebsd-ports-gnome-f85e865a838beb0e4630619216ac84e4e2a50914.tar.zst
freebsd-ports-gnome-f85e865a838beb0e4630619216ac84e4e2a50914.zip
Correct default search path of RealAudio and RealVideo codecs.
PR: ports/61062 Submitted by: Sascha Blank <sblank@tiscali.de>
-rw-r--r--multimedia/libxine/Makefile1
-rw-r--r--multimedia/libxine/files/patch-src:libreal:xine_decoder.c33
2 files changed, 34 insertions, 0 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 917dca7b1b0c..baa43f0992c1 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xine
PORTVERSION= 1.0.r3
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/libxine/files/patch-src:libreal:xine_decoder.c b/multimedia/libxine/files/patch-src:libreal:xine_decoder.c
new file mode 100644
index 000000000000..47ff6e57de68
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:libreal:xine_decoder.c
@@ -0,0 +1,33 @@
+--- src/libreal/xine_decoder.c.orig Mon Dec 15 07:13:24 2003
++++ src/libreal/xine_decoder.c Mon Jan 12 00:04:26 2004
+@@ -589,24 +589,15 @@
+
+ /* try some auto-detection */
+
+- if (!stat ("/usr/local/RealPlayer8/Codecs/drv3.so.6.0", &s))
++ if (!stat ("/usr/local/lib/RealPlayer8/Codecs/drv3.so.6.0", &s))
+ config->update_string (config, "codec.real_codecs_path",
+- "/usr/local/RealPlayer8/Codecs");
+- if (!stat ("/usr/RealPlayer8/Codecs/drv3.so.6.0", &s))
++ "/usr/local/lib/RealPlayer8/Codecs");
++ if (!stat ("/usr/local/lib/RealPlayer9/users/Real/Codecs/drv3.so.6.0", &s))
+ config->update_string (config, "codec.real_codecs_path",
+- "/usr/RealPlayer8/Codecs");
+- if (!stat ("/usr/lib/RealPlayer8/Codecs/drv3.so.6.0", &s))
++ "/usr/local/lib/RealPlayer9/users/Real/Codecs");
++ if (!stat ("/usr/local/lib/win32/drv3.so.6.0", &s))
+ config->update_string (config, "codec.real_codecs_path",
+- "/usr/lib/RealPlayer8/Codecs");
+- if (!stat ("/opt/RealPlayer8/Codecs/drv3.so.6.0", &s))
+- config->update_string (config, "codec.real_codecs_path",
+- "/opt/RealPlayer8/Codecs");
+- if (!stat ("/usr/lib/RealPlayer9/users/Real/Codecs/drv3.so.6.0", &s))
+- config->update_string (config, "codec.real_codecs_path",
+- "/usr/lib/RealPlayer9/users/Real/Codecs");
+- if (!stat ("/usr/lib/win32/drv3.so.6.0", &s))
+- config->update_string (config, "codec.real_codecs_path",
+- "/usr/lib/win32");
++ "/usr/local/lib/win32");
+ }
+
+ lprintf ("real codec path : %s\n", real_codec_path);