aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2011-01-28 18:26:36 +0800
committerbsam <bsam@FreeBSD.org>2011-01-28 18:26:36 +0800
commitf8d0a09bd5dc828433a31635aafc78f98e90928a (patch)
tree7a004ad68c362b6ccf4bd350549ba92e11c073f1
parent8cada57b993cb75d36ee6d2974c85563e967b9ed (diff)
downloadfreebsd-ports-gnome-f8d0a09bd5dc828433a31635aafc78f98e90928a.tar.gz
freebsd-ports-gnome-f8d0a09bd5dc828433a31635aafc78f98e90928a.tar.zst
freebsd-ports-gnome-f8d0a09bd5dc828433a31635aafc78f98e90928a.zip
This is a no-op change, just "make update-patches" (new patches pending).
Feature safe: yes
-rw-r--r--comms/gammu/files/patch-CMakeLists.txt6
-rw-r--r--comms/gammu/files/patch-bluetooth14
-rw-r--r--comms/gammu/files/patch-common.device.devfunc.c8
-rw-r--r--comms/gammu/files/patch-common.service.gsmmisc.c6
4 files changed, 17 insertions, 17 deletions
diff --git a/comms/gammu/files/patch-CMakeLists.txt b/comms/gammu/files/patch-CMakeLists.txt
index 3e7fdfc4e1e8..69272e75ded4 100644
--- a/comms/gammu/files/patch-CMakeLists.txt
+++ b/comms/gammu/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2009-02-25 19:46:07.000000000 +0300
-+++ CMakeLists.txt 2009-03-11 13:04:48.000000000 +0300
-@@ -547,7 +547,7 @@
+--- CMakeLists.txt.orig 2010-07-12 15:51:05.000000000 +0400
++++ CMakeLists.txt 2011-01-28 13:21:17.923548597 +0300
+@@ -593,7 +593,7 @@ mark_as_advanced (INSTALL_LOC_DIR)
set (INSTALL_DOC_DIR "share/doc/gammu" CACHE STRING "Path for documentation installation")
mark_as_advanced (INSTALL_DOC_DIR)
diff --git a/comms/gammu/files/patch-bluetooth b/comms/gammu/files/patch-bluetooth
index d1a3f820c11b..cbdcf14b82d3 100644
--- a/comms/gammu/files/patch-bluetooth
+++ b/comms/gammu/files/patch-bluetooth
@@ -1,8 +1,8 @@
---- libgammu/device/bluetoth/bluez.c.orig 2007-03-10 19:47:59.000000000 +0300
-+++ libgammu/device/bluetoth/bluez.c 2007-06-29 20:00:48.000000000 +0400
+--- libgammu/device/bluetoth/bluez.c.orig 2010-07-12 15:51:05.000000000 +0400
++++ libgammu/device/bluetoth/bluez.c 2011-01-28 13:21:17.936545967 +0300
@@ -23,6 +23,8 @@
#ifdef GSM_ENABLE_BLUETOOTHDEVICE
- #ifdef GSM_ENABLE_BLUEZ
+ #ifdef BLUEZ_FOUND
+#define BDADDR_ANY NG_HCI_BDADDR_ANY
+
@@ -31,7 +31,7 @@
bdaddr_t bdaddr;
int fd;
-@@ -53,15 +51,15 @@
+@@ -53,15 +51,15 @@ GSM_Error bluetooth_connect(GSM_StateMac
smprintf(s, "Connecting to RF channel %i\n",port);
@@ -50,8 +50,8 @@
+ laddr.rfcomm_channel = 0;
if (bind(fd, (struct sockaddr *)&laddr, sizeof(laddr)) < 0) {
- dbgprintf("Can't bind socket\n");
-@@ -70,9 +68,9 @@
+ smprintf(s, "Can't bind socket (%d, %s)\n", errno, strerror(errno));
+@@ -70,9 +68,9 @@ GSM_Error bluetooth_connect(GSM_StateMac
}
str2ba(device, &bdaddr);
@@ -63,4 +63,4 @@
+ raddr.rfcomm_channel = port;
if (connect(fd, (struct sockaddr *)&raddr, sizeof(raddr)) < 0) {
- dbgprintf("Can't connect\n");
+ smprintf(s, "Can't connect (%d, %s)\n", errno, strerror(errno));
diff --git a/comms/gammu/files/patch-common.device.devfunc.c b/comms/gammu/files/patch-common.device.devfunc.c
index cb474f2af445..9de9b4827fe5 100644
--- a/comms/gammu/files/patch-common.device.devfunc.c
+++ b/comms/gammu/files/patch-common.device.devfunc.c
@@ -1,11 +1,11 @@
---- libgammu/device/devfunc.c.orig Fri Feb 23 23:50:01 2007
-+++ libgammu/device/devfunc.c Tue Apr 10 23:46:39 2007
-@@ -19,6 +19,8 @@
+--- libgammu/device/devfunc.c.orig 2010-07-12 15:51:05.000000000 +0400
++++ libgammu/device/devfunc.c 2011-01-28 13:21:17.938543134 +0300
+@@ -15,6 +15,8 @@
#include <string.h>
#include <fcntl.h>
#include <stdlib.h>
+#include <sys/stat.h>
+#include <sys/socket.h>
#ifdef WIN32
+ # include <winsock2.h>
# include <io.h>
- #else
diff --git a/comms/gammu/files/patch-common.service.gsmmisc.c b/comms/gammu/files/patch-common.service.gsmmisc.c
index 8e9d933cdfc2..2654e3a8ba91 100644
--- a/comms/gammu/files/patch-common.service.gsmmisc.c
+++ b/comms/gammu/files/patch-common.service.gsmmisc.c
@@ -1,6 +1,6 @@
---- libgammu/service/gsmmisc.c.orig Fri Dec 30 18:18:47 2005
-+++ libgammu/service/gsmmisc.c Fri Dec 30 18:19:07 2005
-@@ -3,6 +3,7 @@
+--- libgammu/service/gsmmisc.c.orig 2010-07-12 15:51:05.000000000 +0400
++++ libgammu/service/gsmmisc.c 2011-01-28 13:21:17.940543932 +0300
+@@ -5,6 +5,7 @@
#include <string.h>
#include <stdlib.h>
#include <sys/stat.h>