aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2009-10-24 10:11:04 +0800
committerache <ache@FreeBSD.org>2009-10-24 10:11:04 +0800
commitf8e2bd1f29b7d7660ec2bce10f77fc148f541f46 (patch)
tree44f2d97c264ef50923b4aeb8fa9cdf371c713019
parentcf9ab9b5c55fd64c36b8f175012fcb517e3dde8e (diff)
downloadfreebsd-ports-gnome-f8e2bd1f29b7d7660ec2bce10f77fc148f541f46.tar.gz
freebsd-ports-gnome-f8e2bd1f29b7d7660ec2bce10f77fc148f541f46.tar.zst
freebsd-ports-gnome-f8e2bd1f29b7d7660ec2bce10f77fc148f541f46.zip
Add partial OPENLDAP support
Submitted by: Gerhard Schmidt <estartu@augusta.de>
-rw-r--r--mail/milter-greylist/Makefile5
-rw-r--r--mail/milter-greylist/files/patch-ldapcheck.c25
2 files changed, 30 insertions, 0 deletions
diff --git a/mail/milter-greylist/Makefile b/mail/milter-greylist/Makefile
index f7950d352e69..b5b5f9ac4ea6 100644
--- a/mail/milter-greylist/Makefile
+++ b/mail/milter-greylist/Makefile
@@ -22,6 +22,7 @@ OPTIONS= MANPAGES "Install manpages" on\
LIBSPF2 "Include SPF support" off\
GEOIP "Include GeoIP support" off\
CURL "Include curl support" off\
+ OPENLDAP "Include OpenLDAP support" off\
POSTFIX "Use Postfix instead of Sendmail" off
.include <bsd.port.pre.mk>
@@ -57,6 +58,10 @@ CONFIGURE_ARGS+= --with-libGeoIP=${LOCALBASE}
BUILD_DEPENDS+= curl>=7.18:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-libcurl=${LOCALBASE}
.endif
+.if defined(WITH_OPENLDAP)
+USE_OPENLDAP=yes
+CONFIGURE_ARGS+= --with-openldap
+.endif
.if defined(WITH_POSTFIX)
CONFIGURE_ARGS+= --enable-postfix
.else
diff --git a/mail/milter-greylist/files/patch-ldapcheck.c b/mail/milter-greylist/files/patch-ldapcheck.c
new file mode 100644
index 000000000000..89f6bbc6b3ad
--- /dev/null
+++ b/mail/milter-greylist/files/patch-ldapcheck.c
@@ -0,0 +1,25 @@
+--- ldapcheck.c.orig 2009-04-09 05:26:46.000000000 +0200
++++ ldapcheck.c 2009-10-23 23:57:42.000000000 +0200
+@@ -58,6 +58,22 @@
+ #include "prop.h"
+ #include "ldapcheck.h"
+
++#ifndef SIMPLEQ_HEAD
++# define SIMPLEQ_HEAD STAILQ_HEAD
++# define SIMPLEQ_HEAD_INITIALIZER STAILQ_HEAD_INITIALIZER
++# define SIMPLEQ_ENTRY STAILQ_ENTRY
++# define SIMPLEQ_INIT STAILQ_INIT
++# define SIMPLEQ_INSERT_HEAD STAILQ_INSERT_HEAD
++# define SIMPLEQ_INSERT_TAIL STAILQ_INSERT_TAIL
++# define SIMPLEQ_INSERT_AFTER STAILQ_INSERT_AFTER
++# define SIMPLEQ_REMOVE_HEAD STAILQ_REMOVE_HEAD
++# define SIMPLEQ_FOREACH STAILQ_FOREACH
++# define SIMPLEQ_EMPTY STAILQ_EMPTY
++# define SIMPLEQ_FIRST STAILQ_FIRST
++# define SIMPLEQ_NEXT STAILQ_NEXT
++# define SIMPLEQ_REMOVE STAILQ_REMOVE
++#endif
++
+ struct ldapconf_entry {
+ char *lc_url;
+ char *lc_dn;