aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-15 12:39:21 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-15 12:39:21 +0800
commitf90c102a5e0cd19f570fc5a8f22a34186985e1c3 (patch)
treea65551f1b889ab6b555e2c41fb3d3dcfd07f5b51
parentb1aeee08638f6bbe1e573f8b1f55c8b8a4fdd03f (diff)
downloadfreebsd-ports-gnome-f90c102a5e0cd19f570fc5a8f22a34186985e1c3.tar.gz
freebsd-ports-gnome-f90c102a5e0cd19f570fc5a8f22a34186985e1c3.tar.zst
freebsd-ports-gnome-f90c102a5e0cd19f570fc5a8f22a34186985e1c3.zip
- New option LDAP_PORT
-rw-r--r--mail/sendmail-old/Makefile5
-rw-r--r--mail/sendmail811/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/mail/sendmail-old/Makefile b/mail/sendmail-old/Makefile
index 90b3b62b1e82..9b40660c6737 100644
--- a/mail/sendmail-old/Makefile
+++ b/mail/sendmail-old/Makefile
@@ -26,6 +26,7 @@ MAN1= mailq.1 newaliases.1 vacation.1
MAN5= aliases.5
MAN8= sendmail.8 mailstats.8 makemap.8 praliases.8 smrsh.8 \
mail.local.8 rmail.8
+LDAP_PORT?= net/openldap20-client
# Options to define Features:
# SENDMAIL_WITHOUT_IPV6=yes
@@ -37,8 +38,8 @@ MAN8= sendmail.8 mailstats.8 makemap.8 praliases.8 smrsh.8 \
.if defined(SENDMAIL_WITH_LDAP)
PKGNAMESUFFIX?= -ldap
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
-LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap20-client
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
+LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
.endif
.if defined(SENDMAIL_WITH_SASL)
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
diff --git a/mail/sendmail811/Makefile b/mail/sendmail811/Makefile
index 90b3b62b1e82..9b40660c6737 100644
--- a/mail/sendmail811/Makefile
+++ b/mail/sendmail811/Makefile
@@ -26,6 +26,7 @@ MAN1= mailq.1 newaliases.1 vacation.1
MAN5= aliases.5
MAN8= sendmail.8 mailstats.8 makemap.8 praliases.8 smrsh.8 \
mail.local.8 rmail.8
+LDAP_PORT?= net/openldap20-client
# Options to define Features:
# SENDMAIL_WITHOUT_IPV6=yes
@@ -37,8 +38,8 @@ MAN8= sendmail.8 mailstats.8 makemap.8 praliases.8 smrsh.8 \
.if defined(SENDMAIL_WITH_LDAP)
PKGNAMESUFFIX?= -ldap
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
-LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap20-client
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
+LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
.endif
.if defined(SENDMAIL_WITH_SASL)
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl