aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-26 20:35:49 +0800
committerMartin Wilke <miwi@FreeBSD.org>2009-03-26 20:35:49 +0800
commitf9552dfba2c4b4a9562a9212a0f5bf9161223bc0 (patch)
treee7a60cd89e47b928cc70481595626091d49326d1
parentdb85abd1c20af1dcd48cb3d2961ec650743e18f2 (diff)
downloadfreebsd-ports-gnome-f9552dfba2c4b4a9562a9212a0f5bf9161223bc0.tar.gz
freebsd-ports-gnome-f9552dfba2c4b4a9562a9212a0f5bf9161223bc0.tar.zst
freebsd-ports-gnome-f9552dfba2c4b4a9562a9212a0f5bf9161223bc0.zip
A simple REST client for Python, inspired by the microframework
(Camping, Sinatra) style of specifying actions: get, put, post, delete. WWW: http://py-restclient.e-engura.org/ PR: ports/133080 Submitted by: Wen Heping <wenheping at gmail.com>
-rw-r--r--www/Makefile1
-rw-r--r--www/py-py-restclient/Makefile22
-rw-r--r--www/py-py-restclient/distinfo3
-rw-r--r--www/py-py-restclient/pkg-descr5
-rw-r--r--www/py-py-restclient/pkg-plist2
5 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9ea0736a4d68..38df4ee27b8e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1269,6 +1269,7 @@
SUBDIR += py-postmarkup
SUBDIR += py-prewikka
SUBDIR += py-pullparser
+ SUBDIR += py-py-restclient
SUBDIR += py-pylons
SUBDIR += py-pyquery
SUBDIR += py-pysearch
diff --git a/www/py-py-restclient/Makefile b/www/py-py-restclient/Makefile
new file mode 100644
index 000000000000..c1a808db3095
--- /dev/null
+++ b/www/py-py-restclient/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-restclient
+# Date created: 26 March, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= py-restclient
+PORTVERSION= 1.2.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Python REST Client
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/httplib2/__init__.py:${PORTSDIR}/www/py-httplib2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/www/py-py-restclient/distinfo b/www/py-py-restclient/distinfo
new file mode 100644
index 000000000000..3e22589e0eb7
--- /dev/null
+++ b/www/py-py-restclient/distinfo
@@ -0,0 +1,3 @@
+MD5 (py-restclient-1.2.1.tar.gz) = f8c78267411173477cba7352cdeaac39
+SHA256 (py-restclient-1.2.1.tar.gz) = ff7fd3de8cf02f197215ad4c4ec0cd6ff33d828c76ad0b1728fcdc200e469a4b
+SIZE (py-restclient-1.2.1.tar.gz) = 19139
diff --git a/www/py-py-restclient/pkg-descr b/www/py-py-restclient/pkg-descr
new file mode 100644
index 000000000000..d52d1663c080
--- /dev/null
+++ b/www/py-py-restclient/pkg-descr
@@ -0,0 +1,5 @@
+A simple REST client for Python, inspired by the microframework
+(Camping, Sinatra) style of specifying actions: get, put, post,
+delete.
+
+WWW: http://py-restclient.e-engura.org/
diff --git a/www/py-py-restclient/pkg-plist b/www/py-py-restclient/pkg-plist
new file mode 100644
index 000000000000..601ec37b1f82
--- /dev/null
+++ b/www/py-py-restclient/pkg-plist
@@ -0,0 +1,2 @@
+bin/restcli
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%