aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-04-27 04:06:56 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2019-04-27 04:06:56 +0800
commitf96c634e7e1e2b29a007510e1e9a46a4a7415afd (patch)
treefa8cf3caeba8dee4e02d8b8acd8c77bb4bd75fb9
parentc348be382e2f9301aaaeb3ba4c6007972fec20d7 (diff)
downloadfreebsd-ports-gnome-f96c634e7e1e2b29a007510e1e9a46a4a7415afd.tar.gz
freebsd-ports-gnome-f96c634e7e1e2b29a007510e1e9a46a4a7415afd.tar.zst
freebsd-ports-gnome-f96c634e7e1e2b29a007510e1e9a46a4a7415afd.zip
New port: graphics/photoflare: Quick, simple but powerful cross-platform image editor
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/photoflare/Makefile24
-rw-r--r--graphics/photoflare/distinfo3
-rw-r--r--graphics/photoflare/files/patch-PhotoFlare.pro11
-rw-r--r--graphics/photoflare/pkg-descr10
-rw-r--r--graphics/photoflare/pkg-plist20
6 files changed, 69 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f9aec2800eef..1839798c0c5c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -742,6 +742,7 @@
SUBDIR += pgplot
SUBDIR += pho
SUBDIR += photivo
+ SUBDIR += photoflare
SUBDIR += photopc
SUBDIR += photoqt
SUBDIR += phototonic
diff --git a/graphics/photoflare/Makefile b/graphics/photoflare/Makefile
new file mode 100644
index 000000000000..5dfe9fcfdc1c
--- /dev/null
+++ b/graphics/photoflare/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= photoflare
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.5.8.1
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Quick, simple but powerful cross-platform image editor
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libGraphicsMagick++.so:graphics/GraphicsMagick
+
+USES= compiler:c++17-lang desktop-file-utils gl qmake qt:5 localbase pkgconfig
+USE_GITHUB= PhotoFlare
+USE_QT= core gui network printsupport widgets buildtools_build linguisttools_build
+USE_GL= gl
+
+CXXFLAGS+= `pkg-config --cflags GraphicsMagick++`
+LDFLAGS+= `pkg-config --libs GraphicsMagick++`
+
+.include <bsd.port.mk>
diff --git a/graphics/photoflare/distinfo b/graphics/photoflare/distinfo
new file mode 100644
index 000000000000..c8391173bc69
--- /dev/null
+++ b/graphics/photoflare/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556304236
+SHA256 (photoflare-photoflare-v1.5.8.1_GH0.tar.gz) = 125665512597fd5c3697b784aefcb7443141ff7a1af0641f48e382ab2634d038
+SIZE (photoflare-photoflare-v1.5.8.1_GH0.tar.gz) = 831309
diff --git a/graphics/photoflare/files/patch-PhotoFlare.pro b/graphics/photoflare/files/patch-PhotoFlare.pro
new file mode 100644
index 000000000000..db8b28457db2
--- /dev/null
+++ b/graphics/photoflare/files/patch-PhotoFlare.pro
@@ -0,0 +1,11 @@
+--- PhotoFlare.pro.orig 2019-04-26 18:57:02 UTC
++++ PhotoFlare.pro
+@@ -235,7 +235,7 @@ unix:!macx {
+ pixmaps.files = installers/deb/DEBIAN/usr/share/icons/hicolor/48x48/apps/photoflare.png
+ desktopentry.path = $${BASEDIR}$${PREFIX}/share/applications
+ desktopentry.files = installers/deb/DEBIAN/usr/share/applications/$${TARGET}.desktop
+- manpage.path = $${PREFIX}/share/man/man1/
++ manpage.path = $${PREFIX}/man/man1/
+ manpage.files = photoflare.1
+ appstream.path = $${PREFIX}/share/metainfo/
+ appstream.files = io.photoflare.photoflare.appdata.xml
diff --git a/graphics/photoflare/pkg-descr b/graphics/photoflare/pkg-descr
new file mode 100644
index 000000000000..b1599c000965
--- /dev/null
+++ b/graphics/photoflare/pkg-descr
@@ -0,0 +1,10 @@
+PhotoFlare is a multi-platform image editor with an aim to balance between
+powerful features and a simple easy to graphical user interface. PhotoFlare
+suits a wide variety of different tasks and users who value a more nimble
+workflow.
+
+PhotoFlare includes features such as simple painting brushes, basic image
+editing capabilities, image filters, colour adjustments and more advanced
+features such as Batch image processing.
+
+WWW: https://photoflare.io/
diff --git a/graphics/photoflare/pkg-plist b/graphics/photoflare/pkg-plist
new file mode 100644
index 000000000000..8ef377736aac
--- /dev/null
+++ b/graphics/photoflare/pkg-plist
@@ -0,0 +1,20 @@
+bin/photoflare
+man/man1/photoflare.1.gz
+share/applications/photoflare.desktop
+share/icons/hicolor/128x128/apps/photoflare.png
+share/icons/hicolor/16x16/apps/photoflare.png
+share/icons/hicolor/192x192/apps/photoflare.png
+share/icons/hicolor/22x22/apps/photoflare.png
+share/icons/hicolor/24x24/apps/photoflare.png
+share/icons/hicolor/256x256/apps/photoflare.png
+share/icons/hicolor/32x32/apps/photoflare.png
+share/icons/hicolor/48x48/apps/photoflare.png
+share/icons/hicolor/64x64/apps/photoflare.png
+share/metainfo/io.photoflare.photoflare.appdata.xml
+%%DATADIR%%/languages/cs.qm
+%%DATADIR%%/languages/de.qm
+%%DATADIR%%/languages/en.qm
+%%DATADIR%%/languages/fr.qm
+%%DATADIR%%/languages/nl.qm
+%%DATADIR%%/languages/zh_TW.qm
+share/pixmaps/photoflare.png