aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-03-15 14:05:43 +0800
committeryuri <yuri@FreeBSD.org>2019-03-15 14:05:43 +0800
commitfac7a503ac0ee662ef6bb3f2fe4860d68c3d98b5 (patch)
tree91fe56ae21da3d404dab857e39aa382f4075877c
parent12d796db8facd94304624b22414c72f8e79e933a (diff)
downloadfreebsd-ports-gnome-fac7a503ac0ee662ef6bb3f2fe4860d68c3d98b5.tar.gz
freebsd-ports-gnome-fac7a503ac0ee662ef6bb3f2fe4860d68c3d98b5.tar.zst
freebsd-ports-gnome-fac7a503ac0ee662ef6bb3f2fe4860d68c3d98b5.zip
New port: security/mkp224o: Vanity address generator for tor onion v3 (ed25519) hidden services
-rw-r--r--security/Makefile1
-rw-r--r--security/mkp224o/Makefile26
-rw-r--r--security/mkp224o/distinfo3
-rw-r--r--security/mkp224o/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c72de9698825..204550a45d0a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -417,6 +417,7 @@
SUBDIR += mhash
SUBDIR += mindterm-binary
SUBDIR += minisign
+ SUBDIR += mkp224o
SUBDIR += modsecurity3
SUBDIR += monkeysphere
SUBDIR += morphis
diff --git a/security/mkp224o/Makefile b/security/mkp224o/Makefile
new file mode 100644
index 000000000000..8f91f2813f2a
--- /dev/null
+++ b/security/mkp224o/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= mkp224o
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.0
+CATEGORIES= security
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Vanity address generator for tor onion v3 (ed25519) hidden services
+
+LICENSE= CC0-1.0
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+LIB_DEPENDS= libsodium.so:security/libsodium
+
+USES= autoreconf gmake localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= cathugger
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/mkp224o/distinfo b/security/mkp224o/distinfo
new file mode 100644
index 000000000000..624a72c45170
--- /dev/null
+++ b/security/mkp224o/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1552629473
+SHA256 (cathugger-mkp224o-v1.2.0_GH0.tar.gz) = 7ee409017279bec4be1ce510d1d18fa49cf1676c3eeb4ea569790a35f7388068
+SIZE (cathugger-mkp224o-v1.2.0_GH0.tar.gz) = 1518582
diff --git a/security/mkp224o/pkg-descr b/security/mkp224o/pkg-descr
new file mode 100644
index 000000000000..9a9db059a625
--- /dev/null
+++ b/security/mkp224o/pkg-descr
@@ -0,0 +1,6 @@
+mkp224o is a vanity address generator for ed25519 onion services.
+
+This tool generates vanity ed25519 (hidden service version 3, formely known as
+proposal 224) onion addresses.
+
+WWW: https://github.com/cathugger/mkp224o