aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2014-12-25 23:49:49 +0800
committerkmoore <kmoore@FreeBSD.org>2014-12-25 23:49:49 +0800
commitfae73aaabc4bce1fd86dbd3b3dc0fd10c2bf2f4b (patch)
tree65d9194ef2af6ac01aa19d4587e8902a320ffcf6
parentefe6eebdec552fdf3de0949312332c2944590c19 (diff)
downloadfreebsd-ports-gnome-fae73aaabc4bce1fd86dbd3b3dc0fd10c2bf2f4b.tar.gz
freebsd-ports-gnome-fae73aaabc4bce1fd86dbd3b3dc0fd10c2bf2f4b.tar.zst
freebsd-ports-gnome-fae73aaabc4bce1fd86dbd3b3dc0fd10c2bf2f4b.zip
- Fix a bug using shell built-in which command
- Add fallback when using installer 'beadm' command - Bump PORTREV
-rw-r--r--sysutils/grub2-pcbsd/Makefile2
-rw-r--r--sysutils/grub2-pcbsd/files/10_ktrueos.in11
2 files changed, 10 insertions, 3 deletions
diff --git a/sysutils/grub2-pcbsd/Makefile b/sysutils/grub2-pcbsd/Makefile
index 4cdf88874881..d555aad5377e 100644
--- a/sysutils/grub2-pcbsd/Makefile
+++ b/sysutils/grub2-pcbsd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grub2-pcbsd
PORTVERSION= 2.02p
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= sysutils
MASTER_SITES= http://www.pcbsd.org/~kris/software/ \
ftp://ftp.pcbsd.org/pub/software/
diff --git a/sysutils/grub2-pcbsd/files/10_ktrueos.in b/sysutils/grub2-pcbsd/files/10_ktrueos.in
index b3bdfcfc9d09..8f275d1f9be7 100644
--- a/sysutils/grub2-pcbsd/files/10_ktrueos.in
+++ b/sysutils/grub2-pcbsd/files/10_ktrueos.in
@@ -180,14 +180,21 @@ display_loaderopts()
detect_beadm()
{
- which -s beadm
+ /usr/bin/which -s beadm >/dev/null 2>/dev/null
if [ $? -ne 0 ] ; then return 0; fi
# Check if we are running from the installer and use its beadm
if [ -e "/root/beadm.install" ] ; then
BEADM="/root/beadm.install"
+
+ # Check if this is valid
+ testBE=`$BEADM list`
+ if [ -z "$testBE" ] ; then
+ # No BE's, lets switch back to regular mode
+ BEADM="`/usr/bin/which beadm`"
+ fi
else
- BEADM="`which beadm`"
+ BEADM="`/usr/bin/which beadm`"
fi
${BEADM} list >/dev/null 2>/dev/null