aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-08-29 00:27:09 +0800
committeradamw <adamw@FreeBSD.org>2015-08-29 00:27:09 +0800
commitfc63727499e183b0ed09a6bc9e25cb61ffb924a5 (patch)
tree70081ccdc50165a5c8be0b2fc42c6b393c2c1032
parent8b523867922ceeccb221d68c0f155a3bbb953219 (diff)
downloadfreebsd-ports-gnome-fc63727499e183b0ed09a6bc9e25cb61ffb924a5.tar.gz
freebsd-ports-gnome-fc63727499e183b0ed09a6bc9e25cb61ffb924a5.tar.zst
freebsd-ports-gnome-fc63727499e183b0ed09a6bc9e25cb61ffb924a5.zip
Use new _VARS option helpers. Still can't remove bsd.port.options.mk inclusion
though.
-rw-r--r--mail/dovecot2/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index 0a8abbf14ac3..b5fd878a0100 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -95,7 +95,6 @@ KQUEUE_CONFIGURE_ON= --with-ioloop=kqueue --with-notify=kqueue
LDAP_USE= OPENLDAP=yes
LDAP_CONFIGURE_WITH= ldap
-LDAP_RC_REQUIRE= slapd
LIBWRAP_CONFIGURE_WITH= libwrap
@@ -106,11 +105,9 @@ LZ4_LIB_DEPENDS= liblz4.so:${PORTSDIR}/archivers/liblz4
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_WITH= mysql
-MYSQL_RC_REQUIRE= mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
-PGSQL_RC_REQUIRE= postgresql
SOLR_CONFIGURE_WITH= solr
SOLR_BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
@@ -131,21 +128,21 @@ DOCS= AUTHORS COPYING COPYING.LGPL COPYING.MIT INSTALL NEWS TODO README
PORTDOCS= *
PORTEXAMPLES= *
-.include <bsd.port.options.mk>
-
-CPPFLAGS+= -I${LOCALBASE}/include -I${OPENSSLINC}
-LDFLAGS+= -L${LOCALBASE}/lib -I${OPENSSLLIB}
-
# Default requirement for dovecot rc script
_REQUIRE= LOGIN
-.for opt in ${PORT_OPTIONS}
-_REQUIRE+= ${${opt}_RC_REQUIRE}
-.endfor
+LDAP_VARS= _REQUIRE+=slapd
+MYSQL_VARS= _REQUIRE+=mysql
+PGSQL_VARS= _REQUIRE+=postgresql
+
+.include <bsd.port.options.mk>
SUB_LIST+= REQUIRE="${_REQUIRE}"
SUB_FILES+= pkg-message
+CPPFLAGS+= -I${LOCALBASE}/include -I${OPENSSLINC}
+LDFLAGS+= -L${LOCALBASE}/lib -I${OPENSSLLIB}
+
post-patch:
@${REINPLACE_CMD} -e 's,/etc/dovecot,${PREFIX}/etc/dovecot,g; \
s,sysconfdir=/etc,sysconfdir=${PREFIX}/etc,g' \